aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-07-11 18:14:27 +0800
committernovel <novel@FreeBSD.org>2006-07-11 18:14:27 +0800
commit4e4adfc84f89cdf458351f7a30a429ab6094b9fe (patch)
tree62556d60e9c84f52aa19c47b727939802079bf53 /textproc
parentaccd60cbcf4524d755dea4a553108c7050a30303 (diff)
downloadfreebsd-ports-gnome-4e4adfc84f89cdf458351f7a30a429ab6094b9fe.tar.gz
freebsd-ports-gnome-4e4adfc84f89cdf458351f7a30a429ab6094b9fe.tar.zst
freebsd-ports-gnome-4e4adfc84f89cdf458351f7a30a429ab6094b9fe.zip
This is a generalized API that allows a module that generates PDFs to
transparently target multiple backends without changing its code. WWW: http://search.cpan.org/dist/PDF-Writer/ PR: ports/100058 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-PDF-Writer/Makefile28
-rw-r--r--textproc/p5-PDF-Writer/distinfo3
-rw-r--r--textproc/p5-PDF-Writer/pkg-descr4
-rw-r--r--textproc/p5-PDF-Writer/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 58f2fad6b7ce..d65d363abe78 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -375,6 +375,7 @@
SUBDIR += p5-Number-Format
SUBDIR += p5-PDF-API2
SUBDIR += p5-PDF-Create
+ SUBDIR += p5-PDF-Writer
SUBDIR += p5-POE-Filter-XML
SUBDIR += p5-PPI
SUBDIR += p5-PPI-HTML
diff --git a/textproc/p5-PDF-Writer/Makefile b/textproc/p5-PDF-Writer/Makefile
new file mode 100644
index 000000000000..ba2648304e16
--- /dev/null
+++ b/textproc/p5-PDF-Writer/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-PDF-Writer
+# Date created: 2006-07-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PDF-Writer
+PORTVERSION= 0.06
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= PDF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= PDF writer abstraction layer
+
+PERL_MODBUILD= yes
+
+MAN3= PDF::Writer.3 PDF::Writer::pdfapi2.3 PDF::Writer::pdflib.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-PDF-Writer/distinfo b/textproc/p5-PDF-Writer/distinfo
new file mode 100644
index 000000000000..2a99eb2318f4
--- /dev/null
+++ b/textproc/p5-PDF-Writer/distinfo
@@ -0,0 +1,3 @@
+MD5 (PDF-Writer-0.06.tar.gz) = 06fc558ac8654c71517f2a210462ba0a
+SHA256 (PDF-Writer-0.06.tar.gz) = df8d2dd38211b4610d3d4bb1771fe03b5dad1b1282baf060402358c5c17fb06b
+SIZE (PDF-Writer-0.06.tar.gz) = 5512
diff --git a/textproc/p5-PDF-Writer/pkg-descr b/textproc/p5-PDF-Writer/pkg-descr
new file mode 100644
index 000000000000..90bf625ed43f
--- /dev/null
+++ b/textproc/p5-PDF-Writer/pkg-descr
@@ -0,0 +1,4 @@
+This is a generalized API that allows a module that generates PDFs to
+transparently target multiple backends without changing its code.
+
+WWW: http://search.cpan.org/dist/PDF-Writer/
diff --git a/textproc/p5-PDF-Writer/pkg-plist b/textproc/p5-PDF-Writer/pkg-plist
new file mode 100644
index 000000000000..43375bf60b44
--- /dev/null
+++ b/textproc/p5-PDF-Writer/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/PDF/Writer.pm
+%%SITE_PERL%%/PDF/Writer/mock.pm
+%%SITE_PERL%%/PDF/Writer/pdfapi2.pm
+%%SITE_PERL%%/PDF/Writer/pdflib.pm
+@dirrmtry %%SITE_PERL%%/PDF/Writer
+@dirrmtry %%SITE_PERL%%/PDF