aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2003-12-08 18:03:42 +0800
committerlinimon <linimon@FreeBSD.org>2003-12-08 18:03:42 +0800
commit5c8d2d2328351367abc0b24302dfe4cc6e947592 (patch)
tree2f1bd60681653b0e0c6d048f3681703243fe1e2e /textproc
parentdad401261f90eb885d20ad17142f1312bc117732 (diff)
downloadfreebsd-ports-gnome-5c8d2d2328351367abc0b24302dfe4cc6e947592.tar.gz
freebsd-ports-gnome-5c8d2d2328351367abc0b24302dfe4cc6e947592.tar.zst
freebsd-ports-gnome-5c8d2d2328351367abc0b24302dfe4cc6e947592.zip
- Add a pkg-deinstall script for updating LaTeX's content cache after
deinstalling, too. (Suggested by Greg Lewis) - When installing via port, set $PKG_PREFIX to $PREFIX for the pkg-install script to make it look for mktexlsr in there, too. PR: ports/59589 Submitted by: Stefan Walter <sw@gegenunendlich.de> (maintainer)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/foiltex/Makefile4
-rw-r--r--textproc/foiltex/pkg-deinstall13
2 files changed, 15 insertions, 2 deletions
diff --git a/textproc/foiltex/Makefile b/textproc/foiltex/Makefile
index fcd103d30e89..2ea294f76df4 100644
--- a/textproc/foiltex/Makefile
+++ b/textproc/foiltex/Makefile
@@ -57,7 +57,7 @@ do-install:
@${INSTALL_DATA} ${FOIL_FILES} ${FOIL_DIR}
post-install:
- ${SETENV} LOCALBASE=${LOCALBASE} ${SH} ${PKGDIR}/pkg-install \
- ${PKGNAME} POST-INSTALL
+ ${SETENV} LOCALBASE=${LOCALBASE} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>
diff --git a/textproc/foiltex/pkg-deinstall b/textproc/foiltex/pkg-deinstall
new file mode 100644
index 000000000000..f49ad2595ff4
--- /dev/null
+++ b/textproc/foiltex/pkg-deinstall
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+if [ "$2" = "POST-DEINSTALL" ]; then
+ echo "Updating content cache to let LaTeX know about the new style files:"
+ if [ -x ${PKG_PREFIX}/bin/mktexlsr ]; then
+ ${PKG_PREFIX}/bin/mktexlsr
+ elif [ -x /usr/local/bin/mktexlsr ]; then
+ /usr/local/bin/mktexlsr
+ else
+ echo "Could not find mktexlsr. Please run it manually to update"
+ echo "LaTeX's content cache."
+ fi
+fi