aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2009-11-10 19:16:35 +0800
committerdemon <demon@FreeBSD.org>2009-11-10 19:16:35 +0800
commit63df0a146f1b6292ebdd4965f143127fac59b4e1 (patch)
tree22749771244bd8b491257fb8f3cffe1440fe745c /textproc
parentb17ff5ddb41dc035c0e8ca388a91651ac58d39a2 (diff)
downloadfreebsd-ports-gnome-63df0a146f1b6292ebdd4965f143127fac59b4e1.tar.gz
freebsd-ports-gnome-63df0a146f1b6292ebdd4965f143127fac59b4e1.tar.zst
freebsd-ports-gnome-63df0a146f1b6292ebdd4965f143127fac59b4e1.zip
New port: XML-Validate.
XML::Validate is a generic interface to different XML validation backends.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Validate/Makefile26
-rw-r--r--textproc/p5-XML-Validate/distinfo3
-rw-r--r--textproc/p5-XML-Validate/pkg-descr7
-rw-r--r--textproc/p5-XML-Validate/pkg-plist11
5 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a2126ced36f5..11b5dcecbb65 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -832,6 +832,7 @@
SUBDIR += p5-XML-TreeBuilder
SUBDIR += p5-XML-TreePP
SUBDIR += p5-XML-Twig
+ SUBDIR += p5-XML-Validate
SUBDIR += p5-XML-Validator-Schema
SUBDIR += p5-XML-Writer
SUBDIR += p5-XML-XBEL
diff --git a/textproc/p5-XML-Validate/Makefile b/textproc/p5-XML-Validate/Makefile
new file mode 100644
index 000000000000..8c583734d9b3
--- /dev/null
+++ b/textproc/p5-XML-Validate/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: textproc/p5-XML-Validate
+# Date created: 10 November 2009
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Validate
+PORTVERSION= 1.025
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= An XML validator factory
+
+RUN_DEPENDS= ${SITE_PERL}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
+
+PERL_CONFIGURE= yes
+
+MAN1= validxml.pl.1
+MAN3= XML::Validate.3 XML::Validate::Base.3 \
+ XML::Validate::LibXML.3 XML::Validate::MSXML.3 \
+ XML::Validate::Xerces.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Validate/distinfo b/textproc/p5-XML-Validate/distinfo
new file mode 100644
index 000000000000..3fd4bc16feaa
--- /dev/null
+++ b/textproc/p5-XML-Validate/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Validate-1.025.tar.gz) = bcf2b2ac63e0c91a7e87b8b390881fe1
+SHA256 (XML-Validate-1.025.tar.gz) = ccc3231babe223eb2b42edf389669fddebb60b77ab62b6c26d69e282a8764414
+SIZE (XML-Validate-1.025.tar.gz) = 20187
diff --git a/textproc/p5-XML-Validate/pkg-descr b/textproc/p5-XML-Validate/pkg-descr
new file mode 100644
index 000000000000..b3259eafe271
--- /dev/null
+++ b/textproc/p5-XML-Validate/pkg-descr
@@ -0,0 +1,7 @@
+XML::Validate is a generic interface to different XML validation backends.
+
+Backends for the following validators are included with this distribution:
+** LibXML (& you'll need XML::LibXML)
+** Xerces (& you'll need XML::Xerces)
+
+WWW: http://search.cpan.org/~bbc/XML-Validate/
diff --git a/textproc/p5-XML-Validate/pkg-plist b/textproc/p5-XML-Validate/pkg-plist
new file mode 100644
index 000000000000..9dc876d59684
--- /dev/null
+++ b/textproc/p5-XML-Validate/pkg-plist
@@ -0,0 +1,11 @@
+bin/validxml.pl
+%%SITE_PERL%%/XML/Validate.pm
+%%SITE_PERL%%/XML/Validate/Base.pm
+%%SITE_PERL%%/XML/Validate/LibXML.pm
+%%SITE_PERL%%/XML/Validate/MSXML.pm
+%%SITE_PERL%%/XML/Validate/Xerces.pm
+%%SITE_PERL%%/mach/auto/XML/Validate/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Validate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/Validate
+@dirrmtry %%SITE_PERL%%/XML