aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2011-03-04 16:31:12 +0800
committerclsung <clsung@FreeBSD.org>2011-03-04 16:31:12 +0800
commitc7fb5bdce08480ba144fdb332eb1fe10b2f11f5f (patch)
tree87697d3cfa79dc7c39c7f6e9393bf0171e1360ab /textproc
parentbd961ebfa606cf5f9bdce76836a5a036aeb38122 (diff)
downloadfreebsd-ports-gnome-c7fb5bdce08480ba144fdb332eb1fe10b2f11f5f.tar.gz
freebsd-ports-gnome-c7fb5bdce08480ba144fdb332eb1fe10b2f11f5f.tar.zst
freebsd-ports-gnome-c7fb5bdce08480ba144fdb332eb1fe10b2f11f5f.zip
rubygem-multi_xml
A generic swappable back-end for XML parsing. Lots of Ruby libraries utilize XML parsing in some form, and everyone has their favorite XML library. In order to best support multiple XML parsers and libraries, multi_xml is a general-purpose swappable XML backend library. WWW: http://rubygems.org/gems/multi_xml
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-multi_xml/Makefile27
-rw-r--r--textproc/rubygem-multi_xml/distinfo2
-rw-r--r--textproc/rubygem-multi_xml/pkg-descr8
4 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 70acbb90edd7..8db6c83db5d7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1140,6 +1140,7 @@
SUBDIR += rubygem-liquid
SUBDIR += rubygem-loofah
SUBDIR += rubygem-markaby
+ SUBDIR += rubygem-multi_xml
SUBDIR += rubygem-nokogiri
SUBDIR += rubygem-opml
SUBDIR += rubygem-rak
diff --git a/textproc/rubygem-multi_xml/Makefile b/textproc/rubygem-multi_xml/Makefile
new file mode 100644
index 000000000000..2a2ac4235a19
--- /dev/null
+++ b/textproc/rubygem-multi_xml/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: rubygem-multi_xml
+# Date created: 4 March 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= multi_xml
+PORTVERSION= 0.2.0
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Ruby library provide swappable XML backends
+
+OPTIONS= NOKOGIRI "Nokogiri is a HTML, XML, SAX, and Reader parser" off
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NOKOGIRI)
+RUN_DEPENDS+= rubygem-nokogiri>=0:${PORTSDIR}/textproc/rubygem-nokogiri
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/rubygem-multi_xml/distinfo b/textproc/rubygem-multi_xml/distinfo
new file mode 100644
index 000000000000..a5713a3d7555
--- /dev/null
+++ b/textproc/rubygem-multi_xml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/multi_xml-0.2.0.gem) = 5e78981a42028b9ac2f881b75212f8ffe8edcf8dcfe27020a567fd2a5e7ebfff
+SIZE (rubygem/multi_xml-0.2.0.gem) = 13312
diff --git a/textproc/rubygem-multi_xml/pkg-descr b/textproc/rubygem-multi_xml/pkg-descr
new file mode 100644
index 000000000000..95415e4cc6bc
--- /dev/null
+++ b/textproc/rubygem-multi_xml/pkg-descr
@@ -0,0 +1,8 @@
+A generic swappable back-end for XML parsing.
+
+Lots of Ruby libraries utilize XML parsing in some form, and
+everyone has their favorite XML library. In order to best
+support multiple XML parsers and libraries, multi_xml is a
+general-purpose swappable XML backend library.
+
+WWW: http://rubygems.org/gems/multi_xml