aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-07-16 06:54:33 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-07-16 06:54:33 +0800
commitc935c061f13700d1b5af487f829e403765c577a9 (patch)
tree9e6052844f76682aafde23437e86ae3ad2adabb1 /textproc
parent14d418fee97b266c804823d9a6d55de97ccd2e94 (diff)
downloadfreebsd-ports-gnome-c935c061f13700d1b5af487f829e403765c577a9.tar.gz
freebsd-ports-gnome-c935c061f13700d1b5af487f829e403765c577a9.tar.zst
freebsd-ports-gnome-c935c061f13700d1b5af487f829e403765c577a9.zip
- Fix on amd64
- Respect CC - Check for lua version correctly PR: 136786, 136789 Submitted by: Andrew Lewis <freeghb@gmail.com> (maintainer)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/luaexpat/Makefile9
-rw-r--r--textproc/luaexpat/files/patch-config13
2 files changed, 16 insertions, 6 deletions
diff --git a/textproc/luaexpat/Makefile b/textproc/luaexpat/Makefile
index ec07fb100ce3..2e103ad9d30e 100644
--- a/textproc/luaexpat/Makefile
+++ b/textproc/luaexpat/Makefile
@@ -16,17 +16,18 @@ COMMENT= LuaExpat is a SAX XML parser based on the Expat library
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
-ONLY_FOR_ARCHS= i386
-
MAKEFILE= makefile
ALL_TARGET= lib
USE_LUA= 5.0-5.1
+LUA_PREMK= yes
WANT_LUA_VER= 5.1
CFLAGS+= -fPIC
-.if ${USE_LUA} == 5.0
+.include <bsd.port.pre.mk>
+
+.if ${LUA_VER} == 5.0
BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:build
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/luaexpat/files/patch-config b/textproc/luaexpat/files/patch-config
index 5202efab4a23..54f48eec42c0 100644
--- a/textproc/luaexpat/files/patch-config
+++ b/textproc/luaexpat/files/patch-config
@@ -1,5 +1,5 @@
---- config.orig 2006-06-08 20:41:48.000000000 +0000
-+++ config 2009-07-03 03:00:20.000000000 +0000
+--- config.orig 2006-06-09 00:41:48.000000000 +0400
++++ config 2009-07-15 22:46:59.000000000 +0400
@@ -1,15 +1,15 @@
# Installation directories
# System's libraries directory (where binary libraries are installed)
@@ -30,3 +30,12 @@
# Compilation parameters
CWARNS = -Wall -pedantic \
+@@ -31,6 +31,6 @@
+ -Wshadow \
+ -Wwrite-strings
+
+-CFLAGS = $(CWARNS) -ansi -O2 -I$(LUA_INC) \
++CFLAGS += $(CWARNS) -ansi -O2 -I$(LUA_INC) \
+ -I$(COMPAT_DIR) -I$(EXPAT_INC)
+-CC = gcc
++CC? = gcc