aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2009-01-24 07:53:56 +0800
committerpgj <pgj@FreeBSD.org>2009-01-24 07:53:56 +0800
commitcddcfc21f483fa9641abf426a8da25f0194b6153 (patch)
tree8682ca2170971135482e01b754b597c5b028dec5 /textproc
parent41139906e9dbfe776d429c15e7a685295698fb0d (diff)
downloadfreebsd-ports-gnome-cddcfc21f483fa9641abf426a8da25f0194b6153.tar.gz
freebsd-ports-gnome-cddcfc21f483fa9641abf426a8da25f0194b6153.tar.zst
freebsd-ports-gnome-cddcfc21f483fa9641abf426a8da25f0194b6153.zip
A variety of alternative parser combinator libraries for the functional
programming language Haskell, including the original HuttonMeijer set. The Poly sets have features like good error reporting, arbitrary token type, running state, lazy parsing, and so on. Finally, Text.Parse is a proposed replacement for the standard Read class, for better deserialisation of Haskell values from Strings. WWW: http://www.cs.york.ac.uk/fp/polyparse/ Approved by: gabor
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-polyparse-ghc/Makefile55
-rw-r--r--textproc/hs-polyparse-ghc/distinfo3
-rw-r--r--textproc/hs-polyparse-ghc/pkg-descr8
-rw-r--r--textproc/hs-polyparse-ghc/pkg-plist29
-rw-r--r--textproc/hs-polyparse/Makefile55
-rw-r--r--textproc/hs-polyparse/distinfo3
-rw-r--r--textproc/hs-polyparse/pkg-descr8
-rw-r--r--textproc/hs-polyparse/pkg-plist29
9 files changed, 191 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 659fbb38de0e..c92f2efccd67 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -210,6 +210,7 @@
SUBDIR += hs-bytestring-csv
SUBDIR += hs-haxml
SUBDIR += hs-highlighting-kate-ghc
+ SUBDIR += hs-polyparse-ghc
SUBDIR += hs-stringsearch
SUBDIR += hsb-aspell
SUBDIR += htdig
diff --git a/textproc/hs-polyparse-ghc/Makefile b/textproc/hs-polyparse-ghc/Makefile
new file mode 100644
index 000000000000..478d78867724
--- /dev/null
+++ b/textproc/hs-polyparse-ghc/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: hs-polyparse-ghc
+# Date created: January 23, 2009
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= polyparse
+PORTVERSION= 1.1
+CATEGORIES= textproc haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -ghc
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Alternative parser combinator libraries for Haskell
+
+BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+
+GHC_VERSION= 6.8.3
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
+CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${CABALDIR}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= COPYRIGHT html
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+PLIST_SUB+= RMLIC="@comment "
+.else
+PLIST_SUB+= RMLIC=""
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+
+.include <bsd.port.mk>
diff --git a/textproc/hs-polyparse-ghc/distinfo b/textproc/hs-polyparse-ghc/distinfo
new file mode 100644
index 000000000000..4c297ba654df
--- /dev/null
+++ b/textproc/hs-polyparse-ghc/distinfo
@@ -0,0 +1,3 @@
+MD5 (polyparse-1.1.tar.gz) = 3d01daae5ca692b24729093dc45aa94c
+SHA256 (polyparse-1.1.tar.gz) = 87eab9c8f2bee72d0c3a00d002e442405da016794e125f6c47c66607e1983957
+SIZE (polyparse-1.1.tar.gz) = 112884
diff --git a/textproc/hs-polyparse-ghc/pkg-descr b/textproc/hs-polyparse-ghc/pkg-descr
new file mode 100644
index 000000000000..9677bdd925da
--- /dev/null
+++ b/textproc/hs-polyparse-ghc/pkg-descr
@@ -0,0 +1,8 @@
+A variety of alternative parser combinator libraries for the functional
+programming language Haskell, including the original HuttonMeijer set.
+The Poly sets have features like good error reporting, arbitrary token
+type, running state, lazy parsing, and so on. Finally, Text.Parse is a
+proposed replacement for the standard Read class, for better
+deserialisation of Haskell values from Strings.
+
+WWW: http://www.cs.york.ac.uk/fp/polyparse/
diff --git a/textproc/hs-polyparse-ghc/pkg-plist b/textproc/hs-polyparse-ghc/pkg-plist
new file mode 100644
index 000000000000..7c34f162e0cb
--- /dev/null
+++ b/textproc/hs-polyparse-ghc/pkg-plist
@@ -0,0 +1,29 @@
+%%SUBDIR%%/Text/Parse.hi
+%%SUBDIR%%/Text/ParserCombinators/HuttonMeijer.hi
+%%SUBDIR%%/Text/ParserCombinators/HuttonMeijerWallace.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly.hi
+%%SUBDIR%%/Text/ParserCombinators/PolyLazy.hi
+%%SUBDIR%%/Text/ParserCombinators/PolyState.hi
+%%SUBDIR%%/Text/ParserCombinators/PolyStateLazy.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/Base.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/Lazy.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/Plain.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/State.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/StateLazy.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/Lazy.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/Plain.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/State.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/StateLazy.hi
+%%SUBDIR%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%SUBDIR%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%SUBDIR%%/%%PORTNAME%%-register.sh
+%%RMLIC%%%%DOCSDIR%%/COPYRIGHT
+%%RMLIC%%@dirrm %%DOCSDIR%%
+@dirrmtry %%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak
+@dirrmtry %%SUBDIR%%/Text/ParserCombinators/Poly
+@dirrmtry %%SUBDIR%%/Text/ParserCombinators
+@dirrmtry %%SUBDIR%%/Text
+@exec sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
+@exec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec ghc-pkg unregister %%PORTNAME%%
+@unexec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
diff --git a/textproc/hs-polyparse/Makefile b/textproc/hs-polyparse/Makefile
new file mode 100644
index 000000000000..478d78867724
--- /dev/null
+++ b/textproc/hs-polyparse/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: hs-polyparse-ghc
+# Date created: January 23, 2009
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= polyparse
+PORTVERSION= 1.1
+CATEGORIES= textproc haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -ghc
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Alternative parser combinator libraries for Haskell
+
+BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+
+GHC_VERSION= 6.8.3
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
+CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${CABALDIR}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= COPYRIGHT html
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+PLIST_SUB+= RMLIC="@comment "
+.else
+PLIST_SUB+= RMLIC=""
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+
+.include <bsd.port.mk>
diff --git a/textproc/hs-polyparse/distinfo b/textproc/hs-polyparse/distinfo
new file mode 100644
index 000000000000..4c297ba654df
--- /dev/null
+++ b/textproc/hs-polyparse/distinfo
@@ -0,0 +1,3 @@
+MD5 (polyparse-1.1.tar.gz) = 3d01daae5ca692b24729093dc45aa94c
+SHA256 (polyparse-1.1.tar.gz) = 87eab9c8f2bee72d0c3a00d002e442405da016794e125f6c47c66607e1983957
+SIZE (polyparse-1.1.tar.gz) = 112884
diff --git a/textproc/hs-polyparse/pkg-descr b/textproc/hs-polyparse/pkg-descr
new file mode 100644
index 000000000000..9677bdd925da
--- /dev/null
+++ b/textproc/hs-polyparse/pkg-descr
@@ -0,0 +1,8 @@
+A variety of alternative parser combinator libraries for the functional
+programming language Haskell, including the original HuttonMeijer set.
+The Poly sets have features like good error reporting, arbitrary token
+type, running state, lazy parsing, and so on. Finally, Text.Parse is a
+proposed replacement for the standard Read class, for better
+deserialisation of Haskell values from Strings.
+
+WWW: http://www.cs.york.ac.uk/fp/polyparse/
diff --git a/textproc/hs-polyparse/pkg-plist b/textproc/hs-polyparse/pkg-plist
new file mode 100644
index 000000000000..7c34f162e0cb
--- /dev/null
+++ b/textproc/hs-polyparse/pkg-plist
@@ -0,0 +1,29 @@
+%%SUBDIR%%/Text/Parse.hi
+%%SUBDIR%%/Text/ParserCombinators/HuttonMeijer.hi
+%%SUBDIR%%/Text/ParserCombinators/HuttonMeijerWallace.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly.hi
+%%SUBDIR%%/Text/ParserCombinators/PolyLazy.hi
+%%SUBDIR%%/Text/ParserCombinators/PolyState.hi
+%%SUBDIR%%/Text/ParserCombinators/PolyStateLazy.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/Base.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/Lazy.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/Plain.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/State.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/StateLazy.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/Lazy.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/Plain.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/State.hi
+%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/StateLazy.hi
+%%SUBDIR%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%SUBDIR%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%SUBDIR%%/%%PORTNAME%%-register.sh
+%%RMLIC%%%%DOCSDIR%%/COPYRIGHT
+%%RMLIC%%@dirrm %%DOCSDIR%%
+@dirrmtry %%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak
+@dirrmtry %%SUBDIR%%/Text/ParserCombinators/Poly
+@dirrmtry %%SUBDIR%%/Text/ParserCombinators
+@dirrmtry %%SUBDIR%%/Text
+@exec sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
+@exec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec ghc-pkg unregister %%PORTNAME%%
+@unexec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old