aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-07-26 20:32:51 +0800
committersem <sem@FreeBSD.org>2004-07-26 20:32:51 +0800
commit030cd8c2e77d4de2a09bbb4e1b8dccc76a315605 (patch)
tree4773117474247d8359cfabd9602fe243e8832631 /textproc
parenta5ad9e90cbf35314354c973a521c47a815a92820 (diff)
downloadfreebsd-ports-gnome-030cd8c2e77d4de2a09bbb4e1b8dccc76a315605.tar.gz
freebsd-ports-gnome-030cd8c2e77d4de2a09bbb4e1b8dccc76a315605.tar.zst
freebsd-ports-gnome-030cd8c2e77d4de2a09bbb4e1b8dccc76a315605.zip
This is a simple set of C++ classes which allow to use
templates like perl module HTML::Template PR: ports/69277 Submitted by: Andrei V. Shetuhin <shetuhin@corp.mail.ru>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ctpp/Makefile21
-rw-r--r--textproc/ctpp/distinfo2
-rw-r--r--textproc/ctpp/pkg-descr6
-rw-r--r--textproc/ctpp/pkg-plist14
5 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 1ae3b1d1c2cd..c9896fabe3d7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -47,6 +47,7 @@
SUBDIR += crimson
SUBDIR += cs-aspell
SUBDIR += csv2latex
+ SUBDIR += ctpp
SUBDIR += cwtext
SUBDIR += cy-aspell
SUBDIR += da-aspell
diff --git a/textproc/ctpp/Makefile b/textproc/ctpp/Makefile
new file mode 100644
index 000000000000..fb8caf5484fd
--- /dev/null
+++ b/textproc/ctpp/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: ctpp
+# Date created: 19 July 2004
+# Whom: shetuhin@corp.mail.ru (Andrei V. Shetuhin)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctpp
+PORTVERSION= 1.0
+CATEGORIES= textproc devel
+MASTER_SITES= http://www.reki.ru/products/ctpp/
+
+MAINTAINER= shetuhin@corp.mail.ru
+COMMENT= C++ library to use templates in C/C++ projects
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/ctpp/distinfo b/textproc/ctpp/distinfo
new file mode 100644
index 000000000000..cb94149fdd2a
--- /dev/null
+++ b/textproc/ctpp/distinfo
@@ -0,0 +1,2 @@
+MD5 (ctpp-1.0.tar.gz) = 394a4dd9e1565834a17d36979b308359
+SIZE (ctpp-1.0.tar.gz) = 57945
diff --git a/textproc/ctpp/pkg-descr b/textproc/ctpp/pkg-descr
new file mode 100644
index 000000000000..59dea472cdc2
--- /dev/null
+++ b/textproc/ctpp/pkg-descr
@@ -0,0 +1,6 @@
+This is a simple set of C++ classes which allow to use
+templates like perl module HTML::Template
+
+WWW: http://www.reki.ru/products/ctpp
+
+- shetuhin@corp.mail.ru
diff --git a/textproc/ctpp/pkg-plist b/textproc/ctpp/pkg-plist
new file mode 100644
index 000000000000..d7a9be9a789e
--- /dev/null
+++ b/textproc/ctpp/pkg-plist
@@ -0,0 +1,14 @@
+include/ctpp/ctpp/ctpp.hpp
+include/ctpp/ctpp/param_data.hpp
+include/ctpp/ctpp/udf_fn.hpp
+include/ctpp/functions/htmlescape.hpp
+include/ctpp/functions/num_format.hpp
+include/ctpp/functions/std_fn_list.hpp
+include/ctpp/functions/urlescape.hpp
+include/ctpp/functions/value_in_set.hpp
+include/ctpp/util/d2str.hpp
+lib/libctpp.so
+@dirrm include/ctpp/util
+@dirrm include/ctpp/functions
+@dirrm include/ctpp/ctpp
+@dirrm include/ctpp