aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-11 18:25:27 +0800
committerclsung <clsung@FreeBSD.org>2006-07-11 18:25:27 +0800
commit22c7cec90b232d47506140f31f643e760c7ff34c (patch)
tree5602f1606b28257f45e3f7d11c9e9a65034fa6d2 /textproc
parent27248653d32e047388be99198a84db0fc72e77cc (diff)
downloadfreebsd-ports-gnome-22c7cec90b232d47506140f31f643e760c7ff34c.tar.gz
freebsd-ports-gnome-22c7cec90b232d47506140f31f643e760c7ff34c.tar.zst
freebsd-ports-gnome-22c7cec90b232d47506140f31f643e760c7ff34c.zip
Add p5-Text-Hatena 0.14, perl extension for formatting text with Hatena
Style. PR: ports/100066 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Hatena/Makefile35
-rw-r--r--textproc/p5-Text-Hatena/distinfo3
-rw-r--r--textproc/p5-Text-Hatena/pkg-descr8
-rw-r--r--textproc/p5-Text-Hatena/pkg-plist53
5 files changed, 100 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d65d363abe78..e0aa1d609bfe 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -476,6 +476,7 @@
SUBDIR += p5-Text-German
SUBDIR += p5-Text-Glob
SUBDIR += p5-Text-Graphics
+ SUBDIR += p5-Text-Hatena
SUBDIR += p5-Text-Markdown
SUBDIR += p5-Text-Metaphone
SUBDIR += p5-Text-NSP
diff --git a/textproc/p5-Text-Hatena/Makefile b/textproc/p5-Text-Hatena/Makefile
new file mode 100644
index 000000000000..331363d2f98b
--- /dev/null
+++ b/textproc/p5-Text-Hatena/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Text-Hatena
+# Date created: 2006-07-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Hatena
+PORTVERSION= 0.14
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for formatting text with Hatena Style
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Net/Amazon.pm:${PORTSDIR}/net/p5-Net-Amazon
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Hatena.3 Text::Hatena::AutoLink.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601 # inherited from net/p5-Amazon
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Hatena/distinfo b/textproc/p5-Text-Hatena/distinfo
new file mode 100644
index 000000000000..6bd73d4159f0
--- /dev/null
+++ b/textproc/p5-Text-Hatena/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Hatena-0.14.tar.gz) = e0a853ed1c43f9458265ff9741c1d18d
+SHA256 (Text-Hatena-0.14.tar.gz) = 711f8e2cccc957edd71c46c6c91dc36100b5de8851311783e45740d293010a1b
+SIZE (Text-Hatena-0.14.tar.gz) = 26640
diff --git a/textproc/p5-Text-Hatena/pkg-descr b/textproc/p5-Text-Hatena/pkg-descr
new file mode 100644
index 000000000000..f7c091f1fdba
--- /dev/null
+++ b/textproc/p5-Text-Hatena/pkg-descr
@@ -0,0 +1,8 @@
+Text::Hatena parses text with Hatena Style and generates html string.
+Hatena Style is a set of text syntax which is originally used in
+Hatena Diary (http://d.hatena.ne.jp/).
+
+You can get html string from simple text with syntax like Wiki.
+
+Author: Junya Kondo, <jkondo@hatena.ne.jp>
+WWW: http://search.cpan.org/dist/Text-Hatena/
diff --git a/textproc/p5-Text-Hatena/pkg-plist b/textproc/p5-Text-Hatena/pkg-plist
new file mode 100644
index 000000000000..24969701eccd
--- /dev/null
+++ b/textproc/p5-Text-Hatena/pkg-plist
@@ -0,0 +1,53 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Hatena/.packlist
+%%SITE_PERL%%/Text/Hatena.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/ASIN.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/Amazon.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/EAN.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/FTP.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/Google.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HTTP.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaAntenna.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaBookmark.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaDiary.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaFotolife.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaGraph.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaGroup.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaID.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaIdea.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaMap.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaQuestion.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaRSS.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/HatenaSearch.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/Mailto.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/Rakuten.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/Scheme.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/Tex.pm
+%%SITE_PERL%%/Text/Hatena/AutoLink/Unbracket.pm
+%%SITE_PERL%%/Text/Hatena/BlockquoteNode.pm
+%%SITE_PERL%%/Text/Hatena/BodyNode.pm
+%%SITE_PERL%%/Text/Hatena/BrNode.pm
+%%SITE_PERL%%/Text/Hatena/CDataNode.pm
+%%SITE_PERL%%/Text/Hatena/Context.pm
+%%SITE_PERL%%/Text/Hatena/DlNode.pm
+%%SITE_PERL%%/Text/Hatena/FootnoteNode.pm
+%%SITE_PERL%%/Text/Hatena/H3Node.pm
+%%SITE_PERL%%/Text/Hatena/H4Node.pm
+%%SITE_PERL%%/Text/Hatena/H5Node.pm
+%%SITE_PERL%%/Text/Hatena/HTMLFilter.pm
+%%SITE_PERL%%/Text/Hatena/ListNode.pm
+%%SITE_PERL%%/Text/Hatena/Node.pm
+%%SITE_PERL%%/Text/Hatena/PNode.pm
+%%SITE_PERL%%/Text/Hatena/PreNode.pm
+%%SITE_PERL%%/Text/Hatena/SectionNode.pm
+%%SITE_PERL%%/Text/Hatena/SuperpreNode.pm
+%%SITE_PERL%%/Text/Hatena/TableNode.pm
+%%SITE_PERL%%/Text/Hatena/TagNode.pm
+%%SITE_PERL%%/Text/Hatena/TaglineNode.pm
+%%SITE_PERL%%/Text/Hatena/Text.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Hatena
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/Text/Hatena/AutoLink
+@dirrmtry %%SITE_PERL%%/Text/Hatena
+@dirrmtry %%SITE_PERL%%/Text