aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorjase <jase@FreeBSD.org>2012-07-17 16:47:48 +0800
committerjase <jase@FreeBSD.org>2012-07-17 16:47:48 +0800
commit252e94aad18f318b0b45943a96b20ddc0ecb69aa (patch)
treeed36497545128ceb648cff67f0ce61ec90a97cf7 /textproc
parent51f54a073c2ea264864f315253867e57c94fd165 (diff)
downloadfreebsd-ports-gnome-252e94aad18f318b0b45943a96b20ddc0ecb69aa.tar.gz
freebsd-ports-gnome-252e94aad18f318b0b45943a96b20ddc0ecb69aa.tar.zst
freebsd-ports-gnome-252e94aad18f318b0b45943a96b20ddc0ecb69aa.zip
- Update to 1.4.1 [1]
- Add patch from upstream to fix build [2] - Convert to optionsNG, add NLS option - Remove unnecessary bsd.port.{pre,post}.mk includes - Remove unnecessary CPPFLAGS PR: ports/169728 [1] Submitted by: Henry Hu <henry.hu.sh@gmail.com> (maintainer) Obtained from: https://github.com/phuang/ibus/commit/3862735 [2] Approved by: flo (mentor)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ibus/Makefile37
-rw-r--r--textproc/ibus/distinfo4
-rw-r--r--textproc/ibus/files/patch-ibus-common.py2
-rw-r--r--textproc/ibus/files/patch-src-Makefile_in11
-rw-r--r--textproc/ibus/pkg-plist6
5 files changed, 37 insertions, 23 deletions
diff --git a/textproc/ibus/Makefile b/textproc/ibus/Makefile
index 69081ad6a2f8..973476c62b98 100644
--- a/textproc/ibus/Makefile
+++ b/textproc/ibus/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ibus
-PORTVERSION= 1.4.0
-PORTREVISION= 4
+PORTVERSION= 1.4.1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -34,38 +33,40 @@ GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
GCONF_SCHEMAS= ibus.schemas
-OPTIONS= ISOCODES "Use isocodecs" on \
- GTK3 "Install GTK3 client" on \
- VALA "Install vala binding" on \
- GINTRO "Install GObject Introspection data" on
+OPTIONS_DEFINE= ISOCODES NLS GTK3 VALA GINTRO
+OPTIONS_DEFAULT= ISOCODES GTK3 VALA GINTRO
-.include <bsd.port.pre.mk>
+ISOCODES_DESC= Use isocodecs
+GTK3_DESC= Install GTK3 client
+VALA_DESC= Install vala binding
+GINTRO_DESC= Install GObject Introspection data
-.if defined(WITH_ISOCODES)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MISOCODES}
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
RUN_DEPENDS+= ${LOCALBASE}/share/xml/iso-codes/iso_639.xml:${PORTSDIR}/misc/iso-codes
.else
CONFIGURE_ARGS+= --disable-iso-codes-check
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
-CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITHOUT_GTK3)
-CONFIGURE_ARGS+= --disable-gtk3
-PLIST_SUB+= GTK3="@comment "
-.else
+.if ${PORT_OPTIONS:MGTK3}
USE_GNOME+= gtk30
PLIST_SUB+= GTK3=""
+.else
+CONFIGURE_ARGS+= --disable-gtk3
+PLIST_SUB+= GTK3="@comment "
.endif
-.if defined(WITH_VALA)
+.if ${PORT_OPTIONS:MVALA}
CONFIGURE_ARGS+= --enable-vala
PLIST_SUB+= VALA=""
.else
@@ -73,7 +74,7 @@ CONFIGURE_ARGS+= --disable-vala
PLIST_SUB+= VALA="@comment "
.endif
-.if defined(WITH_GINTRO)
+.if ${PORT_OPTIONS:MGINTRO}
BUILD_DEPENDS+= gobject-introspection>=0.6.8:${PORTSDIR}/devel/gobject-introspection
RUN_DEPENDS+= gobject-introspection>=0.6.8:${PORTSDIR}/devel/gobject-introspection
CONFIGURE_ARGS+= --enable-introspection=yes
@@ -95,11 +96,11 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/etc/xdg/autostart
@${INSTALL_DATA} ${WRKSRC}/bus/ibus.desktop ${PREFIX}/etc/xdg/autostart
-. if defined(WITH_GTK3)
+. if ${PORT_OPTIONS:MGTK3}
@gtk-query-immodules-3.0 --update-cache
. endif
@gtk-query-immodules-2.0 > ${LOCALBASE}/etc/gtk-2.0/gtk.immodules
@${CAT} ${PKGMESSAGE}
@${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/ibus/distinfo b/textproc/ibus/distinfo
index 0ac021113e87..0edc3d15746e 100644
--- a/textproc/ibus/distinfo
+++ b/textproc/ibus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ibus-1.4.0.tar.gz) = 9e5a17d910eae932dd0cd185d0a102b56ad4a2bf79d54b1e53f70174cd2c2a3f
-SIZE (ibus-1.4.0.tar.gz) = 1452055
+SHA256 (ibus-1.4.1.tar.gz) = 2f46de279ef3c0a48d3f52061794cfc6544ad8cfe3f04d9d12b251d119a180d6
+SIZE (ibus-1.4.1.tar.gz) = 1479412
diff --git a/textproc/ibus/files/patch-ibus-common.py b/textproc/ibus/files/patch-ibus-common.py
index 30e77c69c4cb..d8db8095a48f 100644
--- a/textproc/ibus/files/patch-ibus-common.py
+++ b/textproc/ibus/files/patch-ibus-common.py
@@ -5,7 +5,7 @@
# return address
-libibus = ctypes.CDLL("libibus-1.0.so.0")
-+libibus = ctypes.CDLL("libibus-1.0.so.400")
++libibus = ctypes.CDLL("libibus-1.0.so.401")
get_address = libibus.ibus_get_address
get_address.restype=ctypes.c_char_p
diff --git a/textproc/ibus/files/patch-src-Makefile_in b/textproc/ibus/files/patch-src-Makefile_in
new file mode 100644
index 000000000000..d001be7874d5
--- /dev/null
+++ b/textproc/ibus/files/patch-src-Makefile_in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2012-07-10 17:36:55.865075371 +0100
++++ src/Makefile.in 2012-07-10 17:37:10.624820391 +0100
+@@ -575,7 +575,7 @@
+ @HAVE_INTROSPECTION_TRUE@ ibusenumtypes.h \
+ @HAVE_INTROSPECTION_TRUE@ $(NULL)
+
+-@HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_SCANNERFLAGS = --pkg=ibus-1.0 $(IBUS_GIR_SCANNERFLAGS)
++@HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_SCANNERFLAGS = --pkg-export=ibus-1.0 $(IBUS_GIR_SCANNERFLAGS)
+ @HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_INCLUDES = GLib-2.0 GObject-2.0 Gio-2.0
+ @HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_LIBS = $(libibus)
+ @HAVE_INTROSPECTION_TRUE@IBus_1_0_gir_FILES = $(addprefix $(srcdir)/,$(introspection_files))
diff --git a/textproc/ibus/pkg-plist b/textproc/ibus/pkg-plist
index b903281f5a37..5dbefb2617ff 100644
--- a/textproc/ibus/pkg-plist
+++ b/textproc/ibus/pkg-plist
@@ -42,7 +42,7 @@ lib/gtk-2.0/2.10.0/immodules/im-ibus.so
%%GTK3%%lib/gtk-3.0/3.0.0/immodules/im-ibus.so
lib/libibus-1.0.la
lib/libibus-1.0.so
-lib/libibus-1.0.so.400
+lib/libibus-1.0.so.401
%%PYTHON_SITELIBDIR%%/ibus/__init__.py
%%PYTHON_SITELIBDIR%%/ibus/__init__.pyc
%%PYTHON_SITELIBDIR%%/ibus/__init__.pyo
@@ -190,7 +190,6 @@ share/gtk-doc/html/ibus/ibus-ibusshare.html
share/gtk-doc/html/ibus/ibus-ibustypes.html
share/gtk-doc/html/ibus/ibus-ibusversion.html
share/gtk-doc/html/ibus/ibus-ibusxml.html
-share/gtk-doc/html/ibus/ibus.devhelp
share/gtk-doc/html/ibus/ibus.devhelp2
share/gtk-doc/html/ibus/index.html
share/gtk-doc/html/ibus/index.sgml
@@ -281,6 +280,7 @@ share/icons/hicolor/scalable/apps/ibus.svg
%%NLS%%share/locale/de/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/es/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/fr/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/gu/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/hi/LC_MESSAGES/ibus10.mo
@@ -289,6 +289,7 @@ share/icons/hicolor/scalable/apps/ibus.svg
%%NLS%%share/locale/ja/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/kn/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/ko/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/ml/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/mr/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/nl/LC_MESSAGES/ibus10.mo
@@ -301,6 +302,7 @@ share/icons/hicolor/scalable/apps/ibus.svg
%%NLS%%share/locale/sr@latin/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/ta/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/te/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/tg/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/uk/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/vi/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus10.mo