aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-10-05 22:52:51 +0800
committerbapt <bapt@FreeBSD.org>2012-10-05 22:52:51 +0800
commit5a1bc3924bc6cf324f9e739a1ed978182c97ae8f (patch)
treed8513d89fe92e0c643c66c449a95adcdef92af57 /textproc
parent574cf6a85084d6ff0bb7f0297932769ca9e4a2b5 (diff)
downloadfreebsd-ports-gnome-5a1bc3924bc6cf324f9e739a1ed978182c97ae8f.tar.gz
freebsd-ports-gnome-5a1bc3924bc6cf324f9e739a1ed978182c97ae8f.tar.zst
freebsd-ports-gnome-5a1bc3924bc6cf324f9e739a1ed978182c97ae8f.zip
Convert to new options framework
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libtranslate/Makefile32
-rw-r--r--textproc/sml-fxp/Makefile43
-rw-r--r--textproc/tdhkit/Makefile22
3 files changed, 43 insertions, 54 deletions
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
index e3777685f66c..acd42cbdaa94 100644
--- a/textproc/libtranslate/Makefile
+++ b/textproc/libtranslate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libtranslate
-# Date created: 15 Jan 2005
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= libtranslate
PORTVERSION= 0.99
@@ -30,8 +26,10 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
MAKE_JOBS_SAFE= yes
-OPTIONS= GENERIC "generic module" on \
- TALKFILTERS "talkfilters module" on
+OPTIONS_DEFINE= GENERIC TALKFILTERS
+OPTIONS_DEFAULT= GENERIC TALKFILTERS
+GENERIC_DESC= generic module
+TALKFILTERS_DESC= talkfilters module
MAN1= translate.1
@@ -39,12 +37,9 @@ post-patch::
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' \
-e 's|libsoup-2.2|libsoup-2.4|g' ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GENERIC)
-CONFIGURE_ARGS+= --disable-generic
-PLIST_SUB+= GENERIC="@comment "
-.else
+.if ${PORT_OPTIONS:MGENERIC}
PLIST_SUB+= GENERIC=""
USE_GNOME+= libxml2
LIB_DEPENDS+= soup-2.4:${PORTSDIR}/devel/libsoup
@@ -57,14 +52,17 @@ post-patch::
${SED} s,SOUP_MESSAGE_RESPONSE_,trans_SOUP_MESSAGE_RESPONSE_,g \
${DISTDIR}/libtranslate-0.99-libsoup24.diff \
| ${PATCH} -d ${WRKSRC} -p1
+.else
+CONFIGURE_ARGS+= --disable-generic
+PLIST_SUB+= GENERIC="@comment "
.endif
-.if defined(WITHOUT_TALKFILTERS)
-CONFIGURE_ARGS+= --disable-talkfilters
-PLIST_SUB+= TALKFILTERS="@comment "
-.else
+.if ${PORT_OPTIONS:MTALKFILTERS}
PLIST_SUB+= TALKFILTERS=""
LIB_DEPENDS+= talkfilters:${PORTSDIR}/misc/talkfilters
+.else
+CONFIGURE_ARGS+= --disable-talkfilters
+PLIST_SUB+= TALKFILTERS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/sml-fxp/Makefile b/textproc/sml-fxp/Makefile
index c4f16c3efee2..ffef37b04fdd 100644
--- a/textproc/sml-fxp/Makefile
+++ b/textproc/sml-fxp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sml-fxp
-# Date created: 16 Sep 2007
-# Whom: Timothy Bourke <timbob@bigpond.com>
-#
+# Created by: Timothy Bourke <timbob@bigpond.com>
# $FreeBSD$
-#
PORTNAME= sml-fxp
PORTVERSION= 2.0
@@ -25,19 +21,20 @@ COMMENT= Validating XML parser with Standard ML interface
# On Off On build apps and stabilize with sml-nj-devel
# Off On On apps with mlton, stabilize for sml-nj
# On On On apps with mlton, stabilize for sml-nj-devel
-OPTIONS= X11 "Build with X11 support" on \
- STABILIZATION "Stabilize the libraries for SML/NJ." on \
- DEVEL "Prefer the devel version of SML/NJ." on \
- MLTON "Build executables with mlton." off
+OPTIONS_DEFINE= X11 STABILIZATION DEVEL MLTON DOCS
+OPTIONS_DEFAULT= X11 STABILIZATION DEVEL
+STABILIZATION_DESC= Stabilize the libraries for SML/NJ.
+DEVEL_DESC= Prefer the devel version of SML/NJ.
+MLTON_DESC= Build executables with mlton.
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
RUN_DEPENDS+= xvcg:${PORTSDIR}/graphics/vcg
.endif
-.if defined(WITH_STABILIZATION) || defined(WITHOUT_MLTON)
-.if defined(WITH_DEVEL)
+.if ${PORT_OPTIONS:MSTABILITATION} || empty(PORT_OPTIONS:MMLTON)
+.if ${PORT_OPTIONS:MDEVEL}
BUILD_DEPENDS+= smlnj-devel>=110.65:${PORTSDIR}/lang/sml-nj-devel
MAKE_ENV+= SMLNJ_DEVEL=yes
@@ -49,20 +46,18 @@ MAKE_ENV+= SMLNJ=yes
.endif
.endif
-.if defined(WITH_MLTON)
+.if ${PORT_OPTIONS:MMLTON}
PLIST_SUB+= SML_EXEC="@comment " SML_EXEC_DEVEL="@comment "
-.else
-.if defined(WITH_DEVEL)
+.elif ${PORT_OPTIONS:MDEVEL}
PLIST_SUB+= SML_EXEC="@comment " SML_EXEC_DEVEL=""
.else
PLIST_SUB+= SML_EXEC="" SML_EXEC_DEVEL="@comment "
.endif
-.endif
-.if defined(WITH_STABILIZATION)
+.if ${PORT_OPTIONS:MSTABILIZATION}
MAKE_ENV+= STABILIZE=yes
-.if defined(WITH_DEVEL)
+.if ${PORT_OPTIONS:MDEVEL}
PLIST_SUB+= STABLE="@comment " STABLE_DEVEL=""
.else
PLIST_SUB+= STABLE="" STABLE_DEVEL="@comment "
@@ -72,23 +67,23 @@ PLIST_SUB+= STABLE="" STABLE_DEVEL="@comment "
PLIST_SUB+= STABLE="@comment " STABLE_DEVEL="@comment "
.endif
-.if defined(WITH_STABILIZATION) && defined(WITH_DEVEL)
+.if ${PORT_OPTIONS:MSTABILITATION} || !empty(PORT_OPTIONS:MDEVEL)
RUN_DEPENDS+= smlnj-devel>=110.65:${PORTSDIR}/lang/sml-nj-devel
.endif
-.if defined(WITH_MLTON)
+.if ${PORT_OPTIONS:MMLTON}
BUILD_DEPENDS+= mlton:${PORTSDIR}/lang/mlton
MAKE_ENV+= MLTON_BUILD=yes
.endif
-.if defined(WITHOUT_MLTON) && defined(WITHOUT_DEVEL)
+.if empty(PORT_OPTIONS:MMLTON) && empty(PORT_OPTIONS:MDEVEL)
MAKE_ENV+= NO_HEAP2EXEC=yes
PLIST_SUB+= SML_EXEC=""
.else
PLIST_SUB+= SML_EXEC="@comment "
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET=install install-doc
.endif
@@ -130,4 +125,4 @@ post-patch:
${MV} ${WRKSRC}/$$e.sml.orig ${WRKSRC}/$$e.orig.sml; \
done
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/tdhkit/Makefile b/textproc/tdhkit/Makefile
index fbd13c562514..d531a07fd2ee 100644
--- a/textproc/tdhkit/Makefile
+++ b/textproc/tdhkit/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: tdhkit
-# Date created: 2 Mar 2010
-# Whom: corky1951@comcast.net
-#
+# Created by: corky1951@comcast.net
# $FreeBSD$
-#
PORTNAME= tdhkit
PORTVERSION= 1.0
@@ -15,11 +10,12 @@ DISTNAME= ${PORTNAME}${PORTVERSION:C/\.//1}
MAINTAINER= ports@FreeBSD.org
COMMENT= Set of programs for working with tabular ASCII data
-OPTIONS= LIBCHRON "Install libchron" Off
+OPTIONS_DEFINE= LIBCHRON DOCS
+LIBCHRON_DESC= Install libchron
.include <bsd.port.options.mk>
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
PLIST_SUB+= LIBCHRON=""
.else
PLIST_SUB+= LIBCHRON="@comment "
@@ -37,7 +33,7 @@ MAN1= dateconvert.1 \
xlcells.1 \
xlcleaner.1
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
MAN3= libchron.3
.endif
MANCOMPRESSED= no
@@ -48,7 +44,7 @@ do-build:
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
cd ${WRKSRC}/libsrc && ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} libchron
.endif
@@ -56,7 +52,7 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
${INSTALL_PROGRAM} ${WRKSRC}/libchron.a ${PREFIX}/lib
.endif
@@ -64,12 +60,12 @@ do-install:
.for manpage in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/man/mantdh/${manpage} ${MAN1PREFIX}/man/man1
.endfor
-.if defined(WITH_LIBCHRON)
+.if ${PORT_OPTIONS:MLIBCHRON}
${INSTALL_MAN} ${WRKSRC}/man/mantdh/${MAN3} ${MAN3PREFIX}/man/man3
.endif
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/man/html/* ${DOCSDIR}
.endif