aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2006-01-25 03:48:09 +0800
committeranray <anray@FreeBSD.org>2006-01-25 03:48:09 +0800
commit5cf54fad44108594f6ab9c6e348b265398c37f40 (patch)
treedcbf116fe15a45b81522fd4c420b952df17035f2 /textproc
parenta77f6926e9ff7cb45ed4ef94a7524cfce77429f9 (diff)
downloadfreebsd-ports-gnome-5cf54fad44108594f6ab9c6e348b265398c37f40.tar.gz
freebsd-ports-gnome-5cf54fad44108594f6ab9c6e348b265398c37f40.tar.zst
freebsd-ports-gnome-5cf54fad44108594f6ab9c6e348b265398c37f40.zip
tools for helping translation of documentation
The po4a (po for anything) project goal is to ease translations (and more interestingly, the maintenance of translations) using gettext tools on areas where they were not expected like documentation. This package contains the main libraries of po4a, and the following sub-modules: - KernelHelp: Help messages of each kernel compilation option. - Man: Good old manual page format. - Pod: Perl documentation format. - Sgml: either debiandoc or docbook DTD. - Dia: uncompressed Dia diagrams. - LaTeX: generic TeX or LaTeX format WWW: http://packages.debian.org/unstable/text/po4a PR: ports/91532 Submitted by: Meno Abels <meno.abels@adviser.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/po4a/Makefile53
-rw-r--r--textproc/po4a/distinfo3
-rw-r--r--textproc/po4a/files/patch-Build.PL11
-rw-r--r--textproc/po4a/pkg-descr16
-rw-r--r--textproc/po4a/pkg-plist119
6 files changed, 203 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 88fc74625e21..2e1e169e66a8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -592,6 +592,7 @@
SUBDIR += php5-xmlreader
SUBDIR += php5-xmlwriter
SUBDIR += php5-xsl
+ SUBDIR += po4a
SUBDIR += pocketreader
SUBDIR += ppower4
SUBDIR += print-n-times
diff --git a/textproc/po4a/Makefile b/textproc/po4a/Makefile
new file mode 100644
index 000000000000..809cea796d87
--- /dev/null
+++ b/textproc/po4a/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: po4a
+# Date created: 08 January 2006
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= po4a
+PORTVERSION= 0.23
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= pool/main/p/po4a
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= Meno.Abels@Adviser.com
+COMMENT= Documentation gettext tools
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/Text/WrapI18N.pm:${PORTSDIR}/textproc/libtext-wrapi18n-perl \
+ ${SITE_PERL}/SGMLS.pm:${PORTSDIR}/textproc/p5-SGMLSpm \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
+
+USE_GETTEXT= yes
+USE_PERL5= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Locale::Po4a::TransTractor.3 \
+ Locale::Po4a::LaTeX.3 \
+ Locale::Po4a::Pod.3 \
+ Locale::Po4a::Po.3 \
+ Locale::Po4a::Sgml.3 \
+ Locale::Po4a::Text.3 \
+ Locale::Po4a::Common.3 \
+ Locale::Po4a::KernelHelp.3 \
+ Locale::Po4a::Guide.3 \
+ Locale::Po4a::Man.3 \
+ Locale::Po4a::Xml.3 \
+ Locale::Po4a::Dia.3 \
+ Locale::Po4a::Docbook.3 \
+ Locale::Po4a::Chooser.3 \
+ Locale::Po4a::TeX.3
+
+MAN1= po4a-translate.1 \
+ po4a.1 \
+ po4a-normalize.1 \
+ msguntypot.1 \
+ po4a-updatepo.1 \
+ po4a-gettextize.1
+
+.include <bsd.port.mk>
diff --git a/textproc/po4a/distinfo b/textproc/po4a/distinfo
new file mode 100644
index 000000000000..c015cd481941
--- /dev/null
+++ b/textproc/po4a/distinfo
@@ -0,0 +1,3 @@
+MD5 (po4a_0.23.orig.tar.gz) = 858a312cff483d7ff3e0db7dfaf759d1
+SHA256 (po4a_0.23.orig.tar.gz) = 0e448e6609efefb37436d3507ab6265df46c94bcab0ea41fad1602ee5b4d6f04
+SIZE (po4a_0.23.orig.tar.gz) = 736399
diff --git a/textproc/po4a/files/patch-Build.PL b/textproc/po4a/files/patch-Build.PL
new file mode 100644
index 000000000000..536be51f1f95
--- /dev/null
+++ b/textproc/po4a/files/patch-Build.PL
@@ -0,0 +1,11 @@
+--- Build.PL.orig Mon Jan 23 13:59:39 2006
++++ Build.PL Mon Jan 23 13:59:52 2006
+@@ -271,7 +271,7 @@
+ 'po4a-translate', 'po4a-normalize', 'po4a', 'msguntypot'],
+ add_to_cleanup => ['t/tmp','messages.mo', 'blib', 'html',
+ 'po/pod/po4a-pod.pot~', 'po4a.log'],
+- install_path => {po => $base.'/locale', man => $base.'/man'},
++ install_path => {po => $base.'/share/locale', man => $base.'/man'},
+ dist_abstract => 'Tools for helping translation of documentation',
+ dist_author => ['Martin Quinson (mquinson#debian.org)',
+ 'Denis Barbier <barbier@linuxfr.org>']
diff --git a/textproc/po4a/pkg-descr b/textproc/po4a/pkg-descr
new file mode 100644
index 000000000000..cc5c2ad82ceb
--- /dev/null
+++ b/textproc/po4a/pkg-descr
@@ -0,0 +1,16 @@
+tools for helping translation of documentation
+
+The po4a (po for anything) project goal is to ease translations
+(and more interestingly, the maintenance of translations) using
+gettext tools on areas where they were not expected like documentation.
+
+This package contains the main libraries of po4a, and the following sub-modules:
+
+ - KernelHelp: Help messages of each kernel compilation option.
+ - Man: Good old manual page format.
+ - Pod: Perl documentation format.
+ - Sgml: either debiandoc or docbook DTD.
+ - Dia: uncompressed Dia diagrams.
+ - LaTeX: generic TeX or LaTeX format
+
+WWW: http://packages.debian.org/unstable/text/po4a
diff --git a/textproc/po4a/pkg-plist b/textproc/po4a/pkg-plist
new file mode 100644
index 000000000000..2b536530d12c
--- /dev/null
+++ b/textproc/po4a/pkg-plist
@@ -0,0 +1,119 @@
+bin/po4a-normalize
+bin/po4a-gettextize
+bin/msguntypot
+bin/po4a-updatepo
+bin/po4a
+bin/po4a-translate
+man/ca/man1/po4a-normalize.1p.gz
+man/ca/man1/po4a-gettextize.1p.gz
+man/ca/man1/po4a-updatepo.1p.gz
+man/ca/man1/po4a-translate.1p.gz
+man/ca/man3/Locale::Po4a::Dia.3pm.gz
+man/ca/man3/Locale::Po4a::Po.3pm.gz
+man/ca/man3/Locale::Po4a::LaTeX.3pm.gz
+man/ca/man3/Locale::Po4a::Pod.3pm.gz
+man/ca/man3/Locale::Po4a::Xml.3pm.gz
+man/ca/man3/Locale::Po4a::TransTractor.3pm.gz
+man/ca/man3/Locale::Po4a::Guide.3pm.gz
+man/ca/man3/Locale::Po4a::KernelHelp.3pm.gz
+man/ca/man3/Locale::Po4a::Chooser.3pm.gz
+man/ca/man3/Locale::Po4a::Docbook.3pm.gz
+man/es/man1/po4a-normalize.1p.gz
+man/es/man1/po4a-gettextize.1p.gz
+man/es/man1/po4a-updatepo.1p.gz
+man/es/man1/po4a-translate.1p.gz
+man/es/man3/Locale::Po4a::Dia.3pm.gz
+man/es/man3/Locale::Po4a::Po.3pm.gz
+man/es/man3/Locale::Po4a::LaTeX.3pm.gz
+man/es/man3/Locale::Po4a::Pod.3pm.gz
+man/es/man3/Locale::Po4a::Xml.3pm.gz
+man/es/man3/Locale::Po4a::TransTractor.3pm.gz
+man/es/man3/Locale::Po4a::Guide.3pm.gz
+man/es/man3/Locale::Po4a::KernelHelp.3pm.gz
+man/es/man3/Locale::Po4a::Chooser.3pm.gz
+man/es/man3/Locale::Po4a::Docbook.3pm.gz
+man/fr/man1/po4a-normalize.1p.gz
+man/fr/man1/msguntypot.1p.gz
+man/fr/man1/po4a-gettextize.1p.gz
+man/fr/man1/po4a.1p.gz
+man/fr/man1/po4a-updatepo.1p.gz
+man/fr/man1/po4a-translate.1p.gz
+man/fr/man3/Locale::Po4a::Dia.3pm.gz
+man/fr/man3/Locale::Po4a::Po.3pm.gz
+man/fr/man3/Locale::Po4a::Man.3pm.gz
+man/fr/man3/Locale::Po4a::LaTeX.3pm.gz
+man/fr/man3/Locale::Po4a::Pod.3pm.gz
+man/fr/man3/Locale::Po4a::TeX.3pm.gz
+man/fr/man3/Locale::Po4a::TransTractor.3pm.gz
+man/fr/man3/Locale::Po4a::Xml.3pm.gz
+man/fr/man3/Locale::Po4a::Guide.3pm.gz
+man/fr/man3/Locale::Po4a::Docbook.3pm.gz
+man/fr/man3/Locale::Po4a::KernelHelp.3pm.gz
+man/fr/man3/Locale::Po4a::Chooser.3pm.gz
+man/fr/man3/Locale::Po4a::Sgml.3pm.gz
+man/fr/man3/Locale::Po4a::Text.3pm.gz
+man/fr/man3/Locale::Po4a::Common.3pm.gz
+man/it/man1/po4a-normalize.1p.gz
+man/it/man1/po4a-gettextize.1p.gz
+man/it/man1/po4a-updatepo.1p.gz
+man/it/man1/po4a-translate.1p.gz
+man/it/man3/Locale::Po4a::Dia.3pm.gz
+man/it/man3/Locale::Po4a::Pod.3pm.gz
+man/it/man3/Locale::Po4a::Guide.3pm.gz
+man/it/man3/Locale::Po4a::KernelHelp.3pm.gz
+man/it/man3/Locale::Po4a::Chooser.3pm.gz
+man/it/man3/Locale::Po4a::Docbook.3pm.gz
+man/pl/man1/po4a-normalize.1p.gz
+man/pl/man1/msguntypot.1p.gz
+man/pl/man1/po4a-gettextize.1p.gz
+man/pl/man1/po4a.1p.gz
+man/pl/man1/po4a-updatepo.1p.gz
+man/pl/man1/po4a-translate.1p.gz
+man/pl/man3/Locale::Po4a::Dia.3pm.gz
+man/pl/man3/Locale::Po4a::Po.3pm.gz
+man/pl/man3/Locale::Po4a::Man.3pm.gz
+man/pl/man3/Locale::Po4a::LaTeX.3pm.gz
+man/pl/man3/Locale::Po4a::Pod.3pm.gz
+man/pl/man3/Locale::Po4a::TeX.3pm.gz
+man/pl/man3/Locale::Po4a::TransTractor.3pm.gz
+man/pl/man3/Locale::Po4a::Xml.3pm.gz
+man/pl/man3/Locale::Po4a::Guide.3pm.gz
+man/pl/man3/Locale::Po4a::Docbook.3pm.gz
+man/pl/man3/Locale::Po4a::KernelHelp.3pm.gz
+man/pl/man3/Locale::Po4a::Chooser.3pm.gz
+man/pl/man3/Locale::Po4a::Sgml.3pm.gz
+man/pl/man3/Locale::Po4a::Text.3pm.gz
+man/pl/man3/Locale::Po4a::Common.3pm.gz
+man/man7/po4a.7.gz
+man/es/man7/po4a.7.gz
+man/fr/man7/po4a.7.gz
+man/pl/man7/po4a.7.gz
+man/ca/man7/po4a.7.gz
+%%SITE_PERL%%/Locale/Po4a/Pod.pm
+%%SITE_PERL%%/Locale/Po4a/Dia.pm
+%%SITE_PERL%%/Locale/Po4a/LaTeX.pm
+%%SITE_PERL%%/Locale/Po4a/Common.pm
+%%SITE_PERL%%/Locale/Po4a/Xml.pm
+%%SITE_PERL%%/Locale/Po4a/Docbook.pm
+%%SITE_PERL%%/Locale/Po4a/TeX.pm
+%%SITE_PERL%%/Locale/Po4a/KernelHelp.pm
+%%SITE_PERL%%/Locale/Po4a/Sgml.pm
+%%SITE_PERL%%/Locale/Po4a/Guide.pm
+%%SITE_PERL%%/Locale/Po4a/Po.pm
+%%SITE_PERL%%/Locale/Po4a/Man.pm
+%%SITE_PERL%%/Locale/Po4a/TransTractor.pm
+%%SITE_PERL%%/Locale/Po4a/Chooser.pm
+%%SITE_PERL%%/Locale/Po4a/Text.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/po4a/.packlist
+share/locale/af/LC_MESSAGES/po4a.mo
+share/locale/ca/LC_MESSAGES/po4a.mo
+share/locale/de/LC_MESSAGES/po4a.mo
+share/locale/cs/LC_MESSAGES/po4a.mo
+share/locale/es/LC_MESSAGES/po4a.mo
+share/locale/fr/LC_MESSAGES/po4a.mo
+share/locale/it/LC_MESSAGES/po4a.mo
+share/locale/pl/LC_MESSAGES/po4a.mo
+share/locale/ru/LC_MESSAGES/po4a.mo
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/po4a
+@dirrm %%SITE_PERL%%/Locale/Po4a
+@dirrmtry %%SITE_PERL%%/Locale