aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-27 22:48:01 +0800
committermiwi <miwi@FreeBSD.org>2011-06-27 22:48:01 +0800
commit5fde172544f56817eec022a2e78e59f0674127f9 (patch)
treeb9f673a07040bd143b83b9c3dcb1bb5ad6336836 /textproc
parent86bb8dec7da77403de5ce765257a2d7378e9da2a (diff)
downloadfreebsd-ports-gnome-5fde172544f56817eec022a2e78e59f0674127f9.tar.gz
freebsd-ports-gnome-5fde172544f56817eec022a2e78e59f0674127f9.tar.zst
freebsd-ports-gnome-5fde172544f56817eec022a2e78e59f0674127f9.zip
This is a port of Q's XML module, which also includes support for XSLT. The
module provides a simplified interface to the Gnome libxml2 and libxslt libraries, and supplies all the necessary data structures and operations to inspect, create, modify and transform XML documents with ease. WWW: http://docs.pure-lang.googlecode.com/hg/pure-xml.html PR: ports/156103 Submitted by: Zhihao Yuan <lichray at gmail.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/pure-xml/Makefile40
-rw-r--r--textproc/pure-xml/distinfo2
-rw-r--r--textproc/pure-xml/pkg-descr6
4 files changed, 49 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d7c42c5e2c53..863f0ea6bb0a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1011,6 +1011,7 @@
SUBDIR += print-n-times
SUBDIR += prosper
SUBDIR += pure-csv
+ SUBDIR += pure-xml
SUBDIR += py-4suite
SUBDIR += py-4suite-xml
SUBDIR += py-Chameleon
diff --git a/textproc/pure-xml/Makefile b/textproc/pure-xml/Makefile
new file mode 100644
index 000000000000..26ba3eb337c8
--- /dev/null
+++ b/textproc/pure-xml/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pure-xml
+# Date created: 2011-03-18
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-xml
+PORTVERSION= 0.6
+CATEGORIES= textproc
+MASTER_SITES= http://pure-lang.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Pure language interface for libxml2 and libxslt
+
+LIB_DEPENDS= pure.7:${PORTSDIR}/lang/pure
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GCC= 4.2+
+USE_GMAKE= yes
+USE_GNOME= libxml2 libxslt
+
+PLIST_FILES= lib/pure/xml.pure \
+ lib/pure/xml.so
+
+MAKE_ARGS+= prefix=${PREFIX} CPPFLAGS+=-I${LOCALBASE}/include \
+ LDFLAGS+=-L${LOCALBASE}/lib CFLAGS="${CFLAGS}"
+
+PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/pure-xml/distinfo b/textproc/pure-xml/distinfo
new file mode 100644
index 000000000000..24d1a29bb818
--- /dev/null
+++ b/textproc/pure-xml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure-xml-0.6.tar.gz) = f00b6b04688fc5e0ae41a5731176b8e471a3af10fcad61396caf812a64848899
+SIZE (pure-xml-0.6.tar.gz) = 50909
diff --git a/textproc/pure-xml/pkg-descr b/textproc/pure-xml/pkg-descr
new file mode 100644
index 000000000000..897500b6b31d
--- /dev/null
+++ b/textproc/pure-xml/pkg-descr
@@ -0,0 +1,6 @@
+This is a port of Q's XML module, which also includes support for XSLT. The
+module provides a simplified interface to the Gnome libxml2 and libxslt
+libraries, and supplies all the necessary data structures and operations to
+inspect, create, modify and transform XML documents with ease.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-xml.html