aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-13 00:41:31 +0800
committermiwi <miwi@FreeBSD.org>2009-03-13 00:41:31 +0800
commit5ff295ef804fbc96ccb372dd665fc8c68bbf7771 (patch)
tree1bd88a2a6eea4427853e81648806e7aeeac22814 /textproc
parent3b3422ae02c67b248522c94c34a2e9f5c75a6dbd (diff)
downloadfreebsd-ports-gnome-5ff295ef804fbc96ccb372dd665fc8c68bbf7771.tar.gz
freebsd-ports-gnome-5ff295ef804fbc96ccb372dd665fc8c68bbf7771.tar.zst
freebsd-ports-gnome-5ff295ef804fbc96ccb372dd665fc8c68bbf7771.zip
This extension provides WBXML (Wireless Binary XML) conversion capabilities
using the libwbxml library, which can be found at https://libwbxml.opensync.org/ WWW: http://pecl.php.net/package/WBXML/ PR: ports/132552 Submitted by: Florian Smeets <flo at kasimir.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/pecl-wbxml/Makefile24
-rw-r--r--textproc/pecl-wbxml/distinfo3
-rw-r--r--textproc/pecl-wbxml/files/patch-config.m424
-rw-r--r--textproc/pecl-wbxml/files/patch-wbxml.c13
-rw-r--r--textproc/pecl-wbxml/pkg-descr4
6 files changed, 69 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 52d49666e4e3..3e77e5a160a5 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -821,6 +821,7 @@
SUBDIR += pecl-html_parse
SUBDIR += pecl-stem
SUBDIR += pecl-syck
+ SUBDIR += pecl-wbxml
SUBDIR += pecl-xdiff
SUBDIR += pecl-xslcache
SUBDIR += perl2html
diff --git a/textproc/pecl-wbxml/Makefile b/textproc/pecl-wbxml/Makefile
new file mode 100644
index 000000000000..baee9ae1d0dd
--- /dev/null
+++ b/textproc/pecl-wbxml/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pecl-wbxml
+# Date created: 2009-03-11
+# Whom: Florian Smeets <flo@kasimir.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wbxml
+PORTVERSION= 1.0.3
+CATEGORIES= textproc pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= flo@kaismir.com
+COMMENT= A PECL extension that provides WBXML conversion capabilities
+
+LIB_DEPENDS= wbxml2.0:${PORTSDIR}/textproc/wbxml2
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/pecl-wbxml/distinfo b/textproc/pecl-wbxml/distinfo
new file mode 100644
index 000000000000..5a894a0abdf3
--- /dev/null
+++ b/textproc/pecl-wbxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/wbxml-1.0.3.tgz) = 9c6a4d347f9a2b4002ea0c83e4b14082
+SHA256 (PECL/wbxml-1.0.3.tgz) = 8a2e36aa1e59712614734a150d4bc2c09c1e7d1f9b90404beeb99d32d19d15ae
+SIZE (PECL/wbxml-1.0.3.tgz) = 5260
diff --git a/textproc/pecl-wbxml/files/patch-config.m4 b/textproc/pecl-wbxml/files/patch-config.m4
new file mode 100644
index 000000000000..fe970179e169
--- /dev/null
+++ b/textproc/pecl-wbxml/files/patch-config.m4
@@ -0,0 +1,24 @@
+--- config.m4.orig 2009-03-11 17:57:16.000000000 +0100
++++ config.m4 2009-03-11 17:57:27.000000000 +0100
+@@ -74,21 +74,6 @@
+ CFLAGS="$CFLAGS -Wall"
+ fi
+
+- AC_DEFINE(WBXML_ENCODER_USE_STRTBL,1,[ ])
+-
+- AC_DEFINE(WBXML_SUPPORT_WML,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_WTA,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_SI,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_SL,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_CO,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_PROV,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_EMN,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_DRMREL,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_OTA_SETTINGS,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_SYNCML,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_WV,1,[ ])
+- AC_DEFINE(WBXML_SUPPORT_AIRSYNC,1,[ ])
+-
+ PHP_SUBST(WBXML_SHARED_LIBADD)
+ PHP_NEW_EXTENSION(wbxml, wbxml.c, $ext_shared)
+ fi
diff --git a/textproc/pecl-wbxml/files/patch-wbxml.c b/textproc/pecl-wbxml/files/patch-wbxml.c
new file mode 100644
index 000000000000..11917b12954d
--- /dev/null
+++ b/textproc/pecl-wbxml/files/patch-wbxml.c
@@ -0,0 +1,13 @@
+--- wbxml.c.orig 2009-03-11 18:12:19.000000000 +0100
++++ wbxml.c 2009-03-11 18:12:27.000000000 +0100
+@@ -27,6 +27,10 @@
+ #include "ext/standard/info.h"
+ #include "php_wbxml.h"
+
++#ifdef HAVE_EXPAT
++#include "expat.h"
++#endif
++
+ #undef HAVE_LIBXML
+ #include "wbxml.h"
+
diff --git a/textproc/pecl-wbxml/pkg-descr b/textproc/pecl-wbxml/pkg-descr
new file mode 100644
index 000000000000..6574d9a1bcfe
--- /dev/null
+++ b/textproc/pecl-wbxml/pkg-descr
@@ -0,0 +1,4 @@
+This extension provides WBXML (Wireless Binary XML) conversion capabilities
+using the libwbxml library, which can be found at https://libwbxml.opensync.org/
+
+WWW: http://pecl.php.net/package/WBXML/