aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2012-06-28 03:52:13 +0800
committerjohans <johans@FreeBSD.org>2012-06-28 03:52:13 +0800
commit65aec6f1482cdbbcff15593ddd76dbc8010a8525 (patch)
tree00379e637907602d3fa097ccab787fbd98953ef4 /textproc
parent07eda3852bc78d11f86e85e0ee88cefbc606f615 (diff)
downloadfreebsd-ports-gnome-65aec6f1482cdbbcff15593ddd76dbc8010a8525.tar.gz
freebsd-ports-gnome-65aec6f1482cdbbcff15593ddd76dbc8010a8525.tar.zst
freebsd-ports-gnome-65aec6f1482cdbbcff15593ddd76dbc8010a8525.zip
Convert to new options framework
Diffstat (limited to 'textproc')
-rw-r--r--textproc/diffutils/Makefile10
-rw-r--r--textproc/flex/Makefile4
-rw-r--r--textproc/ocaml-pxp/Makefile8
3 files changed, 16 insertions, 6 deletions
diff --git a/textproc/diffutils/Makefile b/textproc/diffutils/Makefile
index 76033a6eeba6..160ab9f56b05 100644
--- a/textproc/diffutils/Makefile
+++ b/textproc/diffutils/Makefile
@@ -22,12 +22,14 @@ CONFIGURE_ARGS= --program-prefix=g
INFO= diffutils
MAN1= gcmp.1 gdiff.1 gdiff3.1 gsdiff.1
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.mk>
diff --git a/textproc/flex/Makefile b/textproc/flex/Makefile
index 90cdc8157a19..5a62260f9ab8 100644
--- a/textproc/flex/Makefile
+++ b/textproc/flex/Makefile
@@ -26,7 +26,9 @@ USE_GMAKE= yes
MAN1= flex.1
INFO= flex
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_ICONV= yes
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
diff --git a/textproc/ocaml-pxp/Makefile b/textproc/ocaml-pxp/Makefile
index 644a6460754a..553ad7eb0468 100644
--- a/textproc/ocaml-pxp/Makefile
+++ b/textproc/ocaml-pxp/Makefile
@@ -17,11 +17,17 @@ COMMENT= Validating XML parser for OCaml
BUILD_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
RUN_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
+OPTIONS_DEFINE= ULEX
+OPTIONS_DEFAULT=ULEX
+ULEX_DESC= Include UTF-8 lexical analyzer support
+
USE_OCAML= true
USE_OCAML_FINDLIB= true
USE_OCAML_LDCONFIG= true
-.if !defined(WITHOUT_ULEX)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MULEX}
BUILD_DEPENDS+= ${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
RUN_DEPENDS+= ${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
.endif