aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authordanger <danger@FreeBSD.org>2011-06-15 17:30:35 +0800
committerdanger <danger@FreeBSD.org>2011-06-15 17:30:35 +0800
commit7ea67a7b0e0954f004dd82074ead8d265c2800cc (patch)
tree579d4a392548ef8ba5507e4984e59de6adc07208 /textproc
parent00b3552c6c57a32108e0c8c4fdea975eb6755e29 (diff)
downloadfreebsd-ports-gnome-7ea67a7b0e0954f004dd82074ead8d265c2800cc.tar.gz
freebsd-ports-gnome-7ea67a7b0e0954f004dd82074ead8d265c2800cc.tar.zst
freebsd-ports-gnome-7ea67a7b0e0954f004dd82074ead8d265c2800cc.zip
- import a r2799 from upstream:
o) Fixed crash on WriteValue (affected MIPSEL arch and FreeBSD builds) o) http://code.google.com/p/sphinxsearch/source/detail?r=2799 Submitted by: Brian Eng <eng@vadriven.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/sphinxsearch-devel/Makefile1
-rw-r--r--textproc/sphinxsearch-devel/files/patch-src-sphinxstd.h20
2 files changed, 21 insertions, 0 deletions
diff --git a/textproc/sphinxsearch-devel/Makefile b/textproc/sphinxsearch-devel/Makefile
index 0f4e4066a09d..bf3413fd6eda 100644
--- a/textproc/sphinxsearch-devel/Makefile
+++ b/textproc/sphinxsearch-devel/Makefile
@@ -9,6 +9,7 @@
PORTNAME= sphinxsearch
PORTVERSION= 2.0.1b
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc databases
MASTER_SITES= http://sphinxsearch.com/files/
diff --git a/textproc/sphinxsearch-devel/files/patch-src-sphinxstd.h b/textproc/sphinxsearch-devel/files/patch-src-sphinxstd.h
new file mode 100644
index 000000000000..27c28f4b79b1
--- /dev/null
+++ b/textproc/sphinxsearch-devel/files/patch-src-sphinxstd.h
@@ -0,0 +1,20 @@
+--- src/sphinxstd.h~ 2011-04-01 16:50:14.000000000 +0000
++++ src/sphinxstd.h 2011-06-15 09:22:46.000000000 +0000
+@@ -1922,6 +1922,8 @@
+ T ReadValue() const
+ {
+ assert ( m_pValue );
++ if (!m_pValue)
++ return 0;
+ Lock();
+ T val = *m_pValue;
+ Unlock();
+@@ -1930,6 +1932,8 @@
+ void WriteValue ( const T& tNewValue )
+ {
+ assert ( m_pValue );
++ if (!m_pValue)
++ return;
+ Lock();
+ *m_pValue = tNewValue;
+ Unlock();