aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2002-09-19 03:16:28 +0800
committerseanc <seanc@FreeBSD.org>2002-09-19 03:16:28 +0800
commita2761841b604a4e2dd934249fcbae6a15fa8ec68 (patch)
tree2295c8a1428d928a69148951398882d7c766ce52 /textproc
parent690282fc4a10ba787fca0325c4086f5b9d3610f5 (diff)
downloadfreebsd-ports-gnome-a2761841b604a4e2dd934249fcbae6a15fa8ec68.tar.gz
freebsd-ports-gnome-a2761841b604a4e2dd934249fcbae6a15fa8ec68.tar.zst
freebsd-ports-gnome-a2761841b604a4e2dd934249fcbae6a15fa8ec68.zip
Add various tunables to aid developers using libxml2, most notably adding
the ability to turn on schema support. Approved by: knu (mentor) && marcus
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxml2/Makefile33
1 files changed, 29 insertions, 4 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 14d814e9085a..1246d1745513 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -40,12 +40,37 @@ PLIST_SUB+= PYTHON:="@comment "
PKGNAMESUFFIX= -nopython
.endif
-.if !defined(WITHOUT_PYTHON)
-pre-extract:
+.if defined(WITH_SCHEMA)
+CONFIGURE_ARGS+= --with-schemas
+.endif
+
+.if defined(WITH_MEM_DEBUG)
+CONFIGURE_ARGS+= --with-mem-debug
+.endif
+
+.if defined(WITH_XMLLINT_HIST)
+CONFIGURE_ARGS+= --with-history
+.endif
+
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+= --with-threads
+.endif
+
+.if defined(WITH_THREAD_ALLOC)
+CONFIGURE_ARGS+= --with-thread-alloc
+.endif
+
+pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} "If you don't want Python support, add WITHOUT_PYTHON=yes to command line"
+ @${ECHO_MSG} "libxml2 has the following tunables:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_PYTHON=yes Turns off Python support"
+ @${ECHO_MSG} " WITH_SCHEMA=yes Turns on XML Schema support"
+ @${ECHO_MSG} " WITH_MEM_DEBUG=yes Turns on memory debugging"
+ @${ECHO_MSG} " WITH_XMLLINT_HIST=yes Turns on history for xmllint"
+ @${ECHO_MSG} " WITH_THREADS=yes Turns on multi-threading support"
+ @${ECHO_MSG} " WITH_THREAD_ALLOC=yes Turns on per-thread memory"
@${ECHO_MSG} ""
-.endif
pre-patch:
@find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \