aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-11-07 18:40:30 +0800
committerpetef <petef@FreeBSD.org>2001-11-07 18:40:30 +0800
commitb132049cfc4cd9eff65ccf7593715f2bbf682aae (patch)
treef90db8ad53e5d49a5770a7db4ca5f3e5008b2de8 /textproc
parent551f40ac1d14b7ce35d49de618b339282804fda8 (diff)
downloadfreebsd-ports-gnome-b132049cfc4cd9eff65ccf7593715f2bbf682aae.tar.gz
freebsd-ports-gnome-b132049cfc4cd9eff65ccf7593715f2bbf682aae.tar.zst
freebsd-ports-gnome-b132049cfc4cd9eff65ccf7593715f2bbf682aae.zip
Add xxdiff-2.0, a QT interface to view/merge differences between 2 or
3 files.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xxdiff/Makefile37
-rw-r--r--textproc/xxdiff/distinfo1
-rw-r--r--textproc/xxdiff/files/patch-src::xxdiff.pro17
-rw-r--r--textproc/xxdiff/pkg-comment1
-rw-r--r--textproc/xxdiff/pkg-descr8
-rw-r--r--textproc/xxdiff/pkg-plist3
7 files changed, 68 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index fa3f1bb64b3f..379ce9233caf 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -240,6 +240,7 @@
SUBDIR += xsl-docbook-modular
SUBDIR += xslint
SUBDIR += xt
+ SUBDIR += xxdiff
SUBDIR += y2l
SUBDIR += yodl
diff --git a/textproc/xxdiff/Makefile b/textproc/xxdiff/Makefile
new file mode 100644
index 000000000000..1cd92b54b4d3
--- /dev/null
+++ b/textproc/xxdiff/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: xxdiff
+# Date created: 11 August 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xxdiff
+PORTVERSION= 2.0
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= petef@FreeBSD.org
+
+BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
+
+USE_GMAKE= yes
+USE_QT_VER= 2
+TMAKEENV= TMAKEPATH=${LOCALBASE}/share/tmake/freebsd-g++ QTDIR=${X11BASE}
+MAKE_ENV+= QTDIR=${X11BASE} PTHREAD_LIBS=${PTHREAD_LIBS}
+WRKSRC= ${WRKDIR}/xxdiff-${PORTVERSION}/src
+
+do-build:
+ (cd ${WRKSRC}; ${SETENV} ${TMAKEENV} tmake -o Makefile xxdiff.pro)
+ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xxdiff ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${WRKSRC}/xxdiff --help-html > ${WRKDIR}/xxdiff.html
+ ${INSTALL_DATA} ${WRKDIR}/xxdiff.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/xxdiff/distinfo b/textproc/xxdiff/distinfo
new file mode 100644
index 000000000000..bf0c1b2e96ee
--- /dev/null
+++ b/textproc/xxdiff/distinfo
@@ -0,0 +1 @@
+MD5 (xxdiff-2.0.tar.gz) = 80b3f814002c06ba3eac3470995ba0d7
diff --git a/textproc/xxdiff/files/patch-src::xxdiff.pro b/textproc/xxdiff/files/patch-src::xxdiff.pro
new file mode 100644
index 000000000000..355670493b8d
--- /dev/null
+++ b/textproc/xxdiff/files/patch-src::xxdiff.pro
@@ -0,0 +1,17 @@
+$FreeBSD$
+
+--- xxdiff.pro.orig Tue Nov 6 15:00:01 2001
++++ xxdiff.pro Wed Nov 7 02:22:25 2001
+@@ -80,6 +80,12 @@
+ solaris-cc:TMAKE_CXXFLAGS += -DCOMPILER_SUNWSPRO
+
+
++#
++# FreeBSD
++#
++freebsd-g++:TMAKE_LIBS += ${PTHREAD_LIBS}
++
++
+ # Add diff files to link against directly
+ DIFFUTILS_DIR = ../diffutils-2.7
+
diff --git a/textproc/xxdiff/pkg-comment b/textproc/xxdiff/pkg-comment
new file mode 100644
index 000000000000..14be8dc8a4fa
--- /dev/null
+++ b/textproc/xxdiff/pkg-comment
@@ -0,0 +1 @@
+QT interface to view/merge differences between 2 or 3 files
diff --git a/textproc/xxdiff/pkg-descr b/textproc/xxdiff/pkg-descr
new file mode 100644
index 000000000000..57afa10bac47
--- /dev/null
+++ b/textproc/xxdiff/pkg-descr
@@ -0,0 +1,8 @@
+xxdiff is a graphical browser for viewing the differences between
+two or three files, or between two directories, and can be used to
+produce a merged version.
+
+WWW: http://xxdiff.sourceforge.net/
+
+- Pete
+petef@FreeBSD.org
diff --git a/textproc/xxdiff/pkg-plist b/textproc/xxdiff/pkg-plist
new file mode 100644
index 000000000000..1bbad7691884
--- /dev/null
+++ b/textproc/xxdiff/pkg-plist
@@ -0,0 +1,3 @@
+bin/xxdiff
+%%PORTDOCS%%share/doc/xxdiff/xxdiff.html
+%%PORTDOCS%%@dirrm share/doc/xxdiff