aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2007-10-23 19:38:44 +0800
committergarga <garga@FreeBSD.org>2007-10-23 19:38:44 +0800
commitff5023b83a68c783c4738133850b18635f23b0ef (patch)
tree44bd2a91e3b755f50f4d72381b08381c9e4a7ff8 /textproc
parent1ce5c85c6bb914f9d70e0fb62ed11724b15de31f (diff)
downloadfreebsd-ports-gnome-ff5023b83a68c783c4738133850b18635f23b0ef.tar.gz
freebsd-ports-gnome-ff5023b83a68c783c4738133850b18635f23b0ef.tar.zst
freebsd-ports-gnome-ff5023b83a68c783c4738133850b18635f23b0ef.zip
KMFL aims to bring Tavultesoft Keyman functionality to *nix operating
systems. KMFL is being jointly developed by SIL International (http://www.sil.org) and Tavultesoft (http://www.tavultesoft.com). SCIM KMFL IMEngine allows you to use KMN keyboards (compiled with textproc/kmflcomp) through standard SCIM interface. The powerful KMN keyboard language supports contextual deadkeys, pre- and post-processing of keystrokes, rules grouping, 'storing' of character classes for use in similar rules, custom and Unicode character constants, SIL Ethnologue language codes, etc. Official Tavultesoft repository contains keyboards that cover more than 220 languages. Significant number of them are open source. Ported keyboards are textproc/scim-kmfl-*. WWW: http://kmfl.sourceforge.net/ PR: ports/117170 Submitted by: Nikola Lecic <nikola.lecic at anthesphoria.net>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/scim-kmfl-imengine/Makefile65
-rw-r--r--textproc/scim-kmfl-imengine/distinfo3
-rw-r--r--textproc/scim-kmfl-imengine/files/pkg-message.in12
-rw-r--r--textproc/scim-kmfl-imengine/pkg-descr17
-rw-r--r--textproc/scim-kmfl-imengine/pkg-plist9
6 files changed, 107 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 46354807f5e7..eceb2ec9d819 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -901,6 +901,7 @@
SUBDIR += sc-aspell
SUBDIR += scim
SUBDIR += scim-input-pad
+ SUBDIR += scim-kmfl-imengine
SUBDIR += scim-m17n
SUBDIR += scim-openvanilla
SUBDIR += scim-table-imengine
diff --git a/textproc/scim-kmfl-imengine/Makefile b/textproc/scim-kmfl-imengine/Makefile
new file mode 100644
index 000000000000..a8fb04993256
--- /dev/null
+++ b/textproc/scim-kmfl-imengine/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: scim-kmfl-imengine
+# Date created: 10 October 2007
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-kmfl-imengine
+PORTVERSION= 0.9.6
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://anthesphoria.net/files/distribution/
+MASTER_SITE_SUBDIR= kmfl
+DIST_SUBDIR= kmfl
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= SCIM KMFL IMEngine platform for Keyman (KMN) language keyboards
+
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
+ kmflcomp:${PORTSDIR}/textproc/kmflcomp
+LIB_DEPENDS= kmfl:${PORTSDIR}/textproc/libkmfl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gtk20 intltool intlhack pkgconfig glib20
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+USE_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+DOCSDIR= ${PREFIX}/share/doc/kmfl/${PORTNAME}
+PORTDOCS= AUTHORS COPYING ChangeLog
+SUB_FILES= pkg-message
+
+.if exists(${LOCALBASE}/bin/skim)
+pre-patch:
+ @${ECHO_MSG} ---------------------------------------------------------
+ @${ECHO_MSG} You have SKIM installed. KMFL-SCIM-IMEngine will work
+ @${ECHO_MSG} and you will be able to use textproc/scim-kmfl-* key-
+ @${ECHO_MSG} boards, but KMFL IME does not have SKIM frontend yet.
+ @${ECHO_MSG} Please refer to the textproc/kmflcomp docs on how to
+ @${ECHO_MSG} use KMFL keyboards in QT applications.
+ @${ECHO_MSG} ---------------------------------------------------------
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} \
+ 's|^install-data-am: install-libkmfldocDATA|install-data-am:|' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} \
+ 's|/usr/X11R6/lib|${LOCALBASE}/lib|' \
+ ${WRKSRC}/src/Makefile.in ${WRKSRC}/src/xkbmap.cpp
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+. endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/scim-kmfl-imengine/distinfo b/textproc/scim-kmfl-imengine/distinfo
new file mode 100644
index 000000000000..4e2a75e42985
--- /dev/null
+++ b/textproc/scim-kmfl-imengine/distinfo
@@ -0,0 +1,3 @@
+MD5 (kmfl/scim-kmfl-imengine-0.9.6.tar.gz) = eb86c820dbf2a2cfbe6ef3ed09519746
+SHA256 (kmfl/scim-kmfl-imengine-0.9.6.tar.gz) = a970cab91ca5fe9d238a44041c4584ff451ce9bb7f5fa7b29f0a2631f5ffdc4a
+SIZE (kmfl/scim-kmfl-imengine-0.9.6.tar.gz) = 462278
diff --git a/textproc/scim-kmfl-imengine/files/pkg-message.in b/textproc/scim-kmfl-imengine/files/pkg-message.in
new file mode 100644
index 000000000000..dc25050b57d6
--- /dev/null
+++ b/textproc/scim-kmfl-imengine/files/pkg-message.in
@@ -0,0 +1,12 @@
+
+------------------------------------------------------------------------
+ SCIM-Setup IMEngine list should now have KMFL section.
+
+ The documentation for KMN language and use of KMFL SCIM interface
+ is installed through textproc/kmflcomp port. Please refer to
+
+ %%PREFIX%%/share/doc/kmfl/kmflcomp/KMFL-Compiler.sxw
+
+ You need textproc/scim-kmfl-* ports in order to use actual keyboards
+ through SCIM.
+------------------------------------------------------------------------
diff --git a/textproc/scim-kmfl-imengine/pkg-descr b/textproc/scim-kmfl-imengine/pkg-descr
new file mode 100644
index 000000000000..3331231e6224
--- /dev/null
+++ b/textproc/scim-kmfl-imengine/pkg-descr
@@ -0,0 +1,17 @@
+KMFL aims to bring Tavultesoft Keyman functionality to *nix operating
+systems. KMFL is being jointly developed by SIL International
+(http://www.sil.org) and Tavultesoft (http://www.tavultesoft.com).
+
+SCIM KMFL IMEngine allows you to use KMN keyboards (compiled with
+textproc/kmflcomp) through standard SCIM interface.
+
+The powerful KMN keyboard language supports contextual deadkeys,
+pre- and post-processing of keystrokes, rules grouping, 'storing'
+of character classes for use in similar rules, custom and Unicode
+character constants, SIL Ethnologue language codes, etc.
+
+Official Tavultesoft repository contains keyboards that cover more
+than 220 languages. Significant number of them are open source.
+Ported keyboards are textproc/scim-kmfl-*.
+
+WWW: http://kmfl.sourceforge.net/
diff --git a/textproc/scim-kmfl-imengine/pkg-plist b/textproc/scim-kmfl-imengine/pkg-plist
new file mode 100644
index 000000000000..a9bb19e9c2f9
--- /dev/null
+++ b/textproc/scim-kmfl-imengine/pkg-plist
@@ -0,0 +1,9 @@
+lib/scim-1.0/1.4.0/IMEngine/kmfl.a
+lib/scim-1.0/1.4.0/IMEngine/kmfl.la
+lib/scim-1.0/1.4.0/IMEngine/kmfl.so
+lib/scim-1.0/1.4.0/SetupUI/kmfl_imengine_setup.a
+lib/scim-1.0/1.4.0/SetupUI/kmfl_imengine_setup.la
+lib/scim-1.0/1.4.0/SetupUI/kmfl_imengine_setup.so
+share/scim/kmfl/icons/default.png
+@dirrmtry share/scim/kmfl/icons
+@dirrmtry share/scim/kmfl