aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2018-03-16 05:50:20 +0800
committerbdrewery <bdrewery@FreeBSD.org>2018-03-16 05:50:20 +0800
commit02bd527ec27b922dce501fd79c81b43d8ddb5f82 (patch)
tree9ae8b898879ab3ac555005276cfeb6c04416c4f3 /textproc
parentc7610fcad2ffc487160a707c7d57c3f994448625 (diff)
downloadfreebsd-ports-gnome-02bd527ec27b922dce501fd79c81b43d8ddb5f82.tar.gz
freebsd-ports-gnome-02bd527ec27b922dce501fd79c81b43d8ddb5f82.tar.zst
freebsd-ports-gnome-02bd527ec27b922dce501fd79c81b43d8ddb5f82.zip
Stop touching the filesystem during build.
The pkg-install handles the scrollkeeper-rebuild and xmlcatalog needs. This also avoids: Shared object "libscrollkeeper.so.0" not found, required by "scrollkeeper-update"
Diffstat (limited to 'textproc')
-rw-r--r--textproc/scrollkeeper/Makefile3
-rw-r--r--textproc/scrollkeeper/files/patch-Makefile.in18
-rw-r--r--textproc/scrollkeeper/files/patch-extract_dtds_Makefile.in17
3 files changed, 22 insertions, 16 deletions
diff --git a/textproc/scrollkeeper/Makefile b/textproc/scrollkeeper/Makefile
index 2b147ac9025a..d3527ec8c04d 100644
--- a/textproc/scrollkeeper/Makefile
+++ b/textproc/scrollkeeper/Makefile
@@ -4,7 +4,7 @@
PORTNAME= scrollkeeper
PORTVERSION= 0.3.14
-PORTREVISION= 14
+PORTREVISION= 15
PORTEPOCH= 1
CATEGORIES= textproc gnome
MASTER_SITES= GNOME
@@ -45,7 +45,6 @@ post-patch:
${WRKSRC}/extract/dtds/Makefile.in
post-install:
- @${RM} ${STAGEDIR}/var/log/scrollkeeper.log
@${MKDIR} ${STAGEDIR}/var/db/scrollkeeper
.include <bsd.port.mk>
diff --git a/textproc/scrollkeeper/files/patch-Makefile.in b/textproc/scrollkeeper/files/patch-Makefile.in
index 26e75d4376dc..ef90085bcfa3 100644
--- a/textproc/scrollkeeper/files/patch-Makefile.in
+++ b/textproc/scrollkeeper/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Sat Dec 6 17:36:32 2003
-+++ Makefile.in Sat Dec 6 17:37:57 2003
-@@ -193,18 +193,6 @@
+--- Makefile.in.orig 2018-03-15 21:38:13 UTC
++++ Makefile.in
+@@ -193,18 +193,6 @@ EXTRA_DIST = \
scrollkeeper-spec.txt
@@ -19,7 +19,7 @@
scrollkeeper_localstate_dir = $(localstatedir)/@SCROLLKEEPER_PARTIAL_DB_DIR@
ACLOCAL_AMFLAGS = -I m4
-@@ -222,7 +210,7 @@
+@@ -222,7 +210,7 @@ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = config.h
CONFIG_CLEAN_FILES = intl/Makefile scrollkeeper.spec
DIST_SOURCES =
@@ -28,7 +28,7 @@
RECURSIVE_TARGETS = info-recursive dvi-recursive pdf-recursive \
-@@ -564,7 +552,6 @@
+@@ -564,7 +552,6 @@ check: check-recursive
all-am: Makefile $(DATA) config.h
installdirs: installdirs-recursive
installdirs-am:
@@ -36,3 +36,11 @@
install: install-recursive
install-exec: install-exec-recursive
+@@ -611,7 +598,6 @@ info-am:
+
+ install-data-am: install-scrollkeeperdocDATA
+ @$(NORMAL_INSTALL)
+- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
+
+ install-exec-am:
+
diff --git a/textproc/scrollkeeper/files/patch-extract_dtds_Makefile.in b/textproc/scrollkeeper/files/patch-extract_dtds_Makefile.in
index 1fb855079121..d641051b8e8e 100644
--- a/textproc/scrollkeeper/files/patch-extract_dtds_Makefile.in
+++ b/textproc/scrollkeeper/files/patch-extract_dtds_Makefile.in
@@ -1,11 +1,10 @@
---- extract/dtds/Makefile.in.orig Sat Dec 6 17:43:49 2003
-+++ extract/dtds/Makefile.in Sat Dec 6 17:43:49 2003
-@@ -408,7 +408,7 @@
+--- extract/dtds/Makefile.in.orig 2018-03-15 21:38:13 UTC
++++ extract/dtds/Makefile.in
+@@ -361,7 +361,6 @@ info-am:
- # ScrollKeeper OMF Variation DTD V1.0
- install-data-hook:
-- -/usr/bin/xmlcatalog --noout --add "public" \
-+ -%%LOCALBASE%%/bin/xmlcatalog --noout --add "public" \
- "-//OMF//DTD Scrollkeeper OMF Variant V1.0//EN" \
- "$(dtdsdir)/scrollkeeper-omf.dtd" $(CATALOG)
+ install-data-am: install-dtdsHEADERS
+ @$(NORMAL_INSTALL)
+- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
+
+ install-exec-am: