aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-01-27 12:56:52 +0800
committerpetef <petef@FreeBSD.org>2002-01-27 12:56:52 +0800
commit1f7d66c29cc7a83a611438835ac57def3c933191 (patch)
tree6cdfe27ab3f43e18b00ab6cc9296366d87bdae1c /textproc
parent34a992376e3ead888b8b9deca152f8548cc2af16 (diff)
downloadfreebsd-ports-gnome-1f7d66c29cc7a83a611438835ac57def3c933191.tar.gz
freebsd-ports-gnome-1f7d66c29cc7a83a611438835ac57def3c933191.tar.zst
freebsd-ports-gnome-1f7d66c29cc7a83a611438835ac57def3c933191.zip
Add p5-Lingua-EN-NameParse 1.16, perl routines for manipulating a
person's name. PR: 33381 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Lingua-EN-NameParse/Makefile27
-rw-r--r--textproc/p5-Lingua-EN-NameParse/distinfo1
-rw-r--r--textproc/p5-Lingua-EN-NameParse/pkg-comment1
-rw-r--r--textproc/p5-Lingua-EN-NameParse/pkg-descr7
-rw-r--r--textproc/p5-Lingua-EN-NameParse/pkg-plist8
6 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index fb4c94482ce4..efa016e3f789 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -112,6 +112,7 @@
SUBDIR += p5-Lingua-EN-Gender
SUBDIR += p5-Lingua-EN-Infinitive
SUBDIR += p5-Lingua-EN-Inflect
+ SUBDIR += p5-Lingua-EN-NameParse
SUBDIR += p5-Lingua-EN-Nickname
SUBDIR += p5-Lingua-EN-Numbers-Ordinate
SUBDIR += p5-Lingua-EN-Sentence
diff --git a/textproc/p5-Lingua-EN-NameParse/Makefile b/textproc/p5-Lingua-EN-NameParse/Makefile
new file mode 100644
index 000000000000..3c7f82ff30b4
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NameParse/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Lingua::EN::NameParse
+# Date created: 30 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Lingua-EN-NameParse
+PORTVERSION= 1.16
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Lingua
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= Lingua::EN::NameGrammar.3 \
+ Lingua::EN::NameParse.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Lingua-EN-NameParse/distinfo b/textproc/p5-Lingua-EN-NameParse/distinfo
new file mode 100644
index 000000000000..38dff98ce3ae
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NameParse/distinfo
@@ -0,0 +1 @@
+MD5 (Lingua-EN-NameParse-1.16.tar.gz) = 7037ff8e4ab4e58aa85b155671f571d2
diff --git a/textproc/p5-Lingua-EN-NameParse/pkg-comment b/textproc/p5-Lingua-EN-NameParse/pkg-comment
new file mode 100644
index 000000000000..beb210fff2c6
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NameParse/pkg-comment
@@ -0,0 +1 @@
+Perl routines for manipulating a person's name
diff --git a/textproc/p5-Lingua-EN-NameParse/pkg-descr b/textproc/p5-Lingua-EN-NameParse/pkg-descr
new file mode 100644
index 000000000000..5768c36b2a81
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NameParse/pkg-descr
@@ -0,0 +1,7 @@
+This module takes as input a person or persons name in free format
+text and attempts to parse it. If successful, the name is broken
+down into components and useful functions can be performed.
+
+WWW: http://search.cpan.org/search?dist=Lingua-EN-NameParse
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/textproc/p5-Lingua-EN-NameParse/pkg-plist b/textproc/p5-Lingua-EN-NameParse/pkg-plist
new file mode 100644
index 000000000000..af4463564abc
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NameParse/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/Lingua/EN/NameGrammar.pm
+lib/perl5/site_perl/%%PERL_VER%%/Lingua/EN/NameParse.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Lingua/EN/NameParse/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Lingua/EN/NameParse
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Lingua/EN 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Lingua 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Lingua/EN
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Lingua 2>/dev/null || true