aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-23 15:43:11 +0800
committeredwin <edwin@FreeBSD.org>2004-12-23 15:43:11 +0800
commit387ae91e764f59b0e149f58b2853fc70a54ce542 (patch)
treea69a43703f039e81a8cc3b49dcf8151738ce87e5 /textproc
parent456fb53ad93fc289d0fc758dd36d49bb8f59c310 (diff)
downloadfreebsd-ports-gnome-387ae91e764f59b0e149f58b2853fc70a54ce542.tar.gz
freebsd-ports-gnome-387ae91e764f59b0e149f58b2853fc70a54ce542.tar.zst
freebsd-ports-gnome-387ae91e764f59b0e149f58b2853fc70a54ce542.zip
[NEW PORT] textproc/tkxmlive - Tcl/Tk XML Intelligence Visual Editor
Tcl/TK XML Intelligence Visual Editor WWW: http://tkxmlive.sourceforge.netTcl/ PR: ports/70846 Submitted by: Nicola Vitale <nivit@email.it>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/tkxmlive/Makefile73
-rw-r--r--textproc/tkxmlive/distinfo1
-rw-r--r--textproc/tkxmlive/files/patch-interface.tcl10
-rw-r--r--textproc/tkxmlive/files/patch-tkxmlive8
-rw-r--r--textproc/tkxmlive/pkg-descr7
-rw-r--r--textproc/tkxmlive/pkg-plist51
7 files changed, 151 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 91c443633d7d..24e30a5aebd6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -629,6 +629,7 @@
SUBDIR += texi2html
SUBDIR += tinyxml
SUBDIR += tkdiff
+ SUBDIR += tkxmlive
SUBDIR += tl-aspell
SUBDIR += tn-aspell
SUBDIR += tnef2txt
diff --git a/textproc/tkxmlive/Makefile b/textproc/tkxmlive/Makefile
new file mode 100644
index 000000000000..44fe3a202df7
--- /dev/null
+++ b/textproc/tkxmlive/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: tkxmlive
+# Date created: 4 December 2003
+# Whom: nivit@users.sourceforge.net
+#
+# $FreeBSD$
+
+PORTNAME= tkxmlive
+PORTVERSION= 0.1.5
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= tkxmlive-0.1.5-1
+
+MAINTAINER= nivit@users.sourceforge.net
+COMMENT= Tcl/Tk XML Intelligence Visual Editor
+
+RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
+ ${LOCALBASE}/lib/bwidget/pkgIndex.tcl:${PORTSDIR}/x11-toolkits/bwidget
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+TK_VER?= 8.4
+WISH= wish${TK_VER}
+
+REPLACE_FILES= ${WRKSRC}/interface.tcl \
+ ${WRKSRC}/tkxmlive
+
+post-patch: .SILENT
+ for FILE in ${REPLACE_FILES}; do \
+ ${SED} -i .bak\
+ -e "/%%DATADIR%%/s//${DATADIR:S/\//\\\//g}/g" \
+ -e "/%%PREFIX%%/s//${PREFIX:S/\//\\\//g}/g" \
+ -e "/%%WISH%%/s//${WISH:S/\//\\\//g}/g" \
+ $${FILE}; \
+ done;
+
+LN_OPTS?= -sf
+
+FIND_ARGS1= -type d \! -empty
+FIND_ARGS2= -type f -and -perm -a+x -and \! \
+ -name "*.orig" \! -name "*.bak"
+FIND_ARGS3= -type f -and \! -perm -a+x -and \! \
+ -name "*.orig" \! -name "*~" \! \
+ -regex ".*[[:upper:]]+"
+
+do-install: .SILENT
+# Script and data
+ cd ${WRKSRC}; \
+ DIRS=$$(${FIND} . ${FIND_ARGS1}); \
+ for DIR in $${DIRS}; do \
+ ${MKDIR} ${DATADIR}/$${DIR}; \
+ done; \
+ FILES=$$(${FIND} . ${FIND_ARGS2}); \
+ for FILE in $${FILES}; do \
+ ${INSTALL_SCRIPT} $${FILE} ${DATADIR}/$${FILE}; \
+ done; \
+ FILES=$$(${FIND} -E . ${FIND_ARGS3}); \
+ for FILE in $${FILES}; do \
+ ${INSTALL_DATA} $${FILE} ${DATADIR}/$${FILE}; \
+ done;
+
+# Links to executables
+ cd ${WRKSRC}; \
+ FILES=${PORTNAME}; \
+ for f in $${FILES}; do \
+ ${LN} ${LN_OPTS} ${DATADIR}/$${f} ${PREFIX}/bin/$${f}; \
+ done;
+
+.include <bsd.port.post.mk>
diff --git a/textproc/tkxmlive/distinfo b/textproc/tkxmlive/distinfo
new file mode 100644
index 000000000000..73e36348ef59
--- /dev/null
+++ b/textproc/tkxmlive/distinfo
@@ -0,0 +1 @@
+MD5 (tkxmlive-0.1.5-1.tar.gz) = e369fb667db3aee67359880e228bf786
diff --git a/textproc/tkxmlive/files/patch-interface.tcl b/textproc/tkxmlive/files/patch-interface.tcl
new file mode 100644
index 000000000000..0d34ef9852df
--- /dev/null
+++ b/textproc/tkxmlive/files/patch-interface.tcl
@@ -0,0 +1,10 @@
+--- interface.tcl Thu May 30 23:56:36 2002
++++ interface.tcl.new Fri Feb 20 11:06:41 2004
+@@ -1,4 +1,6 @@
+-#!/usr/bin/wish
++#!/bin/sh
++# The next line restarts using %%WISH%% \
++exec %%WISH%% "$0"
+
+
+ package require msgcat
diff --git a/textproc/tkxmlive/files/patch-tkxmlive b/textproc/tkxmlive/files/patch-tkxmlive
new file mode 100644
index 000000000000..c643994d2d34
--- /dev/null
+++ b/textproc/tkxmlive/files/patch-tkxmlive
@@ -0,0 +1,8 @@
+--- tkxmlive Tue Mar 26 17:21:14 2002
++++ tkxmlive.port Thu Dec 4 13:49:54 2003
+@@ -1,4 +1,4 @@
+ #!/bin/sh
+
+-cd /home/alex/work/aspirantura/tmp
++cd %%DATADIR%%
+ ./interface.tcl
diff --git a/textproc/tkxmlive/pkg-descr b/textproc/tkxmlive/pkg-descr
new file mode 100644
index 000000000000..8ee26288f5ef
--- /dev/null
+++ b/textproc/tkxmlive/pkg-descr
@@ -0,0 +1,7 @@
+Tcl/TK XML Intelligence Visual Editor
+
+WWW: http://tkxmlive.sourceforge.net/
+
+--
+Nicola Vitale
+nivit@users.sourceforge.net
diff --git a/textproc/tkxmlive/pkg-plist b/textproc/tkxmlive/pkg-plist
new file mode 100644
index 000000000000..a5bde0716308
--- /dev/null
+++ b/textproc/tkxmlive/pkg-plist
@@ -0,0 +1,51 @@
+bin/tkxmlive
+%%DATADIR%%/Xresource
+%%DATADIR%%/book.css
+%%DATADIR%%/book.xml
+%%DATADIR%%/gui/default.tcl
+%%DATADIR%%/gui/gui.xml
+%%DATADIR%%/gui/msgs/en.msg
+%%DATADIR%%/gui/msgs/ru.msg
+%%DATADIR%%/img/del_tag.gif
+%%DATADIR%%/img/err-img.gif
+%%DATADIR%%/img/info_tag.gif
+%%DATADIR%%/img/ins_after_tag.gif
+%%DATADIR%%/img/ins_before_tag.gif
+%%DATADIR%%/img/ins_in_tag.gif
+%%DATADIR%%/img/panel.gif
+%%DATADIR%%/interface.tcl
+%%DATADIR%%/library/gridbox.tcl
+%%DATADIR%%/library/gui.tcl
+%%DATADIR%%/library/pane.tcl
+%%DATADIR%%/library/parsexml.tcl
+%%DATADIR%%/library/pkgIndex.tcl
+%%DATADIR%%/library/richtext-bind.tcl
+%%DATADIR%%/library/richtext-instag.tcl
+%%DATADIR%%/library/richtext-status.tcl
+%%DATADIR%%/library/richtext-updatewidget.tcl
+%%DATADIR%%/library/richtext.tcl
+%%DATADIR%%/library/scrolled_text.tcl
+%%DATADIR%%/library/simcss.tcl
+%%DATADIR%%/library/simxml.tcl
+%%DATADIR%%/library/tmp.tcl
+%%DATADIR%%/sample/article/article-1.xml
+%%DATADIR%%/sample/article/article-2.xml
+%%DATADIR%%/sample/article/article-3.xml
+%%DATADIR%%/sample/article/article-3.xml.html
+%%DATADIR%%/sample/article/article-clear.css
+%%DATADIR%%/sample/article/article.css
+%%DATADIR%%/sample/article/article.xml
+%%DATADIR%%/sample/article/article.xsl
+%%DATADIR%%/sample/article/article2latex.xsl
+%%DATADIR%%/sample/article/translate.sh
+%%DATADIR%%/sample/article/xsl2tex.sh
+%%DATADIR%%/sample/docbook.css
+%%DATADIR%%/sample/docbook.xml
+%%DATADIR%%/tkxmlive
+@dirrm %%DATADIR%%/gui/msgs
+@dirrm %%DATADIR%%/gui
+@dirrm %%DATADIR%%/img
+@dirrm %%DATADIR%%/library
+@dirrm %%DATADIR%%/sample/article
+@dirrm %%DATADIR%%/sample
+@dirrm %%DATADIR%%/