aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2003-07-29 23:16:33 +0800
committermi <mi@FreeBSD.org>2003-07-29 23:16:33 +0800
commit3f92308f9abf0b20d0b301ba40d7ee8cc9608161 (patch)
tree67e1d30fa3098162e2a8703b4e0f10561c4d955d /textproc
parenta2cb3ee73b18f6b1c1f19e84e69aa8bcf2b8a9dc (diff)
downloadfreebsd-ports-gnome-3f92308f9abf0b20d0b301ba40d7ee8cc9608161.tar.gz
freebsd-ports-gnome-3f92308f9abf0b20d0b301ba40d7ee8cc9608161.tar.zst
freebsd-ports-gnome-3f92308f9abf0b20d0b301ba40d7ee8cc9608161.zip
The port was broken by the automatic REINPLACE_CMD conversion, as it used
Perl's syntax for replacements. It was officially marked BROKEN by kris this May. This commit fixes the replacements and removes three directories, which are created by the py-xml port, from the pkg-plist. The maintainer did not react to the breakage in a very long time, so I take the liberty of fixing the port without waiting for too much longer. Approved by: maintainer timeout
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-4suite/Makefile15
-rw-r--r--textproc/py-4suite/pkg-plist3
2 files changed, 7 insertions, 11 deletions
diff --git a/textproc/py-4suite/Makefile b/textproc/py-4suite/Makefile
index f8e463c0ebef..8849ff38ce82 100644
--- a/textproc/py-4suite/Makefile
+++ b/textproc/py-4suite/Makefile
@@ -7,7 +7,7 @@
PORTNAME= 4suite
PORTVERSION= 0.11.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc python
MASTER_SITES= ftp://ftp.4suite.org/pub/4Suite/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,12 +16,11 @@ DISTNAME= 4Suite-${PORTVERSION}
MAINTAINER= wjv@FreeBSD.org
COMMENT= A collection of Python tools for XML processing and object database management
-BROKEN= "Broken pkg-plist"
-
BUILD_DEPENDS= ${PYXML}
RUN_DEPENDS= ${PYXML}
USE_REINPLACE= yes
+REINPLACE_ARGS= -i "" -E
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_INSTALLARGS= -c -O1 --prefix=${PREFIX} \
@@ -35,12 +34,12 @@ PLIST_SUB+= PACKAGE_DIR=_xmlplus PYTHON2_ONLY=""
.endif
post-patch:
- @ ${REINPLACE_CMD} -e \
- 's#(copy_to=.)docs#$$1doc/${PORTNAME}#; \
- s#(copy_to=.)(test_suite|demo)#$$1examples/${PORTNAME}/$$2#' \
- ${WRKSRC}/setup.py
+ @ ${REINPLACE_CMD} \
+ -e 's#(copy_to=.)docs#\1doc/${PORTNAME}#' \
+ -e 's#(copy_to=.)(test_suite|demo)#\1examples/${PORTNAME}/\2#' \
+ ${WRKSRC}/setup.py
.if defined(NOPORTDOCS)
- @ ${REINPLACE_CMD} -e 's/(data_files=)data_files/$$1/' \
+ @ ${REINPLACE_CMD} -e 's/(data_files=)data_files/\1/' \
${WRKSRC}/setup.py
.endif
diff --git a/textproc/py-4suite/pkg-plist b/textproc/py-4suite/pkg-plist
index d02d73f0f5d7..a10a32a836b6 100644
--- a/textproc/py-4suite/pkg-plist
+++ b/textproc/py-4suite/pkg-plist
@@ -1557,6 +1557,3 @@ lib/%%PYTHON_VERSION%%/site-packages/Ft/__init__.pyo
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Ft/Lib
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Ft
@dirrm lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/xslt/Debugger
-@dirrm lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/xslt
-@dirrm lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%%/xpath
-@unexec rmdir %D/lib/%%PYTHON_VERSION%%/site-packages/%%PACKAGE_DIR%% 2>/dev/null || true