aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-12-14 05:56:50 +0800
committerrakuco <rakuco@FreeBSD.org>2015-12-14 05:56:50 +0800
commit425ab2f470108aa2b2e552dfed54e18a676fdd64 (patch)
treec8ea48f297bee52a8d84f4ec84da2d9fa23078a5 /textproc
parentc9f665c0b4d537f42b2c6ec9d10e14303cc2afea (diff)
downloadfreebsd-ports-gnome-425ab2f470108aa2b2e552dfed54e18a676fdd64.tar.gz
freebsd-ports-gnome-425ab2f470108aa2b2e552dfed54e18a676fdd64.tar.zst
freebsd-ports-gnome-425ab2f470108aa2b2e552dfed54e18a676fdd64.zip
At very long last land PyQt5 5.5.1 ports.
Add the required bits to Uses/pyqt.mk along with all the PyQt5 ports. Thankfully this commit is mostly adding new ports, as the hard work was already done in r403297 and r403662. Huge kudos to Tobias Berner <tcberner@gmail.com> and, most importantly, Guido Falsi (madpilot@) for their initial work on these ports (see D2910 in Phabricator for an earlier version of the PyQt5 patch set). PR: 204672
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile2
-rw-r--r--textproc/py-qt5-xml/Makefile26
-rw-r--r--textproc/py-qt5-xml/pkg-descr4
-rw-r--r--textproc/py-qt5-xml/pkg-plist7
-rw-r--r--textproc/py-qt5-xmlpatterns/Makefile26
-rw-r--r--textproc/py-qt5-xmlpatterns/pkg-descr4
-rw-r--r--textproc/py-qt5-xmlpatterns/pkg-plist17
7 files changed, 86 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0e734f587bdb..2f03c42dc8e0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1261,6 +1261,8 @@
SUBDIR += py-qrcode
SUBDIR += py-qt4-xml
SUBDIR += py-qt4-xmlpatterns
+ SUBDIR += py-qt5-xml
+ SUBDIR += py-qt5-xmlpatterns
SUBDIR += py-rdflib
SUBDIR += py-regex
SUBDIR += py-reverend
diff --git a/textproc/py-qt5-xml/Makefile b/textproc/py-qt5-xml/Makefile
new file mode 100644
index 000000000000..1851bf85dc03
--- /dev/null
+++ b/textproc/py-qt5-xml/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= xml
+CATEGORIES= textproc devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtXml module
+
+CONFIGURE_ARGS= --enable QtXml
+PYQT_DIST= yes
+
+USES= python pyqt:5
+USE_PYQT= sip_build core_run
+USE_QT5= core xml buildtools_build qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtXml API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2-qt5.so:${PORTSDIR}/devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+.include <bsd.port.mk>
diff --git a/textproc/py-qt5-xml/pkg-descr b/textproc/py-qt5-xml/pkg-descr
new file mode 100644
index 000000000000..91d5b1b08121
--- /dev/null
+++ b/textproc/py-qt5-xml/pkg-descr
@@ -0,0 +1,4 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtXml module.
+
+WWW: http://www.riverbankcomputing.co.uk/software/pyqt/
diff --git a/textproc/py-qt5-xml/pkg-plist b/textproc/py-qt5-xml/pkg-plist
new file mode 100644
index 000000000000..99bc8dd71868
--- /dev/null
+++ b/textproc/py-qt5-xml/pkg-plist
@@ -0,0 +1,7 @@
+bin/pylupdate5
+bin/pyrcc5
+%%PYTHON_SITELIBDIR%%/PyQt5/QtXml.so
+%%PYQT_SIPDIR%%/QtXml/QtXmlmod.sip
+%%PYQT_SIPDIR%%/QtXml/qdom.sip
+%%PYQT_SIPDIR%%/QtXml/qxml.sip
+%%API%%share/qt5/qsci/api/python/QtXml.api
diff --git a/textproc/py-qt5-xmlpatterns/Makefile b/textproc/py-qt5-xmlpatterns/Makefile
new file mode 100644
index 000000000000..b7a9e65828d5
--- /dev/null
+++ b/textproc/py-qt5-xmlpatterns/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= xmlpatterns
+CATEGORIES= textproc devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtXmlPatterns module
+
+CONFIGURE_ARGS= --enable QtXmlPatterns
+PYQT_DIST= yes
+
+USES= python pyqt:5
+USE_PYQT= sip_build core_run network_run
+USE_QT5= core network xmlpatterns qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtXmlPatterns API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2-qt5.so:${PORTSDIR}/devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+.include <bsd.port.mk>
diff --git a/textproc/py-qt5-xmlpatterns/pkg-descr b/textproc/py-qt5-xmlpatterns/pkg-descr
new file mode 100644
index 000000000000..544d322fd86b
--- /dev/null
+++ b/textproc/py-qt5-xmlpatterns/pkg-descr
@@ -0,0 +1,4 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtXmlPatterns module.
+
+WWW: http://www.riverbankcomputing.co.uk/software/pyqt/
diff --git a/textproc/py-qt5-xmlpatterns/pkg-plist b/textproc/py-qt5-xmlpatterns/pkg-plist
new file mode 100644
index 000000000000..20d9892a42d2
--- /dev/null
+++ b/textproc/py-qt5-xmlpatterns/pkg-plist
@@ -0,0 +1,17 @@
+%%PYTHON_SITELIBDIR%%/PyQt5/QtXmlPatterns.so
+%%PYQT_SIPDIR%%/QtXmlPatterns/QtXmlPatternsmod.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qabstractmessagehandler.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qabstracturiresolver.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qabstractxmlnodemodel.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qabstractxmlreceiver.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qsimplexmlnodemodel.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qsourcelocation.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlformatter.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlname.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlnamepool.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlquery.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlresultitems.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlschema.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlschemavalidator.sip
+%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlserializer.sip
+%%API%%share/qt5/qsci/api/python/QtXmlPatterns.api