aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-22 07:05:13 +0800
committeradamw <adamw@FreeBSD.org>2014-08-22 07:05:13 +0800
commit502eac3640504081f2a18eccf59fc92b61252e44 (patch)
tree779151ff645495de3cc9879d4d08b48a8a922cd6 /textproc
parentb0113421712e3e2543fa9e1e0726502ef475e372 (diff)
downloadfreebsd-ports-gnome-502eac3640504081f2a18eccf59fc92b61252e44.tar.gz
freebsd-ports-gnome-502eac3640504081f2a18eccf59fc92b61252e44.tar.zst
freebsd-ports-gnome-502eac3640504081f2a18eccf59fc92b61252e44.zip
Mark BROKEN.
creating libAiksaurusGTK.la (cd .libs && rm -f libAiksaurusGTK.la && ln -s ../libAiksaurusGTK.la libAiksaurusGTK.la) if c++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../base -I/usr/local/include/gtk-2.0 -I/usr/local/include/gio-unix-2.0/ -I/usr/local/include/atk-1.0 -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -D_THREAD_SAFE -I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/libpng15 -I/usr/local/include/pango-1.0 -pthread -I/usr/local/include/glib-2.0 -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include/harfbuzz -O2 -pipe -fno-strict-aliasing -MT gtkAiksaur.t.o -MD -MP -MF ".deps/gtkAiksaur.t.Tpo" -c -o gtkAiksaur.t.o gtkAiksaur.t.cpp; \ then mv -f ".deps/gtkAiksaur.t.Tpo" ".deps/gtkAiksaur.t.Po"; else rm -f ".deps/gtkAiksaur.t.Tpo"; exit 1; fi /bin/sh ../../libtool --mode=link c++ -I/usr/local/include/gtk-2.0 -I/usr/local/include/gio-unix-2.0/ -I/usr/local/include/atk-1.0 -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -D_THREAD_SAFE -I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/libpng15 -I/usr/local/include/pango-1.0 -pthread -I/usr/local/include/glib-2.0 -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include/harfbuzz -O2 -pipe -fno-strict-aliasing -o gaiksaurus gtkAiksaur.t.o libAiksaurusGTK.la c++ -I/usr/local/include/gtk-2.0 -I/usr/local/include/gio-unix-2.0/ -I/usr/local/include/atk-1.0 -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -D_THREAD_SAFE -I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/libpng15 -I/usr/local/include/pango-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include/harfbuzz -O2 -pipe -fno-strict-aliasing -o .libs/gaiksaurus gtkAiksaur.t.o -pthread ./.libs/libAiksaurusGTK.so -L/usr/local/lib -lz -Wl,--rpath -Wl,/usr/local/lib /usr/bin/ld: .: invalid DSO for symbol `gtk_init' definition /usr/local/lib/libgtk-x11-2.0.so.0: could not read symbols: Bad value c++: error: linker command failed with exit code 1 (use -v to see invocation) gmake[4]: *** [gaiksaurus] Error 1 gmake[4]: Leaving directory `/wrkdirs/usr/ports/textproc/aiksaurus-gtk/work/aiksaurus-1.2.1/gtk/src'
Diffstat (limited to 'textproc')
-rw-r--r--textproc/aiksaurus-gtk/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/textproc/aiksaurus-gtk/Makefile b/textproc/aiksaurus-gtk/Makefile
index 269971b05001..ad1a52a6383b 100644
--- a/textproc/aiksaurus-gtk/Makefile
+++ b/textproc/aiksaurus-gtk/Makefile
@@ -14,6 +14,8 @@ PKGDIR= ${.CURDIR}
USE_GNOME= gtk20
CONFIGURE_ARGS=--with-gtk
+BROKEN= does not link against GTK2
+
pre-install:
@${REINPLACE_CMD} -e 's|base [$$][(]GTKSRCDIR[)] data|$$(GTKSRCDIR)|g' \
${WRKSRC}/Makefile