aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-01-15 18:01:19 +0800
committerdanfe <danfe@FreeBSD.org>2018-01-15 18:01:19 +0800
commit544d4ad508ec020bce79532d7d03a0ac4ed0b65e (patch)
treeeb4b7d9c2dfb682c10a8bad79238d252f06c69fb /textproc
parente051ebe986a1748aec1e8626164a9dedf71ba22a (diff)
downloadfreebsd-ports-gnome-544d4ad508ec020bce79532d7d03a0ac4ed0b65e.tar.gz
freebsd-ports-gnome-544d4ad508ec020bce79532d7d03a0ac4ed0b65e.tar.zst
freebsd-ports-gnome-544d4ad508ec020bce79532d7d03a0ac4ed0b65e.zip
Unbreak with pre-C++11 compilers, e.g. with gcc 4.2.1 which is still the
default compiler on some tier-2 architectures like powerpc and sparc64, by using identical types from C's <stdint.h> rather than C++'s <cstdint> header file. While here, convert to USES+=localbase. PR: 225171 Reported by: jhibbits
Diffstat (limited to 'textproc')
-rw-r--r--textproc/teckit/Makefile10
-rw-r--r--textproc/teckit/files/patch-SFconv_UtfCodec.h15
2 files changed, 21 insertions, 4 deletions
diff --git a/textproc/teckit/Makefile b/textproc/teckit/Makefile
index 6c48a6dba40a..0f0c7bdc346d 100644
--- a/textproc/teckit/Makefile
+++ b/textproc/teckit/Makefile
@@ -14,21 +14,23 @@ LICENSE_FILE= ${WRKSRC}/license/LICENSING.txt
LIB_DEPENDS= libexpat.so:textproc/expat2
-USES= autoreconf libtool pkgconfig
+USES= autoreconf libtool localbase pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= silnrsi
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
DOCS= AUTHORS README NEWS docs/*.pdf license/LICENSING.txt
OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} -e '/sfconv_CXXFLAGS = -std=c++11/d' \
+ ${WRKSRC}/bin/Makefile.am
+
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/textproc/teckit/files/patch-SFconv_UtfCodec.h b/textproc/teckit/files/patch-SFconv_UtfCodec.h
new file mode 100644
index 000000000000..c4731e9c8bf4
--- /dev/null
+++ b/textproc/teckit/files/patch-SFconv_UtfCodec.h
@@ -0,0 +1,15 @@
+--- SFconv/UtfCodec.h.orig 2017-06-23 19:39:26 UTC
++++ SFconv/UtfCodec.h
+@@ -28,11 +28,7 @@ of the License or (at your option) any l
+
+ #include <cstddef>
+ #include <cstdlib>
+-#include <cstdint>
+-
+-using std::int8_t;
+-using std::uint8_t;
+-using std::ptrdiff_t;
++#include <stdint.h>
+
+ typedef uint32_t uchar_t;
+