aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2017-05-24 23:01:17 +0800
committerskreuzer <skreuzer@FreeBSD.org>2017-05-24 23:01:17 +0800
commit54e3fd0d3a70bef904021f045c615d0a212faa1b (patch)
tree884701100a12f9dc160e319b4ea3cf028992b822 /textproc
parent1b937cb59bd50c37441183052090d028b162b239 (diff)
downloadfreebsd-ports-gnome-54e3fd0d3a70bef904021f045c615d0a212faa1b.tar.gz
freebsd-ports-gnome-54e3fd0d3a70bef904021f045c615d0a212faa1b.tar.zst
freebsd-ports-gnome-54e3fd0d3a70bef904021f045c615d0a212faa1b.zip
Parsel is a library to extract data from HTML and XML using XPath and CSS
selectors. PR: 219309 Submitted by: Eric Camachat <eric@camachat.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-parsel/Makefile23
-rw-r--r--textproc/py-parsel/distinfo3
-rw-r--r--textproc/py-parsel/pkg-descr8
4 files changed, 35 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6cb8830fac7d..a7284a67291f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1290,6 +1290,7 @@
SUBDIR += py-openpyxl
SUBDIR += py-pandocfilters
SUBDIR += py-paragrep
+ SUBDIR += py-parsel
SUBDIR += py-parsimonious
SUBDIR += py-pdfminer
SUBDIR += py-pss
diff --git a/textproc/py-parsel/Makefile b/textproc/py-parsel/Makefile
new file mode 100644
index 000000000000..03662d7d573d
--- /dev/null
+++ b/textproc/py-parsel/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= parsel
+PORTVERSION= 1.1.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= eric@camachat.org
+COMMENT= Parsel is a library to extract data from HTML and XML using XPath and CSS selectors
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=2.0.0:devel/py-pytest-runner
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cssselect>=0.9:www/py-cssselect \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=3.2.4:devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.5.2:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}w3lib>=1.8.0:www/py-w3lib
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/textproc/py-parsel/distinfo b/textproc/py-parsel/distinfo
new file mode 100644
index 000000000000..c40643c7277c
--- /dev/null
+++ b/textproc/py-parsel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1494866042
+SHA256 (parsel-1.1.0.tar.gz) = 2735b61a4d56b58eab02b793491f5a639ba74425e494d9cafa2ec80558686428
+SIZE (parsel-1.1.0.tar.gz) = 32243
diff --git a/textproc/py-parsel/pkg-descr b/textproc/py-parsel/pkg-descr
new file mode 100644
index 000000000000..17dc00f87c73
--- /dev/null
+++ b/textproc/py-parsel/pkg-descr
@@ -0,0 +1,8 @@
+Parsel is a library to extract data from HTML and XML using XPath and CSS
+selectors.
+
+Features
+ - Extract text using CSS or XPath selectors
+ - Regular expression helper methods
+
+WWW: https://github.com/scrapy/parsel