aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-18 14:03:27 +0800
committermiwi <miwi@FreeBSD.org>2013-02-18 14:03:27 +0800
commit5cca7f31c39e97950297e4bf98a99054abb095e0 (patch)
treeeb99166962e871cc85db7decfde27e244aa42caf /textproc
parent2b34cbe29dddf09c88170db480ba5219f6ca7756 (diff)
downloadfreebsd-ports-gnome-5cca7f31c39e97950297e4bf98a99054abb095e0.tar.gz
freebsd-ports-gnome-5cca7f31c39e97950297e4bf98a99054abb095e0.tar.zst
freebsd-ports-gnome-5cca7f31c39e97950297e4bf98a99054abb095e0.zip
xmlgen is a TCL package to write XML documents in Tcl.
This XML code is expressed by TCL code, which is translated. Every tag is made into a markup command which takes attributes and the element's content as parameters and then prints the XML tagged content. Of course, the content again can contain markup commands. WWW: http://tclxml.sourceforge.net/ PR: ports/175391 Submitted by: Sébastien Santoro <dereckson@gmail.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xmlgen/Makefile20
-rw-r--r--textproc/xmlgen/distinfo2
-rw-r--r--textproc/xmlgen/pkg-descr9
-rw-r--r--textproc/xmlgen/pkg-plist11
5 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8e32f4103972..ee5a1bc47202 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1504,6 +1504,7 @@
SUBDIR += xmldiff
SUBDIR += xmlenc
SUBDIR += xmlformat
+ SUBDIR += xmlgen
SUBDIR += xmlindent
SUBDIR += xmlppm
SUBDIR += xmlprpr
diff --git a/textproc/xmlgen/Makefile b/textproc/xmlgen/Makefile
new file mode 100644
index 000000000000..fe792e67cfe5
--- /dev/null
+++ b/textproc/xmlgen/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sébastien Santoro <dereckson@gmail.com>
+# $FreeBSD$
+
+PORTNAME= xmlgen
+PORTVERSION= 1.4
+CATEGORIES= textproc tcl
+MASTER_SITES= SF/tclxml/${PORTNAME}/v${PORTVERSION}
+
+MAINTAINER= dereckson@gmail.com
+COMMENT= Write XML documents using Tcl
+
+USE_TCL= 83+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ cd ${WRKSRC} && ${TCLSH} bras-sa PKGDIR=${PREFIX}/lib/${PORTNAME} DOCDIR=${PREFIX}/share/doc/${PORTNAME} CGIDIR=${PREFIX}/www/${PORTNAME} install
+
+.include <bsd.port.post.mk>
diff --git a/textproc/xmlgen/distinfo b/textproc/xmlgen/distinfo
new file mode 100644
index 000000000000..cf1bbf8d0386
--- /dev/null
+++ b/textproc/xmlgen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xmlgen-1.4.tar.gz) = 2e35025db5ff9ec8867907618c91d49d72fe93f26956ec2043ce751bc3a7b654
+SIZE (xmlgen-1.4.tar.gz) = 59075
diff --git a/textproc/xmlgen/pkg-descr b/textproc/xmlgen/pkg-descr
new file mode 100644
index 000000000000..d238558107ca
--- /dev/null
+++ b/textproc/xmlgen/pkg-descr
@@ -0,0 +1,9 @@
+xmlgen is a TCL package to write XML documents in Tcl.
+
+This XML code is expressed by TCL code, which is translated.
+
+Every tag is made into a markup command which takes attributes and
+the element's content as parameters and then prints the XML tagged
+content. Of course, the content again can contain markup commands.
+
+WWW: http://tclxml.sourceforge.net/
diff --git a/textproc/xmlgen/pkg-plist b/textproc/xmlgen/pkg-plist
new file mode 100644
index 000000000000..29821c4afdac
--- /dev/null
+++ b/textproc/xmlgen/pkg-plist
@@ -0,0 +1,11 @@
+lib/xmlgen/htmlgen.tcl
+lib/xmlgen/pkgIndex.tcl
+lib/xmlgen/sidenav.tcl
+lib/xmlgen/tab.tcl
+lib/xmlgen/xmlgen.tcl
+share/doc/xmlgen/htmlgen.html
+share/doc/xmlgen/overview.html
+share/doc/xmlgen/sidenav.html
+share/doc/xmlgen/xmlgen.html
+@dirrm share/doc/xmlgen
+@dirrm lib/xmlgen