aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-12-16 00:22:17 +0800
committerwg <wg@FreeBSD.org>2013-12-16 00:22:17 +0800
commit781e42a27d143c9dd7bb035b0e0230c7c1b12e88 (patch)
tree528f950c491cb30f26166e5e23d4b77ad233a5ee /textproc
parent2a2657433c0cd564b2a2da9e60eb35d412a019f2 (diff)
downloadfreebsd-ports-gnome-781e42a27d143c9dd7bb035b0e0230c7c1b12e88.tar.gz
freebsd-ports-gnome-781e42a27d143c9dd7bb035b0e0230c7c1b12e88.tar.zst
freebsd-ports-gnome-781e42a27d143c9dd7bb035b0e0230c7c1b12e88.zip
Use setuptools for all Python ports.
Setuptools is the preferred method to manage Python distributions after many changes to the packaging ecosystem over the past couple of years. Only ports using USE_PYDISTUTILS= yes are affected by this commit, ports using USE_PYDISTUTILS= easy_install remains the same however this usage is now deprecated and should be converted to USE_PYDISTUTILS= yes. Some Python distributions do not work with setuptools out of the box because they extend the install command from distutils and not setuptools, and so they need to be patched accordingly. pip (which leverages setuptools) works around the issue by using eggs, however we want to get rid of those as well, as support for "flat" installation is unavailable or has other issues associated with it. This work allows us to unify how python packages are built, ensure that Python distributions are installed consistently, reduces complexity for Python port maintainers and paves the way for simplifying the Python ports framework in the future. With hat on: python Reviewed by: koobs, antoine Exp-run: bdrewery Approved by: bdrewery (portmgr)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-4suite-xml/Makefile5
-rw-r--r--textproc/py-4suite-xml/pkg-plist1
-rw-r--r--textproc/pychm/Makefile8
3 files changed, 10 insertions, 4 deletions
diff --git a/textproc/py-4suite-xml/Makefile b/textproc/py-4suite-xml/Makefile
index 60214902cd16..67a65441bcf4 100644
--- a/textproc/py-4suite-xml/Makefile
+++ b/textproc/py-4suite-xml/Makefile
@@ -15,6 +15,8 @@ USE_BZIP2= yes
REINPLACE_ARGS= -i "" -E
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_SETUP= ${PYSETUP}
+PYDISTUTILS_NOEGGINFO= yes
CONFLICTS= py*-4suite-[01]*
@@ -31,7 +33,8 @@ LOCALEDIR= share/locale
PLIST_SUB+= PACKAGE_DIR=Ft BINDIR=${BINDIR} SYSCONFDIR=${SYSCONFDIR} \
LIBDIR=${LIBDIR} LOCALSTATEDIR=${LOCALSTATEDIR} \
- DATADIR=${DATADIR} DOCSDIR=${DOCSDIR} LOCALEDIR=${LOCALEDIR}
+ DATADIR=${DATADIR} DOCSDIR=${DOCSDIR} LOCALEDIR=${LOCALEDIR} \
+ PYDISTUTILS_EGGINFO=${PYDISTUTILS_EGGINFO}
SUB_FILES= pkg-message
SUB_LIST+= PACKAGE_DIR=Ft BINDIR=${BINDIR} SYSCONFDIR=${SYSCONFDIR} \
diff --git a/textproc/py-4suite-xml/pkg-plist b/textproc/py-4suite-xml/pkg-plist
index 6993d383359f..835a63856afa 100644
--- a/textproc/py-4suite-xml/pkg-plist
+++ b/textproc/py-4suite-xml/pkg-plist
@@ -805,6 +805,7 @@
%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/__config__.py
%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/__init__.py
%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYDISTUTILS_EGGINFO%%
%%DATADIR%%/Data/Stylesheets/commandline.css
%%DATADIR%%/Data/Stylesheets/commandline_html.xslt
%%DATADIR%%/Data/Stylesheets/docbook_html-css.xslt
diff --git a/textproc/pychm/Makefile b/textproc/pychm/Makefile
index c3f6aff33f53..a6b483bfa08b 100644
--- a/textproc/pychm/Makefile
+++ b/textproc/pychm/Makefile
@@ -14,8 +14,10 @@ LIB_DEPENDS= chm.0:${PORTSDIR}/misc/chmlib
NO_BUILD= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-PYDISTUTILS_INSTALLARGS= build_ext -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- install -c -O1 --prefix=${PREFIX}
NO_STAGE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+PYDISTUTILS_INSTALLARGS:= ${PYDISTUTILS_INSTALLARGS} build_ext -I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+.include <bsd.port.post.mk>