aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2004-01-18 22:37:24 +0800
committerskv <skv@FreeBSD.org>2004-01-18 22:37:24 +0800
commit812e6899b0f753feb3018be34f8e47cb634c2616 (patch)
treea652890d6ddc780418cd4eb61d717052721ec9f2 /textproc
parenta0046b7c2dda291a1c600acb481ddf4e60a59887 (diff)
downloadfreebsd-ports-gnome-812e6899b0f753feb3018be34f8e47cb634c2616.tar.gz
freebsd-ports-gnome-812e6899b0f753feb3018be34f8e47cb634c2616.tar.zst
freebsd-ports-gnome-812e6899b0f753feb3018be34f8e47cb634c2616.zip
Add p5-XML-DifferenceMarkup 0.09,
this module implements an XML diff producing XML output.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-DifferenceMarkup/Makefile26
-rw-r--r--textproc/p5-XML-DifferenceMarkup/distinfo1
-rw-r--r--textproc/p5-XML-DifferenceMarkup/pkg-descr15
-rw-r--r--textproc/p5-XML-DifferenceMarkup/pkg-plist5
5 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 50e1e06833fe..5e80d7e13d5e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -313,6 +313,7 @@
SUBDIR += p5-XML-DOM
SUBDIR += p5-XML-DT
SUBDIR += p5-XML-DTDParser
+ SUBDIR += p5-XML-DifferenceMarkup
SUBDIR += p5-XML-Directory
SUBDIR += p5-XML-Dumper
SUBDIR += p5-XML-Encoding
diff --git a/textproc/p5-XML-DifferenceMarkup/Makefile b/textproc/p5-XML-DifferenceMarkup/Makefile
new file mode 100644
index 000000000000..c3463d1d89e4
--- /dev/null
+++ b/textproc/p5-XML-DifferenceMarkup/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: XML-DifferenceMarkup
+# Date created: 18 January 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-DifferenceMarkup
+PORTVERSION= 0.09
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= This module implements an XML diff producing XML output
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::DifferenceMarkup.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-DifferenceMarkup/distinfo b/textproc/p5-XML-DifferenceMarkup/distinfo
new file mode 100644
index 000000000000..003d433d5ecf
--- /dev/null
+++ b/textproc/p5-XML-DifferenceMarkup/distinfo
@@ -0,0 +1 @@
+MD5 (XML-DifferenceMarkup-0.09.tar.gz) = 300c3a3de27d85dfc45f9c8386048721
diff --git a/textproc/p5-XML-DifferenceMarkup/pkg-descr b/textproc/p5-XML-DifferenceMarkup/pkg-descr
new file mode 100644
index 000000000000..bd4c1461f962
--- /dev/null
+++ b/textproc/p5-XML-DifferenceMarkup/pkg-descr
@@ -0,0 +1,15 @@
+This module implements an XML diff producing XML output. Both input and
+output are DOM documents, as implemented by XML::LibXML.
+
+The diff format used by XML::DifferenceMarkup is meant to be
+human-readable (i.e. simple, as opposed to short) - basically the diff
+is a subset of the input trees, annotated with instruction element nodes
+specifying how to convert the source tree to the target by inserting and
+deleting nodes. To prevent name colisions with input trees, all added
+elements are in a namespace http://www.locus.cz/XML/DifferenceMarkup
+(the diff will fail on input trees which already use that namespace).
+
+WWW: http://search.cpan.org/dist/XML-DifferenceMarkup/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/textproc/p5-XML-DifferenceMarkup/pkg-plist b/textproc/p5-XML-DifferenceMarkup/pkg-plist
new file mode 100644
index 000000000000..22298e5526dc
--- /dev/null
+++ b/textproc/p5-XML-DifferenceMarkup/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/DifferenceMarkup/.packlist
+%%SITE_PERL%%/XML/DifferenceMarkup.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/DifferenceMarkup
+@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true