aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2018-03-21 00:19:08 +0800
committerfeld <feld@FreeBSD.org>2018-03-21 00:19:08 +0800
commit859f7aa124225d73f3d27a599dd825c28f33d822 (patch)
treeb76be73da8e15a42a13e11853aab81893b046c84 /textproc
parent8428948a034df0a5843ebeef450583111079cd56 (diff)
downloadfreebsd-ports-gnome-859f7aa124225d73f3d27a599dd825c28f33d822.tar.gz
freebsd-ports-gnome-859f7aa124225d73f3d27a599dd825c28f33d822.tar.zst
freebsd-ports-gnome-859f7aa124225d73f3d27a599dd825c28f33d822.zip
textproc/elasticsearch{5,6}: Pidfiles should be in a writable subdirectory
This fixes issues Elastic has with starting/stopping in some situations PR: 226800
Diffstat (limited to 'textproc')
-rw-r--r--textproc/elasticsearch5/Makefile2
-rw-r--r--textproc/elasticsearch5/files/elasticsearch.in4
-rw-r--r--textproc/elasticsearch6/Makefile2
-rw-r--r--textproc/elasticsearch6/files/elasticsearch.in4
4 files changed, 6 insertions, 6 deletions
diff --git a/textproc/elasticsearch5/Makefile b/textproc/elasticsearch5/Makefile
index 41c7af14cc95..f938aa75d257 100644
--- a/textproc/elasticsearch5/Makefile
+++ b/textproc/elasticsearch5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 5.6.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
diff --git a/textproc/elasticsearch5/files/elasticsearch.in b/textproc/elasticsearch5/files/elasticsearch.in
index d394d9c764f1..9a1643ab1a03 100644
--- a/textproc/elasticsearch5/files/elasticsearch.in
+++ b/textproc/elasticsearch5/files/elasticsearch.in
@@ -34,7 +34,7 @@ load_rc_config ${name}
: ${elasticsearch_tmp=/var/tmp/elasticsearch}
required_files="${elasticsearch_config}/elasticsearch.yml"
-_pidprefix=/var/run/elasticsearch
+_pidprefix=/var/run/elasticsearch/elasticsearch
pidfile=${_pidprefix}.pid
procname=%%JAVA%%
@@ -46,7 +46,7 @@ command_args="-d --pidfile=${pidfile} -Epath.conf=${elasticsearch_config}"
elasticsearch_precmd()
{
- /usr/bin/install -o ${elasticsearch_user} -g ${elasticsearch_group} /dev/null ${pidfile}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 755 ${pidfile%/*}
/usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 755 ${elasticsearch_tmp}
/usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 755 /var/db/elasticsearch
/usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 755 /var/log/elasticsearch
diff --git a/textproc/elasticsearch6/Makefile b/textproc/elasticsearch6/Makefile
index 994c83882f03..874eb1a29843 100644
--- a/textproc/elasticsearch6/Makefile
+++ b/textproc/elasticsearch6/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 6.2.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
diff --git a/textproc/elasticsearch6/files/elasticsearch.in b/textproc/elasticsearch6/files/elasticsearch.in
index 25e2e1a8d0ce..3345f1795750 100644
--- a/textproc/elasticsearch6/files/elasticsearch.in
+++ b/textproc/elasticsearch6/files/elasticsearch.in
@@ -32,7 +32,7 @@ load_rc_config ${name}
: ${elasticsearch_login_class=root}
required_files="${elasticsearch_config}/elasticsearch.yml"
-_pidprefix=/var/run/elasticsearch
+_pidprefix=/var/run/elasticsearch/elasticsearch
pidfile=${_pidprefix}.pid
procname=%%JAVA%%
@@ -46,7 +46,7 @@ export ES_PATH_CONF=${elasticsearch_config}
elasticsearch_precmd()
{
- /usr/bin/install -o ${elasticsearch_user} -g ${elasticsearch_group} /dev/null ${pidfile}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 755 ${pidfile%/*}
/usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 755 /var/db/elasticsearch
/usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 755 /var/log/elasticsearch
}