aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkiri <kiri@FreeBSD.org>2002-07-29 18:53:16 +0800
committerkiri <kiri@FreeBSD.org>2002-07-29 18:53:16 +0800
commit8e0bb80a63d721d8c85809799f0a9213502e03df (patch)
tree12e601b14da0fc53b23e8617de10c16954b94366 /textproc
parent285caabe37d142b88e8cf30ce468ba74ef692072 (diff)
downloadfreebsd-ports-gnome-8e0bb80a63d721d8c85809799f0a9213502e03df.tar.gz
freebsd-ports-gnome-8e0bb80a63d721d8c85809799f0a9213502e03df.tar.zst
freebsd-ports-gnome-8e0bb80a63d721d8c85809799f0a9213502e03df.zip
New port for SmartDoc development version(Beta). First, put
beta of 1.0.0 at 1/7/2002(1.0.1b) with 1.0.0.20020701.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/smartdoc-devel/Makefile73
-rw-r--r--textproc/smartdoc-devel/distinfo1
-rw-r--r--textproc/smartdoc-devel/files/catalog1
-rw-r--r--textproc/smartdoc-devel/files/sdoc.in12
-rw-r--r--textproc/smartdoc-devel/pkg-comment1
-rw-r--r--textproc/smartdoc-devel/pkg-descr10
-rw-r--r--textproc/smartdoc-devel/pkg-plist245
-rw-r--r--textproc/smartdoc-devel/scripts/configure5
9 files changed, 349 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 81ae65049f24..46509b33e4fa 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -318,6 +318,7 @@
SUBDIR += sgmltools-lite
SUBDIR += sgrep
SUBDIR += smartdoc
+ SUBDIR += smartdoc-devel
SUBDIR += source-highlight
SUBDIR += sp
SUBDIR += spell
diff --git a/textproc/smartdoc-devel/Makefile b/textproc/smartdoc-devel/Makefile
new file mode 100644
index 000000000000..c17dde222644
--- /dev/null
+++ b/textproc/smartdoc-devel/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: SmartDoc devel
+# Date created: 19 December 2000
+# Whom: KIRIYAMA Kazuhiko <kiri@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smartdoc
+PORTVERSION= 1.0.0.20020701
+CATEGORIES= textproc java
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= kiri/smartdoc
+EXTRACT_SUFX= .zip
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= kunishi@acm.org
+
+BUILD_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog \
+ javavm:${PORTSDIR}/java/javavmwrapper
+
+SCRIPTS_ENV= JAVALIBDIR=${JAVALIBDIR}
+WRKSRC= ${WRKDIR}/sdoc
+NO_BUILD= yes
+USE_ZIP= yes
+USE_JAVA= 1.2+
+NO_RUN_DEPENDS_JAVA= yes
+EXTRACT_CMD= ${JAVA}
+EXTRACT_BEFORE_ARGS= -jar ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} \
+ -batch -bindir:${WRKSRC}/bin -installbasedir:${WRKSRC}
+EXTRACT_AFTER_ARGS= #
+
+JAVALIBDIR= ${PREFIX}/share/java
+XMLDIR= ${PREFIX}/share/xml
+EMACSLISPDIR= ${LOCALBASE}/share/emacs/site-lisp
+XEMACSLISPDIR= ${LOCALBASE}/lib/xemacs/site-lisp
+DTDDIR= ${XMLDIR}/${PORTNAME}
+MKCATALOG= ${LOCALBASE}/sbin/mkcatalog
+DOCS= COPYING.txt OroLICENSE.txt README README.sdoc \
+ README_en.html README_ja.html \
+ XalanLICENSE.txt XercesLICENSE.txt
+JARS= SmartDoc.jar
+ELISPS= sdoc-helper.el sdoc-mode.el
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/bin
+ ${CP} ${FILESDIR}/sdoc.in ${WRKSRC}/bin/sdoc
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/sdoc ${PREFIX}/bin
+ ${MKDIR} ${JAVALIBDIR}/classes
+.for jar in ${JARS}
+ ${INSTALL_DATA} ${WRKSRC}/${jar} ${JAVALIBDIR}/classes
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/etc/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+ ${CP} -R ${WRKSRC}/doc ${DOCSDIR}
+.endif
+ ${MKDIR} ${DTDDIR} ${EMACSLISPDIR} ${XEMACSLISPDIR}
+ ${INSTALL_DATA} ${FILESDIR}/catalog ${DTDDIR}
+ ${INSTALL_DATA} ${WRKSRC}/etc/pure/PureSmartDoc.dtd ${DTDDIR}
+ ${MKCATALOG} -c ${LOCALBASE}/share/xml/catalog -q install ${PORTNAME}
+.for file in ${ELISPS}
+ ${INSTALL_DATA} ${WRKSRC}/etc/${file} ${EMACSLISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/etc/${file} ${XEMACSLISPDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/smartdoc-devel/distinfo b/textproc/smartdoc-devel/distinfo
new file mode 100644
index 000000000000..4cc3c09ed836
--- /dev/null
+++ b/textproc/smartdoc-devel/distinfo
@@ -0,0 +1 @@
+MD5 (smartdoc/smartdoc-1.0.0.20020701.zip) = 5317a18c1445460fd9d9d3599f14d677
diff --git a/textproc/smartdoc-devel/files/catalog b/textproc/smartdoc-devel/files/catalog
new file mode 100644
index 000000000000..632495e7c338
--- /dev/null
+++ b/textproc/smartdoc-devel/files/catalog
@@ -0,0 +1 @@
+PUBLIC "-//Tomoharu Asami//DTD PureSmartDoc XML V0.6.9//EN" "PureSmartDoc.dtd"
diff --git a/textproc/smartdoc-devel/files/sdoc.in b/textproc/smartdoc-devel/files/sdoc.in
new file mode 100644
index 000000000000..048013019a1b
--- /dev/null
+++ b/textproc/smartdoc-devel/files/sdoc.in
@@ -0,0 +1,12 @@
+#! /bin/sh
+
+INSTALLDIR=%%JAVALIBDIR%%/classes
+JAVA_VERSION=`javavm -version 2>&1 | grep "^java.* version" | sed -e 's/^.* version "\([0-9]*\.[0-9]*\)\..*"$/\1/'`
+
+if [ "$JAVA_VERSION" = '1.1' ]; then
+ echo "SmartDoc requires Java newer than 1.2."
+ echo "Fix %%LOCALBASE%%/etc/javavms properly, or set the environment variable JAVAVM to a correct JavaVM."
+ exit 1
+fi
+
+exec javavm -jar $INSTALLDIR/SmartDoc.jar $*
diff --git a/textproc/smartdoc-devel/pkg-comment b/textproc/smartdoc-devel/pkg-comment
new file mode 100644
index 000000000000..d57299717c7e
--- /dev/null
+++ b/textproc/smartdoc-devel/pkg-comment
@@ -0,0 +1 @@
+XML utility to create various documents(devel version)
diff --git a/textproc/smartdoc-devel/pkg-descr b/textproc/smartdoc-devel/pkg-descr
new file mode 100644
index 000000000000..f37138d73fd6
--- /dev/null
+++ b/textproc/smartdoc-devel/pkg-descr
@@ -0,0 +1,10 @@
+SmartDoc is the XML utility to create documents.
+
+It can convert SmartDoc format document to HTML4.0, HTML3.2, LaTeX2e
+and Java Help. For more information about SmartDoc, see
+below:
+
+WWW: http://www.asahi-net.or.jp/~dp8t-asm/java/tools/SmartDoc/
+
+This is the development version(beta). If you use the stable one,
+install textproc/smartdoc.
diff --git a/textproc/smartdoc-devel/pkg-plist b/textproc/smartdoc-devel/pkg-plist
new file mode 100644
index 000000000000..e41651806954
--- /dev/null
+++ b/textproc/smartdoc-devel/pkg-plist
@@ -0,0 +1,245 @@
+bin/sdoc
+lib/xemacs/site-lisp/sdoc-helper.el
+lib/xemacs/site-lisp/sdoc-mode.el
+%%PORTDOCS%%share/doc/smartdoc/COPYING.txt
+%%PORTDOCS%%share/doc/smartdoc/OroLICENSE.txt
+%%PORTDOCS%%share/doc/smartdoc/README
+%%PORTDOCS%%share/doc/smartdoc/README.sdoc
+%%PORTDOCS%%share/doc/smartdoc/README_en.html
+%%PORTDOCS%%share/doc/smartdoc/README_ja.html
+%%PORTDOCS%%share/doc/smartdoc/XalanLICENSE.txt
+%%PORTDOCS%%share/doc/smartdoc/XercesLICENSE.txt
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/Dl.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/Figure.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/HelloWorld.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/HelloWorld_ja.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/NaturalP.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/Ol.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/P.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/Sample.java
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/Sample.java.cdata
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/Sample.java.escape
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/SmartDoc.properties
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/TableBasic.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/TableCSV.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/TreeTable.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/Ul.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/figure.eps
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/figure.gif
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/quick.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/quick/sample.console
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/README.euc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/README.sjis
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/SmartDoc.properties
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/adapter.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/bibElement.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/command.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/commonAttr.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/documentElement.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/html3.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/html4.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/index.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/javahelp.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/latex2e.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/normalizer.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/plain.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/pure.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/revised.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/autoimage.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/bean/sample.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/csv.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/intro.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/jdbc/jdbc.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/none.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/sdoc.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/stable.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/text.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/xslt/conv.xsl
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/xslt/data.xml
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/xslt/sample.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/article.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/author.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/bibliography.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/bibliopole.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/book.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/edition.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/editor.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/journal.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/month.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/number.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/pages.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/publisher.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/subtitle.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/title.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/uri.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/volume.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/year.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/command/locale.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/command/localeEn.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/command/localeJa.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/adapter.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/class.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/format.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/id.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/idref.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/key.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/locale.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/normalizer.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/src.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/style.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/title.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/xmllang.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/xmlspace.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/a.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/abbr.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/acronym.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/appendix.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/attribute.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/b.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/blockquote.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/body.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/chapter.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/cite.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/code.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/col.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/colgroup.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/console.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/dd.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/dfn.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/div.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/dl.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/doc.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/dt.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/em.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/equation.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/figure.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/fyi.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/head.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/head2.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/i.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/img.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/index.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/kbd.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/li.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/native.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/note.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/ol.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/p.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/part.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/pre.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/program.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/q.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/samp.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/section.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/span.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/strong.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/subsection.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/subsubsection.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/table.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tbody.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/td.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tfoot.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/th.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/thead.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/title.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tnote.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tr.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tt.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/ul.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/var.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/hello/HelloWorld.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/hello/HelloWorld_ja.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/intro/demo.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/console.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/csv.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/href.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/image.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/javasrc.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/line.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/natural.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/naturallabel.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/none.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/program.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/regex.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/space.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/tag.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/tex.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/plain/sample.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/plain/sample_ascii.txt
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/plain/sample_jis.txt
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/attr.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/block.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/framework.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/head.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/image.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/index.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/link.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/list.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/logical.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/math.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/note.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/program.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/quote.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/special.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/table.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/text.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/refman/structure.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/sample/Sample.java
+%%PORTDOCS%%share/doc/smartdoc/doc/sample/SmartDoc.properties.dvi2ps
+%%PORTDOCS%%share/doc/smartdoc/doc/sample/SmartDoc.properties.dvips
+%%PORTDOCS%%share/doc/smartdoc/doc/sample/figure.eps
+%%PORTDOCS%%share/doc/smartdoc/doc/sample/figure.gif
+%%PORTDOCS%%share/doc/smartdoc/doc/sample/html.html
+%%PORTDOCS%%share/doc/smartdoc/doc/sample/latex.tex
+%%PORTDOCS%%share/doc/smartdoc/doc/sample/sample.console
+%%PORTDOCS%%share/doc/smartdoc/doc/sample/sample.sdoc
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/Sample.java
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/SmartDoc.properties.dvi2ps
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/SmartDoc.properties.dvips
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/data.csv
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/figure.eps
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/figure.gif
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/html.html
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/latex.tex
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/sample.console
+%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/sample.sdoc
+share/emacs/site-lisp/sdoc-helper.el
+share/emacs/site-lisp/sdoc-mode.el
+share/examples/smartdoc/html4/article.css
+share/examples/smartdoc/pure/PureSmartDoc.dtd
+share/examples/smartdoc/pure/PureSmartDoc.rlx
+share/examples/smartdoc/pure/article.css
+share/examples/smartdoc/sdoc-helper.el
+share/examples/smartdoc/sdoc-mode.el
+share/examples/smartdoc/sdoc2html.xsl
+share/java/classes/SmartDoc.jar
+share/xml/catalog
+share/xml/smartdoc/PureSmartDoc.dtd
+share/xml/smartdoc/catalog
+@dirrm share/xml/smartdoc
+@unexec rmdir %D/share/java/classes 2>/dev/null || true
+@dirrm share/examples/smartdoc/pure
+@dirrm share/examples/smartdoc/html4
+@dirrm share/examples/smartdoc
+@unexec rmdir %D/share/emacs/site-lisp 2>/dev/null || true
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/sampleI18N
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/sample
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/structure
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/plain
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/normalizer
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/intro
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/hello
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/element
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/commonAttr
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/command
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/bib
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/adapter/xslt
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/adapter/jdbc
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/adapter/bean
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/adapter
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/quick
+%%PORTDOCS%%@dirrm share/doc/smartdoc/doc
+%%PORTDOCS%%@dirrm share/doc/smartdoc
+@unexec rmdir %D/lib/xemacs/site-lisp 2>/dev/null || true
diff --git a/textproc/smartdoc-devel/scripts/configure b/textproc/smartdoc-devel/scripts/configure
new file mode 100644
index 000000000000..a2703a536bda
--- /dev/null
+++ b/textproc/smartdoc-devel/scripts/configure
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+export JAVALIBDIR
+
+perl -pi -e 's|%%JAVALIBDIR%%|$ENV{JAVALIBDIR}|g;s|%%LOCALBASE%%|$ENV{LOCALBASE}|g;' ${WRKSRC}/bin/sdoc