aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-10-08 04:48:03 +0800
committermandree <mandree@FreeBSD.org>2013-10-08 04:48:03 +0800
commit9bfd11eec1102482b925f3d06a271ab63c91538c (patch)
treefc96f25183dd5518e32bedb6c4161c22ec1ae95c /textproc
parentda23c9b74a2913f4455d777ef2bd9ac602f9f686 (diff)
downloadfreebsd-ports-gnome-9bfd11eec1102482b925f3d06a271ab63c91538c.tar.gz
freebsd-ports-gnome-9bfd11eec1102482b925f3d06a271ab63c91538c.tar.zst
freebsd-ports-gnome-9bfd11eec1102482b925f3d06a271ab63c91538c.zip
Convert to staging; USE_GMAKE -> USES=gmake
Diffstat (limited to 'textproc')
-rw-r--r--textproc/wiggle/Makefile10
-rw-r--r--textproc/wiggle/pkg-plist3
-rw-r--r--textproc/xmlto/Makefile7
-rw-r--r--textproc/xmlto/pkg-plist2
4 files changed, 11 insertions, 11 deletions
diff --git a/textproc/wiggle/Makefile b/textproc/wiggle/Makefile
index c3cd1d21f551..a8758187856c 100644
--- a/textproc/wiggle/Makefile
+++ b/textproc/wiggle/Makefile
@@ -14,14 +14,10 @@ LICENSE= GPLv2
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_GCC= 4.2+ # uses nested functions
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS+= CFLAGS="${CFLAGS} -I. -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter"
-MAN1= wiggle.1
-PLIST_FILES= bin/wiggle
-
-NO_STAGE= yes
pre-patch:
${REINPLACE_CMD} -Ee 's,\./dotest,bash ./dotest,' ${WRKSRC}/Makefile
${REINPLACE_CMD} -Ee "s,/usr/bin/time -o .time -f '%U',," ${WRKSRC}/dotest
@@ -30,7 +26,7 @@ pre-patch:
${REINPLACE_CMD} -Ee 's|(^[[:space:]]+[[:<:]])cols = cols;|\1(void)cols;|' ${WRKSRC}/vpatch.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/wiggle ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/wiggle.1 ${PREFIX}/man/man1/
+ ${INSTALL_PROGRAM} ${WRKSRC}/wiggle ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/wiggle.1 ${STAGEDIR}${PREFIX}/man/man1/
.include <bsd.port.mk>
diff --git a/textproc/wiggle/pkg-plist b/textproc/wiggle/pkg-plist
new file mode 100644
index 000000000000..2642c1b1ae5e
--- /dev/null
+++ b/textproc/wiggle/pkg-plist
@@ -0,0 +1,3 @@
+bin/wiggle
+man/man1/wiggle.1.gz
+
diff --git a/textproc/xmlto/Makefile b/textproc/xmlto/Makefile
index 00c727a67b5b..06e1bcabfc6b 100644
--- a/textproc/xmlto/Makefile
+++ b/textproc/xmlto/Makefile
@@ -29,16 +29,15 @@ PASSIVETEX_DESC= Add dependency on PassiveTeX
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= BASH=${BASH_CMD} GETOPT=${GETOPT_CMD} PDFXMLTEX=${PDFXMLTEX_CMD}
+MAKE_ENV+= HOME=/dev/null
BASH_CMD= ${LOCALBASE}/bin/bash
GETOPT_CMD= ${LOCALBASE}/bin/getopt
XSL_DIR= ${LOCALBASE}/share/xsl/docbook
PDFXMLTEX_CMD= ${LOCALBASE}/bin/pdftex
-MAN1= xmlif.1 xmlto.1
PORTDOCS= AUTHORS COPYING ChangeLog NEWS THANKS
# these two documentation files do not convey information useful for
-NO_STAGE= yes
# the FreeBSD port at this time:
# PORTDOCS+= FAQ README
@@ -68,8 +67,8 @@ post-patch:
.if ${PORT_OPTIONS:MDOCS}
post-install:
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/xmlto/pkg-plist b/textproc/xmlto/pkg-plist
index 1d31a6161f71..2e45d6ff0f76 100644
--- a/textproc/xmlto/pkg-plist
+++ b/textproc/xmlto/pkg-plist
@@ -1,5 +1,7 @@
bin/xmlif
bin/xmlto
+man/man1/xmlif.1.gz
+man/man1/xmlto.1.gz
%%DATADIR%%/format/docbook/awt
%%DATADIR%%/format/docbook/dvi
%%DATADIR%%/format/docbook/epub