aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2018-03-07 08:46:59 +0800
committerjhale <jhale@FreeBSD.org>2018-03-07 08:46:59 +0800
commita03a92743ed4912528391eb4e6c43679f1390935 (patch)
tree101ff983fb0009f2c99a7d1ed1b3d23ba37cd08a /textproc
parent0e92e16519dea86499e361c880c6f356d88a6670 (diff)
downloadfreebsd-ports-gnome-a03a92743ed4912528391eb4e6c43679f1390935.tar.gz
freebsd-ports-gnome-a03a92743ed4912528391eb4e6c43679f1390935.tar.zst
freebsd-ports-gnome-a03a92743ed4912528391eb4e6c43679f1390935.zip
textproc/py-qt5-xml:
- Install python bytecode to avoid build errors in ports depending on it [1] devel/py-qt[4|5]-core: - Fix python bytecode destdir location Reported by: yuri (via freebsd-ports mailing list) [1] Reviewed by: antoine, tcberner Differential Revision: https://reviews.freebsd.org/D14586
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-qt5-xml/Makefile12
-rw-r--r--textproc/py-qt5-xml/pkg-plist4
2 files changed, 14 insertions, 2 deletions
diff --git a/textproc/py-qt5-xml/Makefile b/textproc/py-qt5-xml/Makefile
index cdf57aa0d3b1..23b9674190dc 100644
--- a/textproc/py-qt5-xml/Makefile
+++ b/textproc/py-qt5-xml/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xml
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc devel python
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +12,7 @@ PYQT_DIST= yes
USES= python pyqt:5
USE_PYQT= sip_build core_run
-USE_PYTHON= flavors
+USE_PYTHON= flavors py3kplist
USE_QT5= core xml buildtools_build qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -25,4 +25,12 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
+post-install:
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ -f -d ${PYTHONPREFIX_SITELIBDIR}/PyQt5 \
+ ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5
+ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
+ -f -d ${PYTHONPREFIX_SITELIBDIR}/PyQt5 \
+ ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5
+
.include <bsd.port.mk>
diff --git a/textproc/py-qt5-xml/pkg-plist b/textproc/py-qt5-xml/pkg-plist
index e606a8e1869a..58134a93546c 100644
--- a/textproc/py-qt5-xml/pkg-plist
+++ b/textproc/py-qt5-xml/pkg-plist
@@ -4,8 +4,12 @@ bin/pyrcc5
%%PYTHON_SITELIBDIR%%/PyQt5/QtXml.pyi
%%PYTHON_SITELIBDIR%%/PyQt5/pylupdate.so
%%PYTHON_SITELIBDIR%%/PyQt5/pylupdate_main.py
+%%PYTHON_SITELIBDIR%%/PyQt5/pylupdate_main.pyc
+%%PYTHON_SITELIBDIR%%/PyQt5/pylupdate_main.pyo
%%PYTHON_SITELIBDIR%%/PyQt5/pyrcc.so
%%PYTHON_SITELIBDIR%%/PyQt5/pyrcc_main.py
+%%PYTHON_SITELIBDIR%%/PyQt5/pyrcc_main.pyc
+%%PYTHON_SITELIBDIR%%/PyQt5/pyrcc_main.pyo
%%PYQT_SIPDIR%%/QtXml/QtXmlmod.sip
%%PYQT_SIPDIR%%/QtXml/qdom.sip
%%PYQT_SIPDIR%%/QtXml/qxml.sip