aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-05-25 10:11:02 +0800
committerjrm <jrm@FreeBSD.org>2017-05-25 10:11:02 +0800
commita89a60511f5a020607abbb448ec6ad4aac00a8f9 (patch)
tree915d4178e4d42a5165adb40e7ed5c66897d4154b /textproc
parent995094335a2564d1ddf5f8975a2f5007c4980f78 (diff)
downloadfreebsd-ports-gnome-a89a60511f5a020607abbb448ec6ad4aac00a8f9.tar.gz
freebsd-ports-gnome-a89a60511f5a020607abbb448ec6ad4aac00a8f9.tar.zst
freebsd-ports-gnome-a89a60511f5a020607abbb448ec6ad4aac00a8f9.zip
textproc/rubygem-rails-dom-testing-rails50: Create rails version 5.0 port
by copying textproc/rubygem-rails-dom-testing-rails5 Approved by: swills (mentor, implicit)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-rails-dom-testing-rails50/Makefile24
-rw-r--r--textproc/rubygem-rails-dom-testing-rails50/distinfo3
-rw-r--r--textproc/rubygem-rails-dom-testing-rails50/pkg-descr8
4 files changed, 36 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a7284a67291f..6cdf633df50e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1519,6 +1519,7 @@
SUBDIR += rubygem-pretty-xml
SUBDIR += rubygem-rails-dom-testing
SUBDIR += rubygem-rails-dom-testing-rails5
+ SUBDIR += rubygem-rails-dom-testing-rails50
SUBDIR += rubygem-rails-dom-testing1
SUBDIR += rubygem-rails-html-sanitizer
SUBDIR += rubygem-rak
diff --git a/textproc/rubygem-rails-dom-testing-rails50/Makefile b/textproc/rubygem-rails-dom-testing-rails50/Makefile
new file mode 100644
index 000000000000..64026f65b8d1
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing-rails50/Makefile
@@ -0,0 +1,24 @@
+# Created by: Johannes Jost Meixner <xmj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rails-dom-testing
+PORTVERSION= 2.0.3
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails50
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Analyse and compare DOMs using Nokogiri
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-activesupport50>0:devel/rubygem-activesupport50 \
+ rubygem-nokogiri>=1.6:textproc/rubygem-nokogiri \
+ rubygem-rails-deprecated_sanitizer-rails50>=1.0.1:devel/rubygem-rails-deprecated_sanitizer-rails50
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-rails-dom-testing-rails50/distinfo b/textproc/rubygem-rails-dom-testing-rails50/distinfo
new file mode 100644
index 000000000000..d87274f660df
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing-rails50/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1494610306
+SHA256 (rubygem/rails-dom-testing-2.0.3.gem) = b140c4f39f6e609c8113137b9a60dfc2ecb89864e496f87f23a68b3b8f12d8d1
+SIZE (rubygem/rails-dom-testing-2.0.3.gem) = 14336
diff --git a/textproc/rubygem-rails-dom-testing-rails50/pkg-descr b/textproc/rubygem-rails-dom-testing-rails50/pkg-descr
new file mode 100644
index 000000000000..c87a1ba37065
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing-rails50/pkg-descr
@@ -0,0 +1,8 @@
+This gem is responsible for comparing HTML doms and asserting that DOM elements
+are present in Rails applications. Doms are compared via assert_dom_equal and
+assert_dom_not_equal. Elements are asserted via assert_select,
+assert_select_encoded, assert_select_email and a subset of the dom can be
+selected with css_select. The gem is developed for Rails 4.2 and above, and
+will not work on previous versions.
+
+WWW: https://github.com/rails/rails-dom-testing