aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2018-03-03 00:10:28 +0800
committerfeld <feld@FreeBSD.org>2018-03-03 00:10:28 +0800
commitaf80e112f72af1e1d0bc87675ee59301a6b8f7cb (patch)
treec5f7404394c3e42c32cca8e83eb2c7328ef42600 /textproc
parentc040f0d4e4cc44c3af750429474e14917dcb9712 (diff)
downloadfreebsd-ports-gnome-af80e112f72af1e1d0bc87675ee59301a6b8f7cb.tar.gz
freebsd-ports-gnome-af80e112f72af1e1d0bc87675ee59301a6b8f7cb.tar.zst
freebsd-ports-gnome-af80e112f72af1e1d0bc87675ee59301a6b8f7cb.zip
Kibana is an open source (Apache Licensed), browser based analytics and search
dashboard for Elasticsearch. Kibana is a snap to setup and start using. Kibana strives to be easy to get started with, while also being flexible and powerful, just like Elasticsearch. Kibana 6.x is compatible with Elasticsearch 6.x WWW: https://www.elastic.co/products/kibana
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/kibana6/Makefile44
-rw-r--r--textproc/kibana6/distinfo3
-rw-r--r--textproc/kibana6/files/kibana.in45
-rw-r--r--textproc/kibana6/files/pkg-deinstall.in9
-rw-r--r--textproc/kibana6/pkg-descr8
6 files changed, 110 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 39a084bcc3ce..670394eadff8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -387,6 +387,7 @@
SUBDIR += kibana5
SUBDIR += kibana5-search-guard
SUBDIR += kibana5-x-pack
+ SUBDIR += kibana6
SUBDIR += kiss-templates
SUBDIR += kmfl-european-latin
SUBDIR += kmfl-khmer
diff --git a/textproc/kibana6/Makefile b/textproc/kibana6/Makefile
new file mode 100644
index 000000000000..33b0ab3ecb02
--- /dev/null
+++ b/textproc/kibana6/Makefile
@@ -0,0 +1,44 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= kibana
+PORTVERSION= 6.2.2
+DISTVERSIONSUFFIX= -linux-x86_64
+PORTREVISION= 0
+CATEGORIES= textproc www
+MASTER_SITES= https://artifacts.elastic.co/downloads/kibana/ \
+ http://artifacts.elastic.co/downloads/kibana/
+PKGNAMESUFFIX?= 6
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Browser based analytics and search interface to ElasticSearch
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= node>=0.8.0:www/node
+
+CONFLICTS= kibana[3-5]*
+
+NO_BUILD= yes
+WWWDIR= ${PREFIX}/www/${PORTNAME}${PKGNAMESUFFIX}
+USE_RC_SUBR= ${PORTNAME}
+
+SUB_FILES= pkg-deinstall
+
+do-install:
+ ${CP} ${WRKSRC}/config/kibana.yml ${STAGEDIR}${PREFIX}/etc/kibana.yml.sample
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && \
+ ${RM} -r bin config node && \
+ ${RM} -r optimize && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
+
+post-install:
+ ${ECHO} "@sample etc/kibana.yml.sample" >> ${TMPPLIST}
+ ${FIND} -s ${STAGEDIR}${WWWDIR} -not -type d | ${SORT} | \
+ ${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
+ ${ECHO} "@dir(www,www) ${WWWDIR}/data" >> ${TMPPLIST}
+ ${ECHO} "@dir ${WWWDIR}/plugins" >> ${TMPPLIST}
+ ${ECHO} "@dir ${WWWDIR}/src/ui/public/factories" >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/textproc/kibana6/distinfo b/textproc/kibana6/distinfo
new file mode 100644
index 000000000000..5b4ff1257bbf
--- /dev/null
+++ b/textproc/kibana6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1519487108
+SHA256 (kibana-6.2.2-linux-x86_64.tar.gz) = 225b5c72e333c7e872f3d97f2ab4039e29a7a8bee02f0feb57744dbc59e67abe
+SIZE (kibana-6.2.2-linux-x86_64.tar.gz) = 83415765
diff --git a/textproc/kibana6/files/kibana.in b/textproc/kibana6/files/kibana.in
new file mode 100644
index 000000000000..b9c128934563
--- /dev/null
+++ b/textproc/kibana6/files/kibana.in
@@ -0,0 +1,45 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: kibana
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+. /etc/rc.subr
+
+name=kibana
+rcvar=kibana_enable
+
+load_rc_config $name
+
+: ${kibana_enable:="NO"}
+: ${kibana_config:="%%PREFIX%%/etc/kibana.yml"}
+: ${kibana_user:="www"}
+: ${kibana_group:="www"}
+: ${kibana_log:="/var/log/kibana.log"}
+
+required_files="${kibana_config}"
+pidfile="/var/run/${name}/${name}.pid"
+start_precmd="kibana_precmd"
+procname="%%LOCALBASE%%/bin/node"
+command="/usr/sbin/daemon"
+command_args="-f -p ${pidfile} env BABEL_DISABLE_CACHE=1 ${procname} %%WWWDIR%%/src/cli serve --config ${kibana_config} --log-file ${kibana_log}"
+
+kibana_precmd()
+{
+ if [ ! -d $(dirname ${pidfile}) ]; then
+ install -d -o ${kibana_user} -g ${kibana_group} $(dirname ${pidfile})
+ fi
+
+ if [ ! -f ${kibana_log} ]; then
+ install -o ${kibana_user} -g ${kibana_group} -m 640 /dev/null ${kibana_log}
+ fi
+
+ if [ ! -d %%WWWDIR%%/optimize ]; then
+ install -d -o ${kibana_user} -g ${kibana_group} %%WWWDIR%%/optimize
+ fi
+}
+
+run_rc_command "$1"
diff --git a/textproc/kibana6/files/pkg-deinstall.in b/textproc/kibana6/files/pkg-deinstall.in
new file mode 100644
index 000000000000..863e3fbed119
--- /dev/null
+++ b/textproc/kibana6/files/pkg-deinstall.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+case "$2" in
+POST-DEINSTALL)
+ if [ -d %%WWWDIR%%/optimize ]; then
+ /usr/bin/find %%WWWDIR%%/optimize/ -delete
+ fi
+ ;;
+esac
diff --git a/textproc/kibana6/pkg-descr b/textproc/kibana6/pkg-descr
new file mode 100644
index 000000000000..330c965d3441
--- /dev/null
+++ b/textproc/kibana6/pkg-descr
@@ -0,0 +1,8 @@
+Kibana is an open source (Apache Licensed), browser based analytics and search
+dashboard for Elasticsearch. Kibana is a snap to setup and start using. Kibana
+strives to be easy to get started with, while also being flexible and powerful,
+just like Elasticsearch.
+
+Kibana 6.x is compatible with Elasticsearch 6.x
+
+WWW: https://www.elastic.co/products/kibana