aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2011-04-25 04:28:45 +0800
committermakc <makc@FreeBSD.org>2011-04-25 04:28:45 +0800
commitb5d8511836e445ae065bef3d10c20385d49564e5 (patch)
tree7afdc5dc20355f0ead5787136dcaed5cad2d1209 /textproc
parent457a7ebd9a476d8ec2cae82d96c383733d622d04 (diff)
downloadfreebsd-ports-gnome-b5d8511836e445ae065bef3d10c20385d49564e5.tar.gz
freebsd-ports-gnome-b5d8511836e445ae065bef3d10c20385d49564e5.tar.zst
freebsd-ports-gnome-b5d8511836e445ae065bef3d10c20385d49564e5.zip
Update to 3.0.2
Take maintainership Port changes: rename GNOMEUI option to more common GNOME and turn it off mark run conflict with stardict2 remove support for 6.x update pkg-message sort plist PR: ports/156228 Approved by: maintainer timeout
Diffstat (limited to 'textproc')
-rw-r--r--textproc/stardict3/Makefile37
-rw-r--r--textproc/stardict3/distinfo5
-rw-r--r--textproc/stardict3/files/patch-src::conf.cpp11
-rw-r--r--textproc/stardict3/files/src_conf.h18
-rw-r--r--textproc/stardict3/pkg-message17
-rw-r--r--textproc/stardict3/pkg-plist245
6 files changed, 156 insertions, 177 deletions
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 6beabb84955a..cc3abf727837 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -6,59 +6,58 @@
#
PORTNAME= stardict
-PORTVERSION= 3.0.1
-PORTREVISION= 5
+PORTVERSION= 3.0.2
CATEGORIES= textproc
MASTER_SITES= SF
DIST_SUBDIR= stardict
-MAINTAINER= d9364104@mail.nchu.edu.tw
+MAINTAINER= makc@FreeBSD.org
COMMENT= A cross-platform and international dictionary written in Gtk2
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
enchant.1:${PORTSDIR}/textproc/enchant
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-festival \
--disable-gucharmap \
--disable-espeak \
- --disable-advertisement \
--disable-updateinfo
USE_GMAKE= yes
USE_BZIP2= yes
-USE_GNOME= gnomehack gnomeprefix
+USE_GNOME= gnomehack
USE_GETTEXT= yes
-OPTIONS= GNOMEUI "GNOME support" On
+OPTIONS= GNOME "GNOME support" Off
-CONFLICTS= stardict-2.[0-9]*
+CONFLICTS_RUN= stardict-2.[0-9]*
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_GNOMEUI)
-USE_GNOME+= libgnomeui
+.if !defined(WITHOUT_GNOME)
+USE_GNOME+= gnomeprefix gnomedocutils libgnomeui
GCONF_SCHEMAS= stardict.schemas
INSTALLS_OMF= yes
PLIST_SUB= GNOME=""
.else
+USE_AUTOTOOLS= autoconf
USE_GNOME+= gtk20
CONFIGURE_ARGS+=--disable-gnome-support --disable-schemas-install
-PLIST_SUB= GNOME="@comment not installed: "
+PLIST_SUB= GNOME="@comment "
.endif
MAN1= stardict.1
-.if (${OSVERSION} < 700109)
-EXTRA_PATCHES+= ${FILESDIR}/src_conf.h
-.endif
-
post-patch:
- ${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},' \
+.if defined(WITHOUT_GNOME)
+ ${REINPLACE_CMD} -e '/DATADIRNAME=lib/s,lib,share,' ${WRKSRC}/m4/intltool.m4
+ ${REINPLACE_CMD} -e '/^SUBDIRS/s,help,,' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e '/^GNOME_DOC_INIT/d' ${WRKSRC}/configure.ac
+.endif
+ ${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,g' \
${WRKSRC}/src/conf.cpp
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/stardict3/distinfo b/textproc/stardict3/distinfo
index 049f76e38749..a6d8738533a8 100644
--- a/textproc/stardict3/distinfo
+++ b/textproc/stardict3/distinfo
@@ -1,3 +1,2 @@
-MD5 (stardict/stardict-3.0.1.tar.bz2) = 93bb2d7825bc9d52a4f9ba4c1c506d1d
-SHA256 (stardict/stardict-3.0.1.tar.bz2) = 504b3a7748933b9bd998cb85f37d4fa0a8575306643ffe6a9742450e66cd556f
-SIZE (stardict/stardict-3.0.1.tar.bz2) = 1964195
+SHA256 (stardict/stardict-3.0.2.tar.bz2) = dcd1950d41362b0fbf3df10140a54d74c2c1948c376ff7387c2d28c8185a1ff6
+SIZE (stardict/stardict-3.0.2.tar.bz2) = 4332613
diff --git a/textproc/stardict3/files/patch-src::conf.cpp b/textproc/stardict3/files/patch-src::conf.cpp
deleted file mode 100644
index 376a3f747d7c..000000000000
--- a/textproc/stardict3/files/patch-src::conf.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/conf.cpp.orig Mon Jul 10 05:23:39 2006
-+++ src/conf.cpp Mon Jul 10 05:24:36 2006
-@@ -114,7 +114,7 @@
- #ifdef _WIN32
- add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("C:\\Program Files\\WyabdcRealPeopleTTS\nC:\\Program Files\\OtdRealPeopleTTS\nWyabdcRealPeopleTTS\nOtdRealPeopleTTS"));
- #else
-- add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("/usr/share/WyabdcRealPeopleTTS\n/usr/share/OtdRealPeopleTTS"));
-+ add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("/usr/local/share/WyabdcRealPeopleTTS\n/usr/local/share/OtdRealPeopleTTS"));
- #endif
- add_entry("/apps/stardict/preferences/dictionary/history", get_default_history_filename());
- add_entry("/apps/stardict/preferences/dictionary/only_export_word", true);
diff --git a/textproc/stardict3/files/src_conf.h b/textproc/stardict3/files/src_conf.h
deleted file mode 100644
index 81ee57537444..000000000000
--- a/textproc/stardict3/files/src_conf.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/conf.h.orig 2008-09-26 09:33:59.000000000 +0800
-+++ src/conf.h 2008-09-26 09:34:44.000000000 +0800
-@@ -115,7 +115,6 @@
- std::auto_ptr<config_file> cf;
- cache_t cache;
-
--#ifdef _WIN32
- static void *memrchr(const void *mem, int c, size_t len) {
- char *res;
- char *cmem = (char *)mem;
-@@ -127,7 +126,6 @@
- --res;
- return res == cmem - 1 ? NULL : res;
- }
--#endif
-
- template <typename T>
- void set_value(const char *name, const T& val, bool abs = true) {
diff --git a/textproc/stardict3/pkg-message b/textproc/stardict3/pkg-message
index ef455877c6d2..b268a934458f 100644
--- a/textproc/stardict3/pkg-message
+++ b/textproc/stardict3/pkg-message
@@ -1,9 +1,10 @@
-* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
+=====================================================================
+A set of dictionary ports is available for StarDict:
+ chinese/stardict-*
+ japanese/stardict-dict-ja
+ textproc/stardict-*
+ russian/stardict-*
-Now it's time to install some dictionary files:
-
- chinese/stardict2-dict-zh_CN Simplified Chinese - English
- chinese/stardict2-dict-zh_TW Traditional Chinese - English
- japanese/stardict2-dict-ja Japanese - English
-
-* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
+More dictionaries can be downloaded from StarDict website:
+http://stardict.sourceforge.net/Dictionaries.php
+=====================================================================
diff --git a/textproc/stardict3/pkg-plist b/textproc/stardict3/pkg-plist
index 19862055a8b8..df34919df369 100644
--- a/textproc/stardict3/pkg-plist
+++ b/textproc/stardict3/pkg-plist
@@ -1,69 +1,97 @@
bin/stardict
+lib/stardict/plugins/stardict_dictdotcn.la
+lib/stardict/plugins/stardict_dictdotcn.so
+lib/stardict/plugins/stardict_html_parsedata.la
+lib/stardict/plugins/stardict_html_parsedata.so
+lib/stardict/plugins/stardict_man.la
+lib/stardict/plugins/stardict_man.so
+lib/stardict/plugins/stardict_powerword_parsedata.la
+lib/stardict/plugins/stardict_powerword_parsedata.so
+lib/stardict/plugins/stardict_qqwry.la
+lib/stardict/plugins/stardict_qqwry.so
+lib/stardict/plugins/stardict_spell.la
+lib/stardict/plugins/stardict_spell.so
+lib/stardict/plugins/stardict_wiki_parsedata.la
+lib/stardict/plugins/stardict_wiki_parsedata.so
+lib/stardict/plugins/stardict_wordnet.la
+lib/stardict/plugins/stardict_wordnet.so
+lib/stardict/plugins/stardict_wordnet_parsedata.la
+lib/stardict/plugins/stardict_wordnet_parsedata.so
+lib/stardict/plugins/stardict_xdxf_parsedata.la
+lib/stardict/plugins/stardict_xdxf_parsedata.so
%%GNOME%%libdata/bonobo/servers/GNOME_Stardict.server
share/applications/stardict.desktop
-%%GNOME%%share/gnome/help/stardict/C/legal.xml
-%%GNOME%%share/gnome/help/stardict/C/stardict.xml
+%%GNOME%%share/gnome/help/stardict/C/figures/acrobat_toolbar.png
+%%GNOME%%share/gnome/help/stardict/C/figures/portable_apps_menu.png
%%GNOME%%share/gnome/help/stardict/C/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/C/figures/stardict_full_text_translation.png
%%GNOME%%share/gnome/help/stardict/C/figures/stardict_main_window.png
%%GNOME%%share/gnome/help/stardict/C/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/legal.xml
-%%GNOME%%share/gnome/help/stardict/zh_CN/stardict.xml
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/legal.xml
-%%GNOME%%share/gnome/help/stardict/zh_TW/stardict.xml
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/uk/legal.xml
-%%GNOME%%share/gnome/help/stardict/uk/stardict.xml
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/ru/legal.xml
-%%GNOME%%share/gnome/help/stardict/ru/stardict.xml
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/mk/legal.xml
-%%GNOME%%share/gnome/help/stardict/mk/stardict.xml
+%%GNOME%%share/gnome/help/stardict/C/figures/stardict_windows_console.png
+%%GNOME%%share/gnome/help/stardict/C/legal.xml
+%%GNOME%%share/gnome/help/stardict/C/stardict.xml
+%%GNOME%%share/gnome/help/stardict/mk/figures/acrobat_toolbar.png
+%%GNOME%%share/gnome/help/stardict/mk/figures/portable_apps_menu.png
%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_full_text_translation.png
%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_main_window.png
%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/nl/legal.xml
-%%GNOME%%share/gnome/help/stardict/nl/stardict.xml
+%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_windows_console.png
+%%GNOME%%share/gnome/help/stardict/mk/stardict.xml
+%%GNOME%%share/gnome/help/stardict/nl/figures/acrobat_toolbar.png
+%%GNOME%%share/gnome/help/stardict/nl/figures/portable_apps_menu.png
%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_full_text_translation.png
%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_main_window.png
%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_notification_area.png
+%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_windows_console.png
+%%GNOME%%share/gnome/help/stardict/nl/stardict.xml
+%%GNOME%%share/gnome/help/stardict/ru/figures/acrobat_toolbar.png
+%%GNOME%%share/gnome/help/stardict/ru/figures/portable_apps_menu.png
+%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_full_text_translation.png
+%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_main_window.png
+%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_notification_area.png
+%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_windows_console.png
+%%GNOME%%share/gnome/help/stardict/ru/stardict.xml
+%%GNOME%%share/gnome/help/stardict/uk/figures/acrobat_toolbar.png
+%%GNOME%%share/gnome/help/stardict/uk/figures/portable_apps_menu.png
+%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_full_text_translation.png
+%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_main_window.png
+%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_notification_area.png
+%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_windows_console.png
+%%GNOME%%share/gnome/help/stardict/uk/stardict.xml
+%%GNOME%%share/gnome/help/stardict/zh_CN/figures/acrobat_toolbar.png
+%%GNOME%%share/gnome/help/stardict/zh_CN/figures/portable_apps_menu.png
+%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_full_text_translation.png
+%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_main_window.png
+%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_notification_area.png
+%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_windows_console.png
+%%GNOME%%share/gnome/help/stardict/zh_CN/stardict.xml
+%%GNOME%%share/gnome/help/stardict/zh_TW/figures/acrobat_toolbar.png
+%%GNOME%%share/gnome/help/stardict/zh_TW/figures/portable_apps_menu.png
+%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_float_window.png
+%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_full_text_translation.png
+%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_main_window.png
+%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_notification_area.png
+%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_windows_console.png
+%%GNOME%%share/gnome/help/stardict/zh_TW/stardict.xml
%%GNOME%%share/idl/GNOME_Stardict.idl
-%%GNOME%%share/omf/stardict/stardict-C.omf
-%%GNOME%%share/omf/stardict/stardict-zh_CN.omf
-%%GNOME%%share/omf/stardict/stardict-zh_TW.omf
-%%GNOME%%share/omf/stardict/stardict-uk.omf
-%%GNOME%%share/omf/stardict/stardict-ru.omf
-%%GNOME%%share/omf/stardict/stardict-mk.omf
-%%GNOME%%share/omf/stardict/stardict-nl.omf
-share/pixmaps/stardict.png
-share/stardict/pixmaps/docklet_normal.png
-share/stardict/pixmaps/docklet_scan.png
-share/stardict/pixmaps/docklet_stop.png
-share/stardict/pixmaps/index_appendix.png
-share/stardict/pixmaps/index_wazard.png
-share/stardict/pixmaps/index_dictlist.png
-share/stardict/pixmaps/index_translate.png
-share/stardict/pixmaps/splash.png
-share/stardict/sounds/menushow.wav
-share/stardict/sounds/buttonactive.wav
share/locale/ar/LC_MESSAGES/stardict.mo
+share/locale/be/LC_MESSAGES/stardict.mo
share/locale/cs/LC_MESSAGES/stardict.mo
share/locale/de/LC_MESSAGES/stardict.mo
share/locale/el/LC_MESSAGES/stardict.mo
+share/locale/es/LC_MESSAGES/stardict.mo
share/locale/fr/LC_MESSAGES/stardict.mo
share/locale/ga/LC_MESSAGES/stardict.mo
share/locale/hr/LC_MESSAGES/stardict.mo
share/locale/hu/LC_MESSAGES/stardict.mo
+share/locale/kk/LC_MESSAGES/stardict.mo
share/locale/ku/LC_MESSAGES/stardict.mo
+share/locale/lt/LC_MESSAGES/stardict.mo
share/locale/mk/LC_MESSAGES/stardict.mo
share/locale/nl/LC_MESSAGES/stardict.mo
share/locale/pt_BR/LC_MESSAGES/stardict.mo
@@ -77,93 +105,74 @@ share/locale/uk/LC_MESSAGES/stardict.mo
share/locale/vi/LC_MESSAGES/stardict.mo
share/locale/zh_CN/LC_MESSAGES/stardict.mo
share/locale/zh_TW/LC_MESSAGES/stardict.mo
-lib/stardict/plugins/stardict_dictdotcn.so
-lib/stardict/plugins/stardict_dictdotcn.la
-lib/stardict/plugins/stardict_man.so
-lib/stardict/plugins/stardict_man.la
-lib/stardict/plugins/stardict_html_parsedata.so
-lib/stardict/plugins/stardict_html_parsedata.la
-lib/stardict/plugins/stardict_xdxf_parsedata.so
-lib/stardict/plugins/stardict_xdxf_parsedata.la
-lib/stardict/plugins/stardict_wordnet.so
-lib/stardict/plugins/stardict_wordnet.la
-lib/stardict/plugins/stardict_wordnet_parsedata.so
-lib/stardict/plugins/stardict_wordnet_parsedata.la
-lib/stardict/plugins/stardict_powerword_parsedata.so
-lib/stardict/plugins/stardict_powerword_parsedata.la
-lib/stardict/plugins/stardict_wiki_parsedata.so
-lib/stardict/plugins/stardict_wiki_parsedata.la
-lib/stardict/plugins/stardict_spell.so
-lib/stardict/plugins/stardict_spell.la
-lib/stardict/plugins/stardict_qqwry.so
-lib/stardict/plugins/stardict_qqwry.la
-@dirrmtry share/locale/ar/LC_MESSAGES
-@dirrmtry share/locale/ar
-@dirrmtry share/locale/cs/LC_MESSAGES
-@dirrmtry share/locale/cs
-@dirrmtry share/locale/de/LC_MESSAGES
-@dirrmtry share/locale/de
-@dirrmtry share/locale/el/LC_MESSAGES
-@dirrmtry share/locale/el
-@dirrmtry share/locale/fr/LC_MESSAGES
-@dirrmtry share/locale/fr
-@dirrmtry share/locale/ga/LC_MESSAGES
-@dirrmtry share/locale/ga
-@dirrmtry share/locale/hr/LC_MESSAGES
-@dirrmtry share/locale/hr
-@dirrmtry share/locale/hu/LC_MESSAGES
-@dirrmtry share/locale/hu
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/mk/LC_MESSAGES
-@dirrmtry share/locale/mk
-@dirrmtry share/locale/nl/LC_MESSAGES
-@dirrmtry share/locale/nl
-@dirrmtry share/locale/pt_BR/LC_MESSAGES
-@dirrmtry share/locale/pt_BR
-@dirrmtry share/locale/ru/LC_MESSAGES
-@dirrmtry share/locale/ru
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/sk/LC_MESSAGES
-@dirrmtry share/locale/sk
-@dirrmtry share/locale/sv/LC_MESSAGES
-@dirrmtry share/locale/sv
-@dirrmtry share/locale/tr/LC_MESSAGES
-@dirrmtry share/locale/tr
-@dirrmtry share/locale/tt/LC_MESSAGES
-@dirrmtry share/locale/tt
-@dirrmtry share/locale/uk/LC_MESSAGES
-@dirrmtry share/locale/uk
-@dirrmtry share/locale/vi/LC_MESSAGES
-@dirrmtry share/locale/vi
-@dirrmtry share/locale/zh_CN/LC_MESSAGES
-@dirrmtry share/locale/zh_CN
-@dirrmtry share/locale/zh_TW/LC_MESSAGES
-@dirrmtry share/locale/zh_TW
-@dirrm lib/stardict/plugins
-@dirrm lib/stardict
+%%GNOME%%share/omf/stardict/stardict-C.omf
+%%GNOME%%share/omf/stardict/stardict-mk.omf
+%%GNOME%%share/omf/stardict/stardict-nl.omf
+%%GNOME%%share/omf/stardict/stardict-ru.omf
+%%GNOME%%share/omf/stardict/stardict-uk.omf
+%%GNOME%%share/omf/stardict/stardict-zh_CN.omf
+%%GNOME%%share/omf/stardict/stardict-zh_TW.omf
+share/pixmaps/stardict.png
+share/stardict/dic/stardict-dict/res/huzheng.png
+share/stardict/dic/stardict-dict/res/huzheng_redhat.png
+share/stardict/dic/stardict-dict/res/linux_logo.jpg
+share/stardict/dic/stardict-dict/res/redhat_linux_logo.gif
+share/stardict/dic/stardict-dict/res/redhat_logo.jpg
+share/stardict/dic/stardict-dict/res/splash.png
+share/stardict/dic/stardict-dict/res/wenjing.jpg
+share/stardict/dic/stardict-dict/res/wenjing2.jpg
+share/stardict/dic/stardict-dict/stardict-dict.dict.dz
+share/stardict/dic/stardict-dict/stardict-dict.idx
+share/stardict/dic/stardict-dict/stardict-dict.ifo
+share/stardict/dic/stardict-dict/stardict-dict.syn
+share/stardict/pixmaps/attachment.png
+share/stardict/pixmaps/docklet_normal.png
+share/stardict/pixmaps/docklet_scan.png
+share/stardict/pixmaps/docklet_stop.png
+share/stardict/pixmaps/index_appendix.png
+share/stardict/pixmaps/index_dictlist.png
+share/stardict/pixmaps/index_translate.png
+share/stardict/pixmaps/index_wazard.png
+share/stardict/pixmaps/pronounce.png
+share/stardict/pixmaps/splash.png
+share/stardict/pixmaps/video.png
+share/stardict/sounds/buttonactive.wav
+share/stardict/sounds/menushow.wav
+@dirrmtry share/stardict/treedict
@dirrm share/stardict/sounds
+@dirrm share/stardict/skins
@dirrm share/stardict/pixmaps
-@dirrm share/stardict/treedict
+@dirrm share/stardict/dic/stardict-dict/res
+@dirrm share/stardict/dic/stardict-dict
@dirrmtry share/stardict/dic
@dirrmtry share/stardict
%%GNOME%%@dirrm share/omf/stardict
-%%GNOME%%@dirrm share/gnome/help/stardict/C/figures
-%%GNOME%%@dirrm share/gnome/help/stardict/C
-%%GNOME%%@dirrm share/gnome/help/stardict/zh_CN/figures
-%%GNOME%%@dirrm share/gnome/help/stardict/zh_CN
+@dirrmtry share/locale/tt/LC_MESSAGES
+@dirrmtry share/locale/tt
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+%%GNOME%%@dirrmtry share/idl
%%GNOME%%@dirrm share/gnome/help/stardict/zh_TW/figures
%%GNOME%%@dirrm share/gnome/help/stardict/zh_TW
+%%GNOME%%@dirrm share/gnome/help/stardict/zh_CN/figures
+%%GNOME%%@dirrm share/gnome/help/stardict/zh_CN
%%GNOME%%@dirrm share/gnome/help/stardict/uk/figures
%%GNOME%%@dirrm share/gnome/help/stardict/uk
%%GNOME%%@dirrm share/gnome/help/stardict/ru/figures
%%GNOME%%@dirrm share/gnome/help/stardict/ru
-%%GNOME%%@dirrm share/gnome/help/stardict/mk/figures
-%%GNOME%%@dirrm share/gnome/help/stardict/mk
%%GNOME%%@dirrm share/gnome/help/stardict/nl/figures
%%GNOME%%@dirrm share/gnome/help/stardict/nl
+%%GNOME%%@dirrm share/gnome/help/stardict/mk/figures
+%%GNOME%%@dirrm share/gnome/help/stardict/mk
+%%GNOME%%@dirrm share/gnome/help/stardict/C/figures
+%%GNOME%%@dirrm share/gnome/help/stardict/C
%%GNOME%%@dirrm share/gnome/help/stardict
@dirrmtry share/applications
+@dirrm lib/stardict/plugins
+@dirrm lib/stardict
+@exec mkdir -p %D/share/stardict/skins
@exec mkdir -p %D/share/stardict/treedict
-@exec mkdir -p %D/share/stardict/dic