aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2017-02-18 15:28:02 +0800
committerdemon <demon@FreeBSD.org>2017-02-18 15:28:02 +0800
commitbf4982a92b6f3edccd5df03e04b10399cb2440ac (patch)
tree895aab3d4bfa778c7040496c2ec979c25568d6f4 /textproc
parentafda1fe3476dd17575fdda2f8cc62596483a3267 (diff)
downloadfreebsd-ports-gnome-bf4982a92b6f3edccd5df03e04b10399cb2440ac.tar.gz
freebsd-ports-gnome-bf4982a92b6f3edccd5df03e04b10399cb2440ac.tar.zst
freebsd-ports-gnome-bf4982a92b6f3edccd5df03e04b10399cb2440ac.zip
New port: py-m2r.
M2R is a Python module and command line utility to convert documents formatted with markdown that include embedded reST markups to valid reST formatted documents. PR: 217183 Submitted by: John W. O'Brien <john@saltant.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-m2r/Makefile34
-rw-r--r--textproc/py-m2r/distinfo3
-rw-r--r--textproc/py-m2r/files/patch-setup.py10
-rw-r--r--textproc/py-m2r/pkg-descr5
5 files changed, 53 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ed4367c4d0c1..308aeaa5abb0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1271,6 +1271,7 @@
SUBDIR += py-libxml2
SUBDIR += py-libxslt
SUBDIR += py-ltxml
+ SUBDIR += py-m2r
SUBDIR += py-mako
SUBDIR += py-markdown
SUBDIR += py-markdown2
diff --git a/textproc/py-m2r/Makefile b/textproc/py-m2r/Makefile
new file mode 100644
index 000000000000..b8abcbee6917
--- /dev/null
+++ b/textproc/py-m2r/Makefile
@@ -0,0 +1,34 @@
+# Created by: John W. O'Brien <john@saltant.com>
+# $FreeBSD$
+
+PORTNAME= m2r
+PORTVERSION= 0.1.5
+CATEGORIES= textproc devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= john@saltant.com
+COMMENT= Convert markdown formatted file with reST markup to reST format
+
+LICENSE= MIT
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>0:devel/py-coverage \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mistune>0:textproc/py-mistune \
+ ${PYTHON_PKGNAMEPREFIX}docutils>0:textproc/py-docutils
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3300
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
+.endif
+
+do-test:
+ @cd ${TEST_WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.post.mk>
diff --git a/textproc/py-m2r/distinfo b/textproc/py-m2r/distinfo
new file mode 100644
index 000000000000..1ae3df712837
--- /dev/null
+++ b/textproc/py-m2r/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1487344809
+SHA256 (m2r-0.1.5.tar.gz) = 3448f770aed05ca10390d0917cd51836cbf82a2f095bc91507e6291cfab03223
+SIZE (m2r-0.1.5.tar.gz) = 13202
diff --git a/textproc/py-m2r/files/patch-setup.py b/textproc/py-m2r/files/patch-setup.py
new file mode 100644
index 000000000000..7e80e469ea71
--- /dev/null
+++ b/textproc/py-m2r/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2017-02-17 17:38:50 UTC
++++ setup.py
+@@ -27,7 +27,6 @@ setup(
+ author_email='miyako.dev@gmail.com',
+ url='https://github.com/miyakogi/m2r',
+ py_modules=['m2r'],
+- packages=['tests'],
+ entry_points={'console_scripts': 'm2r = m2r:main'},
+ include_package_data=True,
+ license="MIT",
diff --git a/textproc/py-m2r/pkg-descr b/textproc/py-m2r/pkg-descr
new file mode 100644
index 000000000000..1852d96b973f
--- /dev/null
+++ b/textproc/py-m2r/pkg-descr
@@ -0,0 +1,5 @@
+M2R is a Python module and command line utility to convert documents
+formatted with markdown that include embedded reST markups to valid
+reST formatted documents.
+
+WWW: https://github.com/miyakogi/m2r