aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoruqs <uqs@FreeBSD.org>2014-08-19 15:44:30 +0800
committeruqs <uqs@FreeBSD.org>2014-08-19 15:44:30 +0800
commitc685a30cd1d9e13c8d53dc7e40dfae21ca42c95f (patch)
treef289a1f7171c0159402282af1e5afde50dcf0544 /textproc
parent2fa9b04c88c014871f5360dfd8fb330239ed3976 (diff)
downloadfreebsd-ports-gnome-c685a30cd1d9e13c8d53dc7e40dfae21ca42c95f.tar.gz
freebsd-ports-gnome-c685a30cd1d9e13c8d53dc7e40dfae21ca42c95f.tar.zst
freebsd-ports-gnome-c685a30cd1d9e13c8d53dc7e40dfae21ca42c95f.zip
Update mdocml to 1.13.1
Diffstat (limited to 'textproc')
-rw-r--r--textproc/mdocml/Makefile10
-rw-r--r--textproc/mdocml/distinfo4
-rw-r--r--textproc/mdocml/files/patch-mdoc_macro.c33
-rw-r--r--textproc/mdocml/files/patch-mdoc_validate.c11
-rw-r--r--textproc/mdocml/pkg-plist15
5 files changed, 55 insertions, 18 deletions
diff --git a/textproc/mdocml/Makefile b/textproc/mdocml/Makefile
index 33b2357df41a..522d9b26dd27 100644
--- a/textproc/mdocml/Makefile
+++ b/textproc/mdocml/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mdocml
-PORTVERSION= 1.12.3
+PORTVERSION= 1.13.1
CATEGORIES= textproc
MASTER_SITES= http://mdocml.bsd.lv/snapshots/ \
${MASTER_SITE_LOCAL}
@@ -11,13 +11,15 @@ MASTER_SITE_SUBDIR= uqs
MAINTAINER= uqs@FreeBSD.org
COMMENT= mdoc macro compiler
+LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
+
EXAMPLESDIR_REL=share/examples/mandoc
-# Skip installing preconv(1) to avoid conflicting with textproc/groff
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
post-patch:
@${REINPLACE_CMD} -e '/^CFLAGS/s/-g//' -e '/^PREFIX/s/=/?=/' \
- -e '/INSTALL_LIB/d' -e '/LIBDIR/d' -e '/INCLUDEDIR/d' \
- -e '/INSTALL_/s/preconv\(\.1\)*//' \
${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/textproc/mdocml/distinfo b/textproc/mdocml/distinfo
index 431762ab7e3c..6c953819768a 100644
--- a/textproc/mdocml/distinfo
+++ b/textproc/mdocml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mdocml-1.12.3.tar.gz) = 8ae7f7d471d52313707c4d78b25846dc4edca395b36ad20f24dead5399c13ee6
-SIZE (mdocml-1.12.3.tar.gz) = 292544
+SHA256 (mdocml-1.13.1.tar.gz) = 7a18e728dc8555b1095bf7edbf086e1d6afb5508c06a7baecfd0b0e448648bf9
+SIZE (mdocml-1.13.1.tar.gz) = 317389
diff --git a/textproc/mdocml/files/patch-mdoc_macro.c b/textproc/mdocml/files/patch-mdoc_macro.c
new file mode 100644
index 000000000000..9f9619e41542
--- /dev/null
+++ b/textproc/mdocml/files/patch-mdoc_macro.c
@@ -0,0 +1,33 @@
+Log Message:
+-----------
+If a stray .It follows .El, we are no longer in the list,
+even though the list is still the last processed macro.
+This fixes a regression introduced in mdoc_macro.c rev. 1.138:
+Ulrich Spoerlein <uqs at FreeBSD> reports that various of their
+kernel manuals trigger assertions.
+
+Modified Files:
+--------------
+ mdocml:
+ mdoc_macro.c
+
+Revision Data
+-------------
+Index: mdoc_macro.c
+===================================================================
+RCS file: /usr/vhosts/mdocml.bsd.lv/cvs/mdocml/mdoc_macro.c,v
+retrieving revision 1.140
+retrieving revision 1.141
+diff -Lmdoc_macro.c -Lmdoc_macro.c -u -p -r1.140 -r1.141
+--- mdoc_macro.c
++++ mdoc_macro.c
+@@ -1041,7 +1041,8 @@ blk_full(MACRO_PROT_ARGS)
+
+ if (tok == MDOC_It) {
+ for (n = mdoc->last; n; n = n->parent)
+- if (n->tok == MDOC_Bl)
++ if (n->tok == MDOC_Bl &&
++ ! (n->flags & MDOC_VALID))
+ break;
+ if (n == NULL) {
+ mandoc_vmsg(MANDOCERR_IT_STRAY, mdoc->parse,
diff --git a/textproc/mdocml/files/patch-mdoc_validate.c b/textproc/mdocml/files/patch-mdoc_validate.c
deleted file mode 100644
index 2660539e37d6..000000000000
--- a/textproc/mdocml/files/patch-mdoc_validate.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mdoc_validate.c
-+++ mdoc_validate.c
-@@ -2143,6 +2143,8 @@ post_os(POST_ARGS)
- mdoc_nmsg(m, n, MANDOCERR_MEM);
- return(0);
- }
-+ if (strncmp(utsname.sysname, "FreeBSD", sizeof("FreeBSD")) == 0)
-+ strtok(utsname.release, "-");
- if (strlcat(buf, utsname.release, BUFSIZ) >= BUFSIZ) {
- mdoc_nmsg(m, n, MANDOCERR_MEM);
- return(0);
diff --git a/textproc/mdocml/pkg-plist b/textproc/mdocml/pkg-plist
index 089159631571..feba53ae6600 100644
--- a/textproc/mdocml/pkg-plist
+++ b/textproc/mdocml/pkg-plist
@@ -1,14 +1,27 @@
+bin/apropos
bin/demandoc
bin/mandoc
+@comment bin/preconv
+bin/whatis
+man/man1/apropos.1.gz
man/man1/demandoc.1.gz
man/man1/mandoc.1.gz
+@comment man/man1/preconv.1.gz
+man/man1/whatis.1.gz
man/man3/mandoc.3.gz
+man/man3/mandoc_escape.3.gz
+man/man3/mandoc_malloc.3.gz
+man/man3/mansearch.3.gz
+man/man3/mchars_alloc.3.gz
man/man3/tbl.3.gz
+man/man5/mandoc.db.5.gz
man/man7/eqn.7.gz
man/man7/man.7.gz
man/man7/mandoc_char.7.gz
man/man7/mdoc.7.gz
-man/man7/roff.7.gz
+@comment man/man7/roff.7.gz
man/man7/tbl.7.gz
+man/man8/makewhatis.8.gz
+sbin/makewhatis
%%EXAMPLESDIR%%/example.style.css
@dirrmtry %%EXAMPLESDIR%%