aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-10-31 23:11:11 +0800
committerbapt <bapt@FreeBSD.org>2013-10-31 23:11:11 +0800
commitc77043cb784798d20a6606aa761c3808cbcc0da8 (patch)
treeecf3fd389b335d277538b42fd59b1c876babcd2d /textproc
parente95d63d47de07552e05df160fbbede84bddb441d (diff)
downloadfreebsd-ports-gnome-c77043cb784798d20a6606aa761c3808cbcc0da8.tar.gz
freebsd-ports-gnome-c77043cb784798d20a6606aa761c3808cbcc0da8.tar.zst
freebsd-ports-gnome-c77043cb784798d20a6606aa761c3808cbcc0da8.zip
Fix trying to ranlib a readonly file (thank automake used without libtool)
Fix shebang of ispellaff2myspell Add run dependency on perl Strip final binaries Bump portrevision
Diffstat (limited to 'textproc')
-rw-r--r--textproc/hunspell/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index 967d46e7d3d7..694fad65baa3 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hunspell
PORTVERSION= 1.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/Hunspell/${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
@@ -16,10 +16,18 @@ LICENSE_COMB= dual
CONFIGURE_ARGS= --disable-nls ${ICONV_CONFIGURE_ARG} --with-readline --with-ui
GNU_CONFIGURE= yes
-USES= pathfix iconv ncurses readline
+USES= pathfix iconv ncurses readline shebangfix perl5
+SHEBANG_FILES= src/tools/ispellaff2myspell
USE_LDCONFIG= yes
+USE_PERL5= run
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/tools/hunspell.cxx
+post-configure:
+ @${REINPLACE_CMD} -e 's|444|644|g' ${WRKSRC}/src/parsers/Makefile
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libhunspell-1.3.so.0
+
.include <bsd.port.mk>