aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-04-04 17:08:11 +0800
committerstas <stas@FreeBSD.org>2011-04-04 17:08:11 +0800
commitd30616988ff9dd3950583e786a4d443036fe2167 (patch)
tree3f602d6c4d311cfd609f48a1768fc12c8dcb5f79 /textproc
parent13e4ffc90f5845ae22a46bfe0e04528c46551ab7 (diff)
downloadfreebsd-ports-gnome-d30616988ff9dd3950583e786a4d443036fe2167.tar.gz
freebsd-ports-gnome-d30616988ff9dd3950583e786a4d443036fe2167.tar.zst
freebsd-ports-gnome-d30616988ff9dd3950583e786a4d443036fe2167.zip
- Fix build with ocaml 3.12.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/bibtex2html/files/patch-Makefile.in15
-rw-r--r--textproc/htmlc/files/patch-compiler_Makefile17
2 files changed, 29 insertions, 3 deletions
diff --git a/textproc/bibtex2html/files/patch-Makefile.in b/textproc/bibtex2html/files/patch-Makefile.in
index 6e68e3c8aad1..6b7da44a9cb4 100644
--- a/textproc/bibtex2html/files/patch-Makefile.in
+++ b/textproc/bibtex2html/files/patch-Makefile.in
@@ -1,6 +1,15 @@
---- Makefile.in.orig 2010-09-29 06:56:25.000000000 +0000
-+++ Makefile.in 2010-10-24 23:00:14.000000000 +0000
-@@ -60,7 +60,7 @@ BIB2BIBOBJS = options.cmx bibtex.cmx bib
+--- Makefile.in.orig 2010-09-28 23:56:25.000000000 -0700
++++ Makefile.in 2011-04-04 02:06:08.000000000 -0700
+@@ -45,7 +45,7 @@
+ FLAGS = $(ZLIBS) $(DEBUG)
+ PROFILE =
+
+-STRLIB = -cclib -lstr
++STRLIB =
+
+ OBJS = options.cmx html.cmx latexmacros.cmx latexscan.cmx bbl_lexer.cmx \
+ bibtex.cmx bibtex_parser.cmx bibtex_lexer.cmx \
+@@ -60,7 +60,7 @@
bibfilter.cmx latexmacros.cmx latexscan.cmx expand.cmx \
html.cmx biboutput.cmx version.cmx copying.cmx bib2bib.cmx
diff --git a/textproc/htmlc/files/patch-compiler_Makefile b/textproc/htmlc/files/patch-compiler_Makefile
new file mode 100644
index 000000000000..99095b44e95e
--- /dev/null
+++ b/textproc/htmlc/files/patch-compiler_Makefile
@@ -0,0 +1,17 @@
+--- compiler/Makefile.orig 2011-04-04 02:08:25.000000000 -0700
++++ compiler/Makefile 2011-04-04 02:08:42.000000000 -0700
+@@ -37,12 +37,12 @@
+
+ $(PROG).bin: $(BINOBJS)
+ $(CAMLBIN) -o $(PROG).bin str.cmxa unix.cmxa $(BINOBJS) \
+- -cclib -lunix -cclib -lstr && \
++ && \
+ $(RM) $(PROG) && ln -s $(PROG).bin $(PROG)
+
+ $(PROG).byt: $(BYTOBJS)
+ $(CAMLBYT) -g -custom -o $(PROG).byt str.cma unix.cma $(BYTOBJS) \
+- -cclib -lunix -cclib -lstr && \
++ && \
+ $(RM) $(PROG) && ln -s $(PROG).byt $(PROG)
+
+ installbyt: