aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-01-03 07:08:27 +0800
committerswills <swills@FreeBSD.org>2017-01-03 07:08:27 +0800
commitdef7efb9972c388ec09b7df5fbd7a6bc03128848 (patch)
tree1067c3d0391bc53d9e706adcfc8de371f60907ec /textproc
parent892093e67bfb3b65a28eee0aea3265d83e263e28 (diff)
downloadfreebsd-ports-gnome-def7efb9972c388ec09b7df5fbd7a6bc03128848.tar.gz
freebsd-ports-gnome-def7efb9972c388ec09b7df5fbd7a6bc03128848.tar.zst
freebsd-ports-gnome-def7efb9972c388ec09b7df5fbd7a6bc03128848.zip
textproc/rubygem-rails-dom-testing1: create port
Create port for 1.x version of rubygem-rails-dom-testing for the ports that still need the older version.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-rails-dom-testing1/Makefile26
-rw-r--r--textproc/rubygem-rails-dom-testing1/distinfo3
-rw-r--r--textproc/rubygem-rails-dom-testing1/pkg-descr8
4 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8e8476c27c37..444a2c87cb1b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1487,6 +1487,7 @@
SUBDIR += rubygem-phone
SUBDIR += rubygem-pretty-xml
SUBDIR += rubygem-rails-dom-testing
+ SUBDIR += rubygem-rails-dom-testing1
SUBDIR += rubygem-rails-html-sanitizer
SUBDIR += rubygem-rak
SUBDIR += rubygem-rchardet
diff --git a/textproc/rubygem-rails-dom-testing1/Makefile b/textproc/rubygem-rails-dom-testing1/Makefile
new file mode 100644
index 000000000000..e9c913fafcfb
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing1/Makefile
@@ -0,0 +1,26 @@
+# Created by: Johannes Jost Meixner <xmj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rails-dom-testing
+PORTVERSION= 1.0.8
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 1
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Analyse and compare DOMs using Nokogiri
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-activesupport4>=4.2.0:devel/rubygem-activesupport4 \
+ rubygem-nokogiri>=1.6:textproc/rubygem-nokogiri \
+ rubygem-rails-deprecated_sanitizer>=1.0.1:devel/rubygem-rails-deprecated_sanitizer
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+PORTSCOUT= limit:^1\.
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-rails-dom-testing1/distinfo b/textproc/rubygem-rails-dom-testing1/distinfo
new file mode 100644
index 000000000000..e2edab58d70c
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483397706
+SHA256 (rubygem/rails-dom-testing-1.0.8.gem) = 19dd4498c8e203b6c7747d0261d961354712e6f67bc74bdecf4060d8e5aac7db
+SIZE (rubygem/rails-dom-testing-1.0.8.gem) = 17408
diff --git a/textproc/rubygem-rails-dom-testing1/pkg-descr b/textproc/rubygem-rails-dom-testing1/pkg-descr
new file mode 100644
index 000000000000..c87a1ba37065
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing1/pkg-descr
@@ -0,0 +1,8 @@
+This gem is responsible for comparing HTML doms and asserting that DOM elements
+are present in Rails applications. Doms are compared via assert_dom_equal and
+assert_dom_not_equal. Elements are asserted via assert_select,
+assert_select_encoded, assert_select_email and a subset of the dom can be
+selected with css_select. The gem is developed for Rails 4.2 and above, and
+will not work on previous versions.
+
+WWW: https://github.com/rails/rails-dom-testing