aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-09-03 04:39:26 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-09-03 04:39:26 +0800
commitf563d1bfa338bcb20e6af302b8f8c32044980081 (patch)
treea5a695bc7185ac057ce00212cf505eee7beaf982 /textproc
parent7d13068a83205b56c77c142325826f5f30e5c214 (diff)
downloadfreebsd-ports-gnome-f563d1bfa338bcb20e6af302b8f8c32044980081.tar.gz
freebsd-ports-gnome-f563d1bfa338bcb20e6af302b8f8c32044980081.tar.zst
freebsd-ports-gnome-f563d1bfa338bcb20e6af302b8f8c32044980081.zip
- Fix build with gcc4.2 and amd64: remove -fwritable-strings.
- Remove GNU_CONFIGURE since it was doing nothing: respect CXX CXXFLAGS. - Clean some warnings related to deprecated C++ headers. - Use %%DOCSDIR%% in pkg-plist PR: 126441 Submitted by: "Pedro F. Giffuni" <giffunip at tutopia dot com> Approved by: Paul Marquis <pmarquis at pobox dot com> (maintainer)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/isearch/Makefile15
-rw-r--r--textproc/isearch/files/patch-Makefile53
-rw-r--r--textproc/isearch/files/patch-doctype+Makefile20
-rw-r--r--textproc/isearch/files/patch-src+string::hxx12
-rw-r--r--textproc/isearch/files/patch-src::Iindex.cxx11
-rw-r--r--textproc/isearch/files/patch-src::fc.hxx12
-rw-r--r--textproc/isearch/files/patch-src::intlist.hxx12
-rw-r--r--textproc/isearch/files/patch-src::mergeunit.hxx10
-rw-r--r--textproc/isearch/files/patch-src::opstack.hxx11
-rw-r--r--textproc/isearch/files/patch-src::string.cxx18
-rw-r--r--textproc/isearch/pkg-plist10
11 files changed, 167 insertions, 17 deletions
diff --git a/textproc/isearch/Makefile b/textproc/isearch/Makefile
index a7f3503a3e18..f4b0edaf1c7c 100644
--- a/textproc/isearch/Makefile
+++ b/textproc/isearch/Makefile
@@ -1,12 +1,13 @@
# New ports collection makefile for: isearch
# Date created: 21 Sept 1996
-# Whom: Pedro
+# Whom: Pedro Giffuni
#
# $FreeBSD$
#
PORTNAME= isearch
PORTVERSION= 1.47i
+PORTREVISION= 1
CATEGORIES= textproc databases
MASTER_SITES= http://www.etymon.com/software/Isearch/
DISTNAME= Isearch-${PORTVERSION}
@@ -14,7 +15,9 @@ DISTNAME= Isearch-${PORTVERSION}
MAINTAINER= pmarquis@pobox.com
COMMENT= Text Search Engine by CNIDR
-GNU_CONFIGURE= yes
+USE_GCC= 3.4
+CFLAGS+= -fwritable-strings
+
MAKE_ARGS= INSTALL=${PREFIX}/bin
post-install:
@@ -23,10 +26,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/html/*.html ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/isearch/files/patch-Makefile b/textproc/isearch/files/patch-Makefile
new file mode 100644
index 000000000000..e538644baa82
--- /dev/null
+++ b/textproc/isearch/files/patch-Makefile
@@ -0,0 +1,53 @@
+--- Makefile.orig 2000-10-12 15:55:56.000000000 -0500
++++ Makefile 2008-08-10 22:44:02.000000000 -0500
+@@ -23,9 +23,9 @@
+ #
+ # Compiler
+ #
+-CC=g++
++CC=${CXX}
+
+-DTCC=g++
++DTCC=${CXX}
+ #CC=/sw/CenterLine/bin/CC
+
+ #
+@@ -45,7 +45,7 @@
+ #
+ # for Linux
+ #
+-CFLAGS=-O2 -DUNIX -fwritable-strings
++CFLAGS=-O2 -DUNIX ${CXXFLAGS}
+ #CFLAGS=-g -fwritable-strings -Wall -Wno-unused -DUNIX # -DVERBOSE -DDEBUG
+
+ #
+@@ -76,8 +76,8 @@
+ #
+ # Where should I install executables (make install)?
+ #
+-INSTALL=/usr/local/bin
+-CGI_INSTALL=/home/httpd/cgi-bin
++INSTALL=${PREFIX}/bin
++CGI_INSTALL=/usr/local/www/cgi-bin
+
+ #
+ # Executables Directory
+@@ -189,12 +189,12 @@
+
+ install:
+ @echo "*** Copying Isearch executables to $(INSTALL) ***"
+- cp $(BIN_DIR)/Iindex $(INSTALL)
+- cp $(BIN_DIR)/Isearch $(INSTALL)
+- cp $(BIN_DIR)/Iutil $(INSTALL)
+- cp $(BIN_DIR)/Iget $(INSTALL)
+- cp $(BIN_DIR)/zsearch $(INSTALL)
+- cp $(BIN_DIR)/zpresent $(INSTALL)
++ install -s $(BIN_DIR)/Iindex $(INSTALL)
++ install -s $(BIN_DIR)/Isearch $(INSTALL)
++ install -s $(BIN_DIR)/Iutil $(INSTALL)
++ install -s $(BIN_DIR)/Iget $(INSTALL)
++ install -s $(BIN_DIR)/zsearch $(INSTALL)
++ install -s $(BIN_DIR)/zpresent $(INSTALL)
+ @echo ""
+ @echo "To install Isearch-cgi, cd into the Isearch-cgi directory"
+ @echo "Then run the configure script"
diff --git a/textproc/isearch/files/patch-doctype+Makefile b/textproc/isearch/files/patch-doctype+Makefile
new file mode 100644
index 000000000000..9739aedd12fa
--- /dev/null
+++ b/textproc/isearch/files/patch-doctype+Makefile
@@ -0,0 +1,20 @@
+--- doctype/Makefile.orig 2008-08-10 20:21:14.000000000 -0500
++++ doctype/Makefile 2008-08-10 20:22:13.000000000 -0500
+@@ -2,7 +2,7 @@
+ #
+ # Compiler
+ #
+-CC=g++
++CC=${CXX}
+
+ #
+ # Compiler Flags
+@@ -13,7 +13,7 @@
+
+ #CFLAGS=-DUNIX -O2
+ #CFLAGS=-g -DUNIX -Wall -O2
+-CFLAGS=-g -DUNIX -Wall -D__CSTRING__
++CFLAGS+= -DUNIX -D__CSTRING__
+
+ #
+ # Source Files Directory
diff --git a/textproc/isearch/files/patch-src+string::hxx b/textproc/isearch/files/patch-src+string::hxx
new file mode 100644
index 000000000000..89a1667604f4
--- /dev/null
+++ b/textproc/isearch/files/patch-src+string::hxx
@@ -0,0 +1,12 @@
+--- src/string.hxx.orig 2008-08-10 20:45:33.000000000 -0500
++++ src/string.hxx 2008-08-10 20:46:39.000000000 -0500
+@@ -44,7 +44,8 @@
+ #define STRING_HXX
+
+ #include <string.h>
+-#include <iostream.h>
++#include <iostream>
++using namespace std;
+ #include "gdt.h"
+ #include "defs.hxx"
+
diff --git a/textproc/isearch/files/patch-src::Iindex.cxx b/textproc/isearch/files/patch-src::Iindex.cxx
new file mode 100644
index 000000000000..91c704666a01
--- /dev/null
+++ b/textproc/isearch/files/patch-src::Iindex.cxx
@@ -0,0 +1,11 @@
+--- src/Iindex.cxx.orig 2008-08-10 22:50:36.000000000 -0500
++++ src/Iindex.cxx 2008-08-10 22:52:14.000000000 -0500
+@@ -170,7 +170,7 @@
+ }
+ }
+ if (Found) {
+- Offset = (GPTYPE)((UINT4)Found - (UINT4)Buffer);
++ Offset = (GPTYPE)((UINT8)Found - (UINT8)Buffer);
+ /* the separator marks the beginning of the next
+ record. (offset - 1), then marks the end of
+ the current record. we must make sure that the
diff --git a/textproc/isearch/files/patch-src::fc.hxx b/textproc/isearch/files/patch-src::fc.hxx
new file mode 100644
index 000000000000..02336ee5c15c
--- /dev/null
+++ b/textproc/isearch/files/patch-src::fc.hxx
@@ -0,0 +1,12 @@
+--- src/fc.hxx.orig 2008-08-10 20:45:08.000000000 -0500
++++ src/fc.hxx 2008-08-10 20:47:33.000000000 -0500
+@@ -8,7 +8,8 @@
+ #ifndef FC_HXX
+ #define FC_HXX
+
+-#include <iostream.h>
++#include <iostream>
++using namespace std;
+ /*
+ #include "defs.hxx"
+ */
diff --git a/textproc/isearch/files/patch-src::intlist.hxx b/textproc/isearch/files/patch-src::intlist.hxx
new file mode 100644
index 000000000000..68808191c90b
--- /dev/null
+++ b/textproc/isearch/files/patch-src::intlist.hxx
@@ -0,0 +1,12 @@
+--- src/intlist.hxx.orig 2008-08-10 20:45:21.000000000 -0500
++++ src/intlist.hxx 2008-08-10 20:47:28.000000000 -0500
+@@ -50,7 +50,8 @@
+
+ #include <stdlib.h>
+ #include <time.h>
+-#include <iostream.h>
++#include <iostream>
++using namespace std;
+
+ #include "gdt.h"
+ #include "defs.hxx"
diff --git a/textproc/isearch/files/patch-src::mergeunit.hxx b/textproc/isearch/files/patch-src::mergeunit.hxx
new file mode 100644
index 000000000000..850929208c59
--- /dev/null
+++ b/textproc/isearch/files/patch-src::mergeunit.hxx
@@ -0,0 +1,10 @@
+--- src/mergeunit.hxx.orig 1998-05-12 16:49:13.000000000 +0000
++++ src/mergeunit.hxx 2007-12-01 16:40:09.000000000 +0000
+@@ -49,6 +49,7 @@ Author: Jim Fullton, MCNC/CNIDR
+
+ #include "defs.hxx"
+ #include "idbobj.hxx"
++#include "filemap.hxx"
+
+ #define LIM 10000
+
diff --git a/textproc/isearch/files/patch-src::opstack.hxx b/textproc/isearch/files/patch-src::opstack.hxx
new file mode 100644
index 000000000000..c007e5230479
--- /dev/null
+++ b/textproc/isearch/files/patch-src::opstack.hxx
@@ -0,0 +1,11 @@
+--- src/opstack.hxx.orig 1996-12-21 00:41:10.000000000 +0000
++++ src/opstack.hxx 2007-12-01 16:38:59.000000000 +0000
+@@ -57,7 +57,7 @@ public:
+ OPSTACK& operator<<(OPOBJ* Op);
+ POPOBJ operator>>(POPOBJ& OpPtr);
+ PIRSET operator>>(PIRSET& OpPtr);
+- void OPSTACK::Reverse();
++ void Reverse();
+ ~OPSTACK();
+ private:
+ void Push(OPOBJ& Op);
diff --git a/textproc/isearch/files/patch-src::string.cxx b/textproc/isearch/files/patch-src::string.cxx
index 784a3ac9cc14..89f95c9b428f 100644
--- a/textproc/isearch/files/patch-src::string.cxx
+++ b/textproc/isearch/files/patch-src::string.cxx
@@ -1,6 +1,18 @@
---- src/string.cxx.orig Sun Dec 15 09:27:00 2002
-+++ src/string.cxx Sun Dec 15 09:27:20 2002
-@@ -574,7 +574,7 @@
+--- src/string.cxx.orig 2000-10-31 01:22:09.000000000 -0500
++++ src/string.cxx 2008-08-10 20:55:59.000000000 -0500
+@@ -45,9 +45,10 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <fstream.h>
+ #include <ctype.h>
+ #include <sys/stat.h>
++#include <fstream>
++using namespace std;
+
+ #ifdef UNIX
+ #include <unistd.h>
+@@ -574,7 +575,7 @@
// can this be const STRING& ?
ostream& operator<<(ostream& os, const STRING& str) {
diff --git a/textproc/isearch/pkg-plist b/textproc/isearch/pkg-plist
index 91614c27faa4..50a6c492f00f 100644
--- a/textproc/isearch/pkg-plist
+++ b/textproc/isearch/pkg-plist
@@ -4,8 +4,8 @@ bin/Isearch
bin/Iutil
bin/zpresent
bin/zsearch
-%%PORTDOCS%%share/doc/isearch/Isearch-cgi-tutorial.html
-%%PORTDOCS%%share/doc/isearch/IsearchFeatures.html
-%%PORTDOCS%%share/doc/isearch/IsearchTutorial.html
-%%PORTDOCS%%share/doc/isearch/QuickStart.html
-%%PORTDOCS%%@dirrm share/doc/isearch
+%%PORTDOCS%%%%DOCSDIR%%/Isearch-cgi-tutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/IsearchFeatures.html
+%%PORTDOCS%%%%DOCSDIR%%/IsearchTutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/QuickStart.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%