aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2017-01-24 00:40:43 +0800
committerolivierd <olivierd@FreeBSD.org>2017-01-24 00:40:43 +0800
commitf923e06d7d7b6ad0a738914135a5a1f7d5fcfd1b (patch)
tree07e8569749d379922e8ef35e48ce40309a1a9c5f /textproc
parent498d7237166c84da1c8042a9624037f08e49a8cc (diff)
downloadfreebsd-ports-gnome-f923e06d7d7b6ad0a738914135a5a1f7d5fcfd1b.tar.gz
freebsd-ports-gnome-f923e06d7d7b6ad0a738914135a5a1f7d5fcfd1b.tar.zst
freebsd-ports-gnome-f923e06d7d7b6ad0a738914135a5a1f7d5fcfd1b.zip
- Update to 1.6.1
- Switch to GitHub host - Remove GETOPT_LONG option - Pass maintainership to submitter PR: 216180 Submitted by: Danilo G. Baio MFH: 2017Q1
Diffstat (limited to 'textproc')
-rw-r--r--textproc/extract_url/Makefile27
-rw-r--r--textproc/extract_url/distinfo5
-rw-r--r--textproc/extract_url/files/extract_urlview31
-rw-r--r--textproc/extract_url/files/patch-extract__url.pl22
-rw-r--r--textproc/extract_url/files/pkg-message.in2
5 files changed, 38 insertions, 49 deletions
diff --git a/textproc/extract_url/Makefile b/textproc/extract_url/Makefile
index d5429459e0d9..adf1ef08e963 100644
--- a/textproc/extract_url/Makefile
+++ b/textproc/extract_url/Makefile
@@ -2,20 +2,16 @@
# $FreeBSD$
PORTNAME= extract_url
-PORTVERSION= 1.5.8
-PORTREVISION= 1
+PORTVERSION= 1.6.1
+DISTVERSIONPREFIX= v
CATEGORIES= textproc
-MASTER_SITES= GOOGLE_CODE
-PROJECTHOST= extracturl
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dbaio@bsd.com.br
COMMENT= Perl script that extracts URLs from email in MIME or plain text format
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= Unfetchable (google code has gone away)
-
BUILD_DEPENDS= p5-MIME-Tools>=0:mail/p5-MIME-Tools \
p5-HTML-Parser>=0:www/p5-HTML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -25,26 +21,26 @@ MAKE_ARGS= all prefix=${PREFIX} man_prefix=${PREFIX}
SUB_FILES= pkg-message
NO_ARCH= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= m3m0ryh0l3
+GH_PROJECT= extracturl
PLIST_FILES= bin/extract_url \
- etc/extract_urlview.sample \
+ share/extract_url/extract_urlview.sample \
man/man1/extract_url.1.gz
PORTDOCS= AUTHORS NEWS README
-OPTIONS_DEFINE= DOCS GETOPT_LONG URI_FIND
+OPTIONS_DEFINE= DOCS URI_FIND
OPTIONS_RADIO= URL_SELECTOR
OPTIONS_RADIO_URL_SELECTOR= CURSES_UI URLVIEW
-OPTIONS_DEFAULT= CURSES_UI GETOPT_LONG URI_FIND
+OPTIONS_DEFAULT= CURSES_UI URI_FIND
OPTIONS_SUB= yes
CURSES_UI_DESC= Allows it to fully replace urlview
-GETOPT_LONG_DESC= Recognizes long options --version and --list
URI_FIND_DESC= Recognizes more exotic URL variations in plain text
URLVIEW_DESC= Uses urlview for the URL selector menu
CURSES_UI_RUN_DEPENDS= p5-Curses-UI>=0:devel/p5-Curses-UI
-GETOPT_LONG_RUN_DEPENDS=p5-Getopt-Long>=0:devel/p5-Getopt-Long
URLVIEW_RUN_DEPENDS= urlview>=0:textproc/urlview
URI_FIND_RUN_DEPENDS= p5-URI-Find>=0:textproc/p5-URI-Find
@@ -53,8 +49,9 @@ post-patch:
${WRKSRC}/${MAKEFILE}
post-install:
- ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}view \
- ${STAGEDIR}${PREFIX}/etc/${PORTNAME}view.sample
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}view.sample \
+ ${STAGEDIR}${DATADIR}/
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/textproc/extract_url/distinfo b/textproc/extract_url/distinfo
index 90df858c7f65..e4c10f47464c 100644
--- a/textproc/extract_url/distinfo
+++ b/textproc/extract_url/distinfo
@@ -1,2 +1,3 @@
-SHA256 (extract_url-1.5.8.tar.gz) = 58eac907cb926deba74ab81e7503a1055fd3cbe20952f011d8e6b75da12d6bcc
-SIZE (extract_url-1.5.8.tar.gz) = 13861
+TIMESTAMP = 1485089324
+SHA256 (m3m0ryh0l3-extracturl-v1.6.1_GH0.tar.gz) = 6ce3a977477cce6c7c8355500db4ef660d5b22118df6534d3ab022124c62a393
+SIZE (m3m0ryh0l3-extracturl-v1.6.1_GH0.tar.gz) = 16192
diff --git a/textproc/extract_url/files/extract_urlview b/textproc/extract_url/files/extract_urlview
deleted file mode 100644
index b08a38f4bddb..000000000000
--- a/textproc/extract_url/files/extract_urlview
+++ /dev/null
@@ -1,31 +0,0 @@
-################################
-### extract_url(1) configuration
-#
-# Copy this file to ~/.extract_urlview
-
-# Command used to view URLs
-#COMMAND firefox %s &
-
-# URL will be opened without prompting when emails contains only one
-#SHORTCUT
-
-# Turn off showing the full URL before opening it
-#NOREVIEW
-
-# Disable the automatic exit of URL selection menu after viewing a URL
-#PERSISTENT
-
-# Ignore links that don't correspond to any text
-#IGNORE_EMPTY_TAGS
-
-# Specify which HTML tags will be examined for URLs
-#HTML_TAGS a,applet,area,blockquote,embed,form,frame,iframe,input,ins,isindex,head,layer,link,object,q,script,xmp
-
-# Key for PERSISTENT behaviour, or opposite if PERSISTENT is specified
-#ALTSELECT k
-
-# Show [url] list or show URLs in [context] when the program is run
-#DEFAULT_VIEW url
-
-# Sanitize URLs before they are displayed
-#DISPLAY_SANITIZED
diff --git a/textproc/extract_url/files/patch-extract__url.pl b/textproc/extract_url/files/patch-extract__url.pl
new file mode 100644
index 000000000000..fe5e094cbd55
--- /dev/null
+++ b/textproc/extract_url/files/patch-extract__url.pl
@@ -0,0 +1,22 @@
+--- extract_url.pl.orig 2017-01-18 14:59:52 UTC
++++ extract_url.pl
+@@ -54,18 +54,7 @@ sub VERSION_MESSAGE {
+
+ my $term_cols = 80;
+ my ($term_rows, $term_wpix, $term_hpix);
+-if (eval "use Term::Readkey") {
+- ($term_cols, $term_rows, $term_wpix, $term_hpix) = GetTerminalSize();
+-} else {
+- require 'sys/ioctl.ph';
+- if (defined &TIOCGWINSZ and open(TTY, "+</dev/tty")) {
+- my $winsize = '';
+- unless (ioctl(TTY, &TIOCGWINSZ, $winsize)) {
+- die sprintf "$0: ioctl TIOCGWINSZ (%08x: $!)\n", &TIOCGWINSZ;
+- }
+- ($term_rows, $term_cols, $term_wpix, $term_hpix) = unpack('S4', $winsize);
+- }
+-}
++require 'sys/ioctl.ph';
+ my $list_width = $term_cols - 4; # 4 is for the border width on either side
+
+ my %options;
diff --git a/textproc/extract_url/files/pkg-message.in b/textproc/extract_url/files/pkg-message.in
index f6ad289066f7..72eb7f882f13 100644
--- a/textproc/extract_url/files/pkg-message.in
+++ b/textproc/extract_url/files/pkg-message.in
@@ -8,7 +8,7 @@ the extract_url configuration file can be copied, please type as user:
su - user
- cp %%PREFIX%%/etc/extract_urlview.sample ~/.extract_urlview
+ cp %%DATADIR%%/extract_urlview.sample ~/.extract_urlview
exit