aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-08-02 23:03:19 +0800
committertijl <tijl@FreeBSD.org>2015-08-02 23:03:19 +0800
commit2593b8ce7a7784074d28066b8690c9c2da075fd7 (patch)
treeea36e7f5c3df09ecf07eacd3dfa1065817e07c56 /textproc
parentdfc31d8ad6426dcddd1e4f4718d93857c195b031 (diff)
downloadfreebsd-ports-gnome-2593b8ce7a7784074d28066b8690c9c2da075fd7.tar.gz
freebsd-ports-gnome-2593b8ce7a7784074d28066b8690c9c2da075fd7.tar.zst
freebsd-ports-gnome-2593b8ce7a7784074d28066b8690c9c2da075fd7.zip
By default libtool replaces -export-symbols <file> with -retain-symbols-file
<file> on ELF systems, but this doesn't really do what -export-symbols is meant to do. On GNU ELF systems it converts <file> to a simple version script first and then uses -version-script instead of -retain-symbols-file. Let USES=libtool patch libtool scripts to do this on all systems with GNU ld(1). Bump PORTREVISION on all ports where the build log contains -export-symbols. audio/calf: This port builds a module that now exports only one function, but it also builds a number of executables that link to this module and expect to see other functions. Because it's already a bit dodgy to link to a module (libtool warns about this) let the module continue to export only one function and instead build an ordinary library from the same source that the executables can link to. Fix a number of other issues in the same Makefile.am and clean up the port Makefile. japanese/scim-honoka: Tries to hide all symbols that start with an underscore, but because this library is written in C++ all symbols start with _Z so it ends up hiding everything. Just don't hide anything at all like the textproc/scim configure script does. multimedia/schroedinger: Apply an upstream patch. textproc/scim-input-pad: Same as japanese/scim-honoka. PR: 201922 Approved by: portmgr (antoine) Exp-run by: antoine
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libextractor/Makefile2
-rw-r--r--textproc/link-grammar/Makefile2
-rw-r--r--textproc/rarian/Makefile2
-rw-r--r--textproc/scim-input-pad/Makefile12
-rw-r--r--textproc/scim-m17n/Makefile2
-rw-r--r--textproc/scim-openvanilla/Makefile2
-rw-r--r--textproc/scim-table-imengine/Makefile2
7 files changed, 13 insertions, 11 deletions
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index 601da78db98e..8a04a5fbf8bd 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libextractor
PORTVERSION= 1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= GNU
diff --git a/textproc/link-grammar/Makefile b/textproc/link-grammar/Makefile
index f5926b093b2c..370ceb9805ca 100644
--- a/textproc/link-grammar/Makefile
+++ b/textproc/link-grammar/Makefile
@@ -2,7 +2,7 @@
PORTNAME= link-grammar
PORTVERSION= 4.7.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= http://www.abisource.com/downloads/${PORTNAME}/${PORTVERSION}/
diff --git a/textproc/rarian/Makefile b/textproc/rarian/Makefile
index 58a81053c201..49163443d345 100644
--- a/textproc/rarian/Makefile
+++ b/textproc/rarian/Makefile
@@ -4,7 +4,7 @@
PORTNAME= rarian
PORTVERSION= 0.8.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc gnome
MASTER_SITES= GNOME
diff --git a/textproc/scim-input-pad/Makefile b/textproc/scim-input-pad/Makefile
index 8dc10b904a3c..b97030bf3622 100644
--- a/textproc/scim-input-pad/Makefile
+++ b/textproc/scim-input-pad/Makefile
@@ -43,12 +43,14 @@ PLIST_SUB+= NLS="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -E 's|(SCIM_LIBEXECDIR=).*|\1${PREFIX}/lib/scim-1.0| ; \
- s|(SCIM_MODULEDIR=).*|\1${PREFIX}/lib/scim-1.0/1.4.0| ; \
- s|(SCIM_ICONDIR=).*|\1${PREFIX}/share/scim/icons| ; \
- s|(SCIM_DATADIR=).*|\1${PREFIX}/share/scim|' \
+ @${REINPLACE_CMD} \
+ -e '/^SCIM_LIBEXECDIR=/s|=.*|=${PREFIX}/lib/scim-1.0|' \
+ -e '/^SCIM_MODULEDIR=/s|=.*|=${PREFIX}/lib/scim-1.0/1.4.0|' \
+ -e '/^SCIM_ICONDIR=/s|=.*|=${PREFIX}/share/scim/icons|' \
+ -e '/^SCIM_DATADIR=/s|=.*|=${PREFIX}/share/scim|' \
+ -e '/^LIBTOOL_EXPORT_OPTIONS=/s/=.*/=/' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -E 's|^_NAME|NAME|g' ${WRKSRC}/data/*.pad.in
+ @${REINPLACE_CMD} 's|^_NAME|NAME|' ${WRKSRC}/data/*.pad.in
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/textproc/scim-m17n/Makefile b/textproc/scim-m17n/Makefile
index ec405b60ded0..284c2126e00c 100644
--- a/textproc/scim-m17n/Makefile
+++ b/textproc/scim-m17n/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scim-m17n
PORTVERSION= 0.2.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= textproc
MASTER_SITES= SF/scim/${PORTNAME}/${PORTVERSION} \
http://anthesphoria.net/FreeBSD/ports/distfiles/
diff --git a/textproc/scim-openvanilla/Makefile b/textproc/scim-openvanilla/Makefile
index 02f9952c4997..594df523f4bd 100644
--- a/textproc/scim-openvanilla/Makefile
+++ b/textproc/scim-openvanilla/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scim-openvanilla
PORTVERSION= 0.7.2.20070514
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= textproc
MASTER_SITES= LOCAL/rafan
DISTNAME= openvanilla-${PORTVERSION}
diff --git a/textproc/scim-table-imengine/Makefile b/textproc/scim-table-imengine/Makefile
index 515a663b1e22..78da9a24efb7 100644
--- a/textproc/scim-table-imengine/Makefile
+++ b/textproc/scim-table-imengine/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scim-table-imengine
PORTVERSION= 0.5.10
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= textproc
MASTER_SITES= SF/scim/scim-tables/${PORTVERSION}
DISTNAME= scim-tables-${PORTVERSION}