aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-04-17 13:27:34 +0800
committermiwi <miwi@FreeBSD.org>2010-04-17 13:27:34 +0800
commit61b0ffb0ff9c28e5a12fc6560bc9bf92b5f03770 (patch)
tree645701d3e9faeecf401db22b10d55814c4ce69ef /textproc
parent7c3beefb281233441df9a80e9170495dbbb6f0fa (diff)
downloadfreebsd-ports-gnome-61b0ffb0ff9c28e5a12fc6560bc9bf92b5f03770.tar.gz
freebsd-ports-gnome-61b0ffb0ff9c28e5a12fc6560bc9bf92b5f03770.tar.zst
freebsd-ports-gnome-61b0ffb0ff9c28e5a12fc6560bc9bf92b5f03770.zip
This library is minimum, easy-to-use, C implementation for xml file parsing.
Because XML parsing is always hard to reinvent. Because very often, xml libraries are too big to fit with little application. WWW: http://code.google.com/p/libroxml/ PR: ports/145755 Submitted by: Hung-Yi Chen <gaod at hychen.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libroxml/Makefile31
-rw-r--r--textproc/libroxml/distinfo3
-rw-r--r--textproc/libroxml/files/patch-Makefile35
-rw-r--r--textproc/libroxml/pkg-descr5
5 files changed, 75 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 07694e465fa0..15edae8df3cc 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -307,6 +307,7 @@
SUBDIR += libnxml
SUBDIR += libparsifal
SUBDIR += libpathan
+ SUBDIR += libroxml
SUBDIR += libstree
SUBDIR += libtext-charwidth-perl
SUBDIR += libtext-wrapi18n-perl
diff --git a/textproc/libroxml/Makefile b/textproc/libroxml/Makefile
new file mode 100644
index 000000000000..1b3e3cb2a021
--- /dev/null
+++ b/textproc/libroxml/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libroxml
+# Date created: 2010-04-16
+# Whom: Hung-Yi Chen <gaod@hychen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libroxml
+PORTVERSION= 2.0.1
+CATEGORIES= textproc
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= libroxml-${PORTVERSION}
+
+MAINTAINER= gaod@hychen.org
+COMMENT= A minimum, easy-to-use, C implementation for xml file parsing
+
+PROJECTHOST= libroxml
+
+USE_GMAKE= yes
+MAKE_ENV+= DESTDIR=${PREFIX}
+USE_LDCONFIG= yes
+
+MAN1= roxml.1
+
+PLIST_FILES= bin/roxml \
+ lib/libroxml.so \
+ lib/libroxml.so.0 \
+ lib/libroxml.a \
+ include/roxml.h
+
+.include <bsd.port.mk>
diff --git a/textproc/libroxml/distinfo b/textproc/libroxml/distinfo
new file mode 100644
index 000000000000..97a4547e4f16
--- /dev/null
+++ b/textproc/libroxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (libroxml-2.0.1.tar.gz) = a309bc508195a5e9ebf8224ff4ef998f
+SHA256 (libroxml-2.0.1.tar.gz) = f544334cae3b7471bf0f8acd41e989c75f7544c09eaba7e1e26b9eab50d1509a
+SIZE (libroxml-2.0.1.tar.gz) = 85427
diff --git a/textproc/libroxml/files/patch-Makefile b/textproc/libroxml/files/patch-Makefile
new file mode 100644
index 000000000000..2c3ebfe7cc22
--- /dev/null
+++ b/textproc/libroxml/files/patch-Makefile
@@ -0,0 +1,35 @@
+--- Makefile.orig 2010-03-20 07:47:37.000000000 +0800
++++ Makefile 2010-04-16 18:56:26.000000000 +0800
+@@ -111,25 +111,13 @@
+ $E - $(MAKE) -C $(abspath fuse.xml)
+
+ .PHONY: install
+-install: $(TARGETS) doxy
+- $P ' INSTALL DIRS'
+- $E mkdir -p $(DESTDIR)/usr/bin
+- $E mkdir -p $(DESTDIR)/usr/include
+- $E mkdir -p $(DESTDIR)/usr/lib/pkgconfig
+- $E mkdir -p $(DESTDIR)/usr/share/man/man3
+- $E mkdir -p $(DESTDIR)/usr/share/man/man1
+- $E mkdir -p $(DESTDIR)/usr/share/doc/libroxml/html
+- $P ' INSTALL FILES'
+- $E install -D $(TARGET_SLIB) $(DESTDIR)/usr/lib
+- $E install -D $(TARGET_LIB) $(DESTDIR)/usr/lib
+- $E install -D $(TARGET_BIN) $(DESTDIR)/usr/bin
+- $E install -D $(INC) $(DESTDIR)/usr/include
+- $E install -D LGPL.txt $(DESTDIR)/usr/share/doc/libroxml/
+- $E install -D docs/roxml.1 $(DESTDIR)/usr/share/man/man1/
+- $E install -D docs/man/man3/* $(DESTDIR)/usr/share/man/man3/
+- $E install -D docs/html/* $(DESTDIR)/usr/share/doc/libroxml/html/
+- $E install -m644 libroxml.pc $(DESTDIR)/usr/lib/pkgconfig
+- $E cp -d $(TARGET_LN) $(DESTDIR)/usr/lib
++install:
++ $E install $(TARGET_SLIB) $(DESTDIR)/lib
++ $E install $(TARGET_LIB) $(DESTDIR)/lib
++ $E install $(TARGET_BIN) $(DESTDIR)/bin
++ $E install $(INC) $(DESTDIR)/include
++ $E install docs/roxml.1 $(DESTDIR)/man/man1/
++ $E install $(TARGET_LN) $(DESTDIR)/lib
+
+ .PHONY: uninstall
+ uninstall:
diff --git a/textproc/libroxml/pkg-descr b/textproc/libroxml/pkg-descr
new file mode 100644
index 000000000000..22c9cb3a95ba
--- /dev/null
+++ b/textproc/libroxml/pkg-descr
@@ -0,0 +1,5 @@
+This library is minimum, easy-to-use, C implementation for xml file parsing.
+Because XML parsing is always hard to reinvent.
+Because very often, xml libraries are too big to fit with little application.
+
+WWW: http://code.google.com/p/libroxml/