aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2015-07-05 18:05:36 +0800
committerrm <rm@FreeBSD.org>2015-07-05 18:05:36 +0800
commitbebd21c11bc48cab2c26d1878ee5624a88f978bb (patch)
tree51eda41d0a8e4bed54c3f472880e6df78e03de68 /textproc
parente60ca3fe2cfe36cd5716424da74cb0642e76cfdd (diff)
downloadfreebsd-ports-gnome-bebd21c11bc48cab2c26d1878ee5624a88f978bb.tar.gz
freebsd-ports-gnome-bebd21c11bc48cab2c26d1878ee5624a88f978bb.tar.zst
freebsd-ports-gnome-bebd21c11bc48cab2c26d1878ee5624a88f978bb.zip
textproc/pychm: fix runtime
- fix missing symbol _get_leaf_node_offset which causes chm2pdf to exit - pass maintainership to submitter - bump PORTREVISION While here, limit python version to 2.x, since it doesn't build with 3.x and convert to autoplist. PR: 201351 Submitted by: Carlos Jacobo Puga Medina <cpm@fbsd.es>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/pychm/Makefile7
-rw-r--r--textproc/pychm/files/patch-chm_extra.c63
-rw-r--r--textproc/pychm/pkg-plist11
3 files changed, 67 insertions, 14 deletions
diff --git a/textproc/pychm/Makefile b/textproc/pychm/Makefile
index d34c8a544346..4222065081e4 100644
--- a/textproc/pychm/Makefile
+++ b/textproc/pychm/Makefile
@@ -3,10 +3,11 @@
PORTNAME= pychm
PORTVERSION= 0.8.4
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= SF/gnochm/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cpm@fbsd.es
COMMENT= Bindings for CHMLIB library
LICENSE= GPLv2 # or later
@@ -15,8 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libchm.so:${PORTSDIR}/misc/chmlib
NO_BUILD= yes
-USES= python
-USE_PYTHON= distutils
+USES= python:2
+USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
diff --git a/textproc/pychm/files/patch-chm_extra.c b/textproc/pychm/files/patch-chm_extra.c
new file mode 100644
index 000000000000..bcbbd2596690
--- /dev/null
+++ b/textproc/pychm/files/patch-chm_extra.c
@@ -0,0 +1,63 @@
+--- chm/extra.c.orig 2015-07-05 03:15:19 UTC
++++ chm/extra.c
+@@ -70,13 +70,13 @@
+
+ #define FREE(x) free (x); x = NULL
+
+-inline uint16_t
++uint16_t
+ get_uint16 (uint8_t* b) {
+ return b[0] |
+ b[1]<<8;
+ }
+
+-inline uint32_t
++uint32_t
+ get_uint32 (uint8_t* b) {
+ return b[0] |
+ b[1]<<8 |
+@@ -84,7 +84,7 @@ get_uint32 (uint8_t* b) {
+ b[3]<<24;
+ }
+
+-inline uint64_t
++uint64_t
+ get_uint64 (uint8_t* b) {
+ return b[0] |
+ b[1]<<8 |
+@@ -117,7 +117,7 @@ be_encint (unsigned char *buffer, size_t
+ Finds the first unset bit in memory. Returns the number of set bits found.
+ Returns -1 if the buffer runs out before we find an unset bit.
+ */
+-inline int
++int
+ ffus (unsigned char* byte, int* bit, size_t *length) {
+ int bits = 0;
+ *length = 0;
+@@ -144,7 +144,7 @@ ffus (unsigned char* byte, int* bit, siz
+ }
+
+
+-inline uint64_t
++uint64_t
+ sr_int(unsigned char* byte, int* bit,
+ unsigned char s, unsigned char r, size_t *length)
+ {
+@@ -221,7 +221,7 @@ sr_int(unsigned char* byte, int* bit,
+ }
+
+
+-inline uint32_t
++uint32_t
+ get_leaf_node_offset(struct chmFile *chmfile,
+ const char *text,
+ uint32_t initial_offset,
+@@ -294,7 +294,7 @@ get_leaf_node_offset(struct chmFile *chm
+ return initial_offset;
+ }
+
+-inline int
++int
+ pychm_process_wlc (struct chmFile *chmfile,
+ uint64_t wlc_count, uint64_t wlc_size,
+ uint32_t wlc_offset, unsigned char ds,
diff --git a/textproc/pychm/pkg-plist b/textproc/pychm/pkg-plist
deleted file mode 100644
index 18063075c424..000000000000
--- a/textproc/pychm/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-%%PYTHON_SITELIBDIR%%/chm/__init__.py
-%%PYTHON_SITELIBDIR%%/chm/__init__.pyc
-%%PYTHON_SITELIBDIR%%/chm/__init__.pyo
-%%PYTHON_SITELIBDIR%%/chm/_chmlib.so
-%%PYTHON_SITELIBDIR%%/chm/chm.py
-%%PYTHON_SITELIBDIR%%/chm/chm.pyc
-%%PYTHON_SITELIBDIR%%/chm/chm.pyo
-%%PYTHON_SITELIBDIR%%/chm/chmlib.py
-%%PYTHON_SITELIBDIR%%/chm/chmlib.pyc
-%%PYTHON_SITELIBDIR%%/chm/chmlib.pyo
-%%PYTHON_SITELIBDIR%%/chm/extra.so