aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /textproc
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'textproc')
-rw-r--r--textproc/kbedic/Makefile12
-rw-r--r--textproc/nicetext/Makefile12
-rw-r--r--textproc/word2x/Makefile10
-rw-r--r--textproc/xmlpp/Makefile10
-rw-r--r--textproc/xxdiff/Makefile12
5 files changed, 28 insertions, 28 deletions
diff --git a/textproc/kbedic/Makefile b/textproc/kbedic/Makefile
index 0a542c257bed..de35b2183f95 100644
--- a/textproc/kbedic/Makefile
+++ b/textproc/kbedic/Makefile
@@ -16,12 +16,6 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= todorov@freebsd-bg.org
COMMENT= An English-to-Bulgarian and Bulgarian-to-English dictionary
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
RUN_DEPENDS= ${DICT_DIR}/${DICT_CHECK}:${PORTSDIR}/textproc/bedic-data
DICT_CHECK?= buleng.dat
@@ -39,6 +33,12 @@ CONFIGURE_ARGS+= --with-x
PLIST= ${PKGDIR}/pkg-plist.console
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
pre-fetch:
@${ECHO_MSG} " --- Dictionaries setup information ---"
@${ECHO_MSG} "This port uses dictionaries provided by the textproc/bedic-data port."
diff --git a/textproc/nicetext/Makefile b/textproc/nicetext/Makefile
index 69252ff8ff27..e07cde7fba89 100644
--- a/textproc/nicetext/Makefile
+++ b/textproc/nicetext/Makefile
@@ -13,12 +13,6 @@ MASTER_SITES= ftp://ctgi.net/pub/ctgi/nicetext/src/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert files to pseudo-natural-language text and back again
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_GMAKE= YES
MAKE_FLAGS= CXXFLAGS="${CXXFLAGS} -pedantic" CFLAGS="${CFLAGS} -pedantic"
@@ -29,6 +23,12 @@ PROGRAMS= bitcp dct2mstr expgram genmodel gramtest impkimmo impmsc \
impwbstr listword nicetext nttpd printint rinfo scramble \
sortdct txt2dct
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-install:
@${ECHO_CMD} "#!/bin/sh" > ${WRKSRC}/bin/qstart-nttpd
@${ECHO_CMD} ${PREFIX}/bin/"nttpd -b " ${PREFIX}/share/examples/nicetext/database >> ${WRKSRC}/bin/qstart-nttpd
diff --git a/textproc/word2x/Makefile b/textproc/word2x/Makefile
index da2cca048860..7c6e09b446b9 100644
--- a/textproc/word2x/Makefile
+++ b/textproc/word2x/Makefile
@@ -14,15 +14,15 @@ MASTER_SITE_SUBDIR= word2x
MAINTAINER= billf@FreeBSD.org
COMMENT= Converter from MS Word to text, HTML or LaTeX
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+MAN1= word2x.1
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
-MAN1= word2x.1
-
.include <bsd.port.post.mk>
diff --git a/textproc/xmlpp/Makefile b/textproc/xmlpp/Makefile
index ae244172a009..88749dfe382b 100644
--- a/textproc/xmlpp/Makefile
+++ b/textproc/xmlpp/Makefile
@@ -14,17 +14,17 @@ MASTER_SITES= http://www.root.at/download/gpl/
MAINTAINER= ports@FreeBSD.org
COMMENT= XML Parser and Validator
+USE_REINPLACE= yes
+FETCH_CMD= /usr/bin/fetch
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-USE_REINPLACE= yes
-FETCH_CMD= /usr/bin/fetch
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-
pre-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|/usr/local/share|$$(datadir)|g'
diff --git a/textproc/xxdiff/Makefile b/textproc/xxdiff/Makefile
index 02a01f8b37d5..5d6ea2e99949 100644
--- a/textproc/xxdiff/Makefile
+++ b/textproc/xxdiff/Makefile
@@ -22,12 +22,6 @@ COMMENT= QT interface to view/merge differences between 2 or 3 files
BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_BISON= yes
USE_GMAKE= yes
USE_QT_VER= 2
@@ -35,6 +29,12 @@ TMAKEENV= TMAKEPATH=${LOCALBASE}/share/tmake/freebsd-g++ QTDIR=${X11BASE}
MAKE_ENV+= QTDIR=${X11BASE} PTHREAD_LIBS=${PTHREAD_LIBS}
WRKSRC= ${WRKDIR}/xxdiff-${PORTVERSION}/src
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-build:
(cd ${WRKSRC}; ${SETENV} ${TMAKEENV} tmake -o Makefile xxdiff.pro)
(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \