aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsimokawa <simokawa@FreeBSD.org>1999-01-23 22:28:28 +0800
committersimokawa <simokawa@FreeBSD.org>1999-01-23 22:28:28 +0800
commit03e64bbe930d451acfe187a3f65a503a72bb6a69 (patch)
tree5d14b0b1226fb7b3f626ffff77beafa6a5c23ff5 /textproc
parent19c57c41e3cc5477d5b7e438a96110b863e5013b (diff)
downloadfreebsd-ports-gnome-03e64bbe930d451acfe187a3f65a503a72bb6a69.tar.gz
freebsd-ports-gnome-03e64bbe930d451acfe187a3f65a503a72bb6a69.tar.zst
freebsd-ports-gnome-03e64bbe930d451acfe187a3f65a503a72bb6a69.zip
Add fix for Alpha.
- patch for configure, unexelf.c, alpha.h, PLIST and etc.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/coco/Makefile7
-rw-r--r--textproc/coco/files/patch-ac17
-rw-r--r--textproc/coco/files/patch-af13
-rw-r--r--textproc/coco/files/patch-ag34
-rw-r--r--textproc/coco/files/patch-ah54
-rw-r--r--textproc/coco/files/patch-mn11
-rw-r--r--textproc/coco/pkg-plist24
7 files changed, 139 insertions, 21 deletions
diff --git a/textproc/coco/Makefile b/textproc/coco/Makefile
index ce146b0e586e..51d07146a87f 100644
--- a/textproc/coco/Makefile
+++ b/textproc/coco/Makefile
@@ -3,7 +3,7 @@
# Date created: 7 July 1997
# Whom: Satoshi Taoka <taoka@infonets.hiroshima-u.ac.jp>
#
-# $Id: Makefile,v 1.34 1998/10/21 09:58:29 asami Exp $
+# $Id: Makefile,v 1.35 1998/12/02 07:57:11 asami Exp $
#
DISTNAME= mule-2.3
@@ -58,14 +58,15 @@ BROKEN= You should build install one of the other mule ports first
INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
PACKAGE_COOKIE= ${WRKDIR}/.package_done-${PKGNAME}
TMPPLIST= ${WRKDIR}/.PLIST.mktmp-${PKGNAME}
-PLIST_SUB= EMACS_VERSION=19.34
+EMACS_ARCH= ${MACHINE_ARCH}--freebsd
+PLIST_SUB= EMACS_VERSION=19.34 EMACS_ARCH=${EMACS_ARCH}
USE_XLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
EMACS_PREFIX= mule
EMACS_EXECUTABLE = mule
-CONFIGURE_ARGS= i386--freebsd --with-executable=${EMACS_EXECUTABLE} \
+CONFIGURE_ARGS= ${EMACS_ARCH} --with-executable=${EMACS_EXECUTABLE} \
--with-emacs-prefix=${EMACS_PREFIX} \
--with-terminal-face \
--x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib
diff --git a/textproc/coco/files/patch-ac b/textproc/coco/files/patch-ac
index 32937f709d3f..264e517b385f 100644
--- a/textproc/coco/files/patch-ac
+++ b/textproc/coco/files/patch-ac
@@ -1,5 +1,5 @@
---- orig/s/freebsd.h Mon Jun 10 05:14:32 1996
-+++ src/s/freebsd.h Tue Sep 29 11:35:32 1998
+--- src/s/freebsd.h.orig Mon Jun 10 05:14:32 1996
++++ src/s/freebsd.h Sat Jan 16 22:17:58 1999
@@ -1,5 +1,15 @@
/* s/ file for freebsd system. */
@@ -24,16 +24,21 @@
#define SYSV_SYSTEM_DIR
-@@ -42,12 +51,28 @@
+@@ -42,12 +51,33 @@
#undef BSD_PGRPS
#define GETPGRP_NO_ARG
+#ifdef __ELF__
+
+#define LD_SWITCH_SYSTEM
++#ifdef i386
+#define START_FILES pre-crt0.o /usr/lib/crt1.o /usr/lib/crti.o /usr/lib/crtbegin.o
-+#define UNEXEC unexelf.o
+#define LIB_STANDARD -lgcc -lc -lgcc /usr/lib/crtend.o /usr/lib/crtn.o
++#else
++#define START_FILES pre-crt0.o /usr/lib/crt1.o /usr/lib/crtbegin.o
++#define LIB_STANDARD -lgcc -lc -lgcc /usr/lib/crtend.o
++#endif
++#define UNEXEC unexelf.o
+#undef LIB_GCC
+#define LIB_GCC
+
@@ -54,7 +59,7 @@
#ifndef N_TRELOFF
#define N_PAGSIZ(x) __LDPGSZ
-@@ -63,6 +88,8 @@
+@@ -63,6 +93,8 @@
#endif /* __FreeBSD__ */
#endif /* NO_SHARED_LIBS */
@@ -63,7 +68,7 @@
#define HAVE_WAIT_HEADER
#define HAVE_GETLOADAVG
/*#define HAVE_GETPAGESIZE /* configure now puts this in config.h */
-@@ -80,6 +107,8 @@
+@@ -80,6 +112,8 @@
#define BSD 199103
#elif __FreeBSD__ == 2
#define BSD 199306
diff --git a/textproc/coco/files/patch-af b/textproc/coco/files/patch-af
new file mode 100644
index 000000000000..23092a4a8ca0
--- /dev/null
+++ b/textproc/coco/files/patch-af
@@ -0,0 +1,13 @@
+--- configure.orig Tue Aug 20 13:11:26 1996
++++ configure Sat Jan 16 23:18:54 1999
+@@ -756,6 +756,10 @@
+ machine=alpha opsys=gnu-linux
+ ;;
+
++ alpha-*-freebsd* )
++ machine=alpha opsys=freebsd
++ ;;
++
+ ## Altos 3068
+ m68*-altos-sysv* )
+ machine=altos opsys=usg5-2
diff --git a/textproc/coco/files/patch-ag b/textproc/coco/files/patch-ag
new file mode 100644
index 000000000000..a556bd24f5eb
--- /dev/null
+++ b/textproc/coco/files/patch-ag
@@ -0,0 +1,34 @@
+--- src/m/alpha.h.orig Sat Aug 10 07:03:36 1996
++++ src/m/alpha.h Sat Jan 16 22:34:10 1999
+@@ -234,7 +234,11 @@
+
+ #ifndef NOT_C_CODE
+ /* We need these because pointers are larger than the default ints. */
++#if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
+ #include <alloca.h>
++#else
++#include <stdlib.h>
++#endif
+
+ /* Hack alert! For reasons unknown to mankind the string.h file insists
+ on defining bcopy etc. as taking char pointers as arguments. With
+@@ -299,10 +303,18 @@
+ termio and struct termios are mutually incompatible. */
+ #define NO_TERMIO
+
+-#ifdef LINUX
++#if defined(LINUX) || \
++ defined(__FreeBSD__) || defined (__NetBSD__) || defined (__OpenBSD__)
+ # define TEXT_END ({ extern int _etext; &_etext; })
+ # ifndef __ELF__
+ # define COFF
+ # define DATA_END ({ extern int _EDATA; &_EDATA; })
+ # endif /* notdef __ELF__ */
+ #endif
++
++#if (defined (__FreeBSD__) || defined (__NetBSD__) || defined (__OpenBSD__)) \
++ && defined (__ELF__)
++#define HAVE_TEXT_START
++#endif
++
++
diff --git a/textproc/coco/files/patch-ah b/textproc/coco/files/patch-ah
new file mode 100644
index 000000000000..3f990e4b5970
--- /dev/null
+++ b/textproc/coco/files/patch-ah
@@ -0,0 +1,54 @@
+--- src/unexelf1.c.orig Sat Aug 10 06:56:52 1996
++++ src/unexelf1.c Sun Jan 17 00:28:21 1999
+@@ -423,12 +423,50 @@
+ #include <elf.h>
+ #include <sys/mman.h>
+
+-#ifdef __alpha__
++#if defined(__alpha__) && defined(__osf__)
+ # include <sym.h> /* get COFF debugging symbol table declaration */
++#else if defined(__alpha__)
++typedef struct {
++ short magic;
++ short vstamp;
++ int ilineMax;
++ int idnMax;
++ int ipdMax;
++ int isymMax;
++ int ioptMax;
++ int iauxMax;
++ int issMax;
++ int issExtMax;
++ int ifdMax;
++ int crfd;
++ int iextMax;
++ long cbLine;
++ long cbLineOffset;
++ long cbDnOffset;
++ long cbPdOffset;
++ long cbSymOffset;
++ long cbOptOffset;
++ long cbAuxOffset;
++ long cbSsOffset;
++ long cbSsExtOffset;
++ long cbFdOffset;
++ long cbRfdOffset;
++ long cbExtOffset;
++} HDRR, *pHDRR;
++#define cbHDRR sizeof(HDRR)
++#define hdrNil ((pHDRR)0)
+ #endif
+
+ #if __GNU_LIBRARY__ - 0 >= 6
+ # include <link.h> /* get ElfW etc */
++#endif
++
++#ifdef __FreeBSD__
++# ifdef __STDC__
++# define ElfW(type) Elf_##type
++# else
++# define ElfW(type) Elf_/**/type
++# endif
+ #endif
+
+ #ifndef ElfW
diff --git a/textproc/coco/files/patch-mn b/textproc/coco/files/patch-mn
new file mode 100644
index 000000000000..2ac99a2b4caa
--- /dev/null
+++ b/textproc/coco/files/patch-mn
@@ -0,0 +1,11 @@
+--- src/coding.c.orig Sun Jan 17 04:48:45 1999
++++ src/coding.c Sun Jan 17 04:49:02 1999
+@@ -154,7 +154,7 @@
+ /* 92.4.3, 92.12.18 by K.Handa */
+ Lisp_Object Qcoding_system, Qcoding_system_p, Qnon_nil_coding_system_p;
+ Lisp_Object Qeol_type;
+-Lisp_Object Qpriority;
++extern Lisp_Object Qpriority;
+ /* end of patch */
+ #endif /* emacs */
+
diff --git a/textproc/coco/pkg-plist b/textproc/coco/pkg-plist
index ec16183eda67..5d9c87dc6ada 100644
--- a/textproc/coco/pkg-plist
+++ b/textproc/coco/pkg-plist
@@ -153,18 +153,18 @@ info/terminology
@exec install-info --section="The Emacs editor and associated tools" --entry="* Canna-jp: (canna-jp). Another Japanese Inputting Method. (Japanese)" %D/info/canna-jp %D/info/dir
@comment
@exec [ -f %D/share/mule/%%EMACS_VERSION%%/info/dir ] || mkdir -p %D/share/mule/%%EMACS_VERSION%%/info; sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/share/mule/%%EMACS_VERSION%%/info/dir
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/cvtmail
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/digest-doc
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/emacsserver
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/fakemail
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/hexl
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/movemail
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/profile
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/rcs2log
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/sorted-doc
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/vcdiff
-libexec/mule/%%EMACS_VERSION%%/i386--freebsd/yow
-@dirrm libexec/mule/%%EMACS_VERSION%%/i386--freebsd
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/cvtmail
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/digest-doc
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/emacsserver
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/fakemail
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/hexl
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/movemail
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/profile
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/rcs2log
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/sorted-doc
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/vcdiff
+libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%/yow
+@dirrm libexec/mule/%%EMACS_VERSION%%/%%EMACS_ARCH%%
@dirrm libexec/mule/%%EMACS_VERSION%%
@dirrm libexec/mule
share/mule/%%EMACS_VERSION%%/etc/3B-MAXMEM
20&id=b0fdc88ad6a8729e15b83c8342a3edb9cec2dcb9'>- Broken Checksum mismatchmiwi2013-02-231-0/+2 * - Update to 0.6.2olivierd2013-02-153-19/+49 * - Fix build with clangmiwi2013-02-101-5/+7 * KDE/FreeBSD team presents KDE SC 4.9.5 ports!makc2013-02-044-12/+5 * - add comment for imake problem with clangdinoex2013-01-261-5/+3 * Remove the created by me and update those header at the same time. I nevermezz2013-01-011-5/+0 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-301-0/+3 * 2012-11-27 devel/p5-SPOPS: Depend on the expired p5-Class-Fieldsbapt2012-11-284-38/+0 * - Update to 2.2.2madpilot2012-11-278-80/+491 * Deprecate a bunch of ports that are either abandonware and/or for which no morebapt2012-10-261-5/+4 * 2012-10-20 x11-themes/metacity-ana-theme: No more public distfilesbapt2012-10-265-54/+0 * Update to 2.37wxs2012-10-172-3/+3 * Force numerous ports that fail to build with clang over to instead alwayslinimon2012-10-101-0/+1 * - Reassign to the heap due to mail bouncestabthorpe2012-09-301-6/+2 * - Update to 1.0.0olivierd2012-09-253-7/+8 * Deprecate a bunch a ports with no more public distfiles (thanks ehaupt's dist...bapt2012-09-211-0/+3 * - Update MAINTAINER to my new FreeBSD.org addressjhale2012-09-132-2/+2 * - reset maintainership per maintainerjgh2012-09-071-4/+6 * Mark ports unsafe per wiki page of broken ports.eadler2012-09-031-0/+2 * - Reassign nork@ ports to the heaptabthorpe2012-08-161-1/+1 * Switch from libglut to freeglut and retire libglut. Libglut hasn't beenkwm2012-08-051-1/+1 * Fix typos in COMMENTcs2012-07-291-1/+1 * new devel/pkgconf added to replace devel/pkg-config. new version of pkg-configbapt2012-07-261-1/+1 * For the ports that are maintained by ports@ that have pkgconfig as theirdougb2012-07-231-1/+1 * - reset MAINTAINERdinoex2012-06-261-1/+1 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-153-5/+4 * Add missing dependseadler2012-06-091-1/+2 * - Convert USE_QT_VER=4 and QT_COMPONETS to USE_QT4miwi2012-06-064-8/+4 * - Update to version 0.4.9.2sylvio2012-06-064-32/+24 * - update png to 1.5.10dinoex2012-06-0120-16/+20 * - Update to 1.0.1miwi2012-05-263-9/+16 * - Bump all XFCE after XFCE importmiwi2012-05-262-1/+2 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-257-4/+49 * Update to 2.36wxs2012-04-242-3/+3 * Update to 3.1makc2012-02-223-4/+5 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-164-2/+4 * Update to 1.0.3eadler2012-02-112-4/+4 * Update to 1.0.6eadler2012-02-112-3/+3 * Update to 0.6.4rene2012-02-093-3/+5 * The KDE/FreeBSD team is pleased to announce KDE SC 4.7.4, whichavilla2012-01-251-2/+2 * Update to 0.6.3rene2012-01-083-3/+9 * - update to 2.8rm2012-01-062-8/+5 * - X11BASE is going away. Hack the last few ports that depend on X11BASE to no...eadler2011-12-262-1/+2 * - update to 1.0.5eadler2011-11-233-15/+3 * The KDE on FreeBSD team is pleased to update the KDE4 ports to 4.7.3.rakuco2011-11-141-2/+2 * Consistify spelling of "Xfce", and some other projects while there.rene2011-10-274-4/+4 * The vast majority of pkg-descr files had the following format when theydougb2011-10-243-4/+2 * Remove more tags from pkg-descr files fo the form:dougb2011-10-247-19/+0 * Re-assign to the Xfce team.rene2011-10-233-3/+3 * - update to 0.4.0dinoex2011-10-214-6/+30 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-172-5/+7 * - remove uneeded oaf dependencybapt2011-10-061-2/+2 * Fix build error with clang.vanilla2011-09-281-0/+11 * When not -D BATCH mark IS_INTERACTIVE, make imake dependency unconditionaldougb2011-09-251-6/+7 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-243-4/+3 * - update mkfontscale to 1.0.9eadler2011-09-182-4/+3 * Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where ...kwm2011-08-242-1/+13 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-124-4/+4 * - drop MASTER_SITE_GNUSTEP_CHdinoex2011-08-091-2/+1 * - add new WWWdinoex2011-08-071-0/+1 * - update WWWdinoex2011-08-071-1/+1 * Update broken/outdated WWW entries. Remove those where no alternate source wasehaupt2011-08-051-2/+0 * Remove WWW entries from unmaintained ports that return 404 or where the domainehaupt2011-08-031-2/+0 * Fix master_sitebapt2011-08-032-2/+2 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-081-1/+1 * Update KDE Software Compilation ports to 4.6.5makc2011-07-081-2/+2 * - - Fix MASTER_SITES & Cleanupmiwi2011-07-021-5/+3 * Fixes build with clangjlaffaye2011-06-291-2/+11 * - Update to 0.6.2miwi2011-06-253-5/+16 * Mark broken some ports with unfetchable distfilesbapt2011-06-171-0/+2