aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-28 20:02:27 +0800
committerbapt <bapt@FreeBSD.org>2014-01-28 20:02:27 +0800
commit47bd091a48228f9a325021d4058005c47224e0fc (patch)
treeb2ffcee9b3194f59429342c7239733f26fd8580a /textproc
parentcb42af37c88a00969bc78afa8954ff6c27f2a6b3 (diff)
downloadfreebsd-ports-gnome-47bd091a48228f9a325021d4058005c47224e0fc.tar.gz
freebsd-ports-gnome-47bd091a48228f9a325021d4058005c47224e0fc.tar.zst
freebsd-ports-gnome-47bd091a48228f9a325021d4058005c47224e0fc.zip
Extract the ispell wrapper out of aspell into a dedicated port
Cleanup up the aspell port Propertly strip aspell libraries Use short form of MASTER_SITES
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/aspell-ispell/Makefile29
-rw-r--r--textproc/aspell-ispell/distinfo2
-rw-r--r--textproc/aspell-ispell/pkg-descr3
-rw-r--r--textproc/aspell/Makefile26
-rw-r--r--textproc/aspell/pkg-plist4
6 files changed, 43 insertions, 22 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 92b81745205e..6671fb2ada42 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -31,6 +31,7 @@
SUBDIR += asciidoc
SUBDIR += asm-xml
SUBDIR += aspell
+ SUBDIR += aspell-ispell
SUBDIR += ast-aspell
SUBDIR += atom
SUBDIR += ats-contrib-parcomb
diff --git a/textproc/aspell-ispell/Makefile b/textproc/aspell-ispell/Makefile
new file mode 100644
index 000000000000..b6a4e1ad374e
--- /dev/null
+++ b/textproc/aspell-ispell/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= aspell
+PORTVERSION= 0.60.6.1
+CATEGORIES= textproc
+MASTER_SITES= GNU/aspell
+PKGNAMESUFFIX= -ispell
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Ispell compatibility script for aspell
+
+LICENSE= LGPL21
+
+CONFLICTS+= ispell* ??-ispell*
+
+RUN_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+
+NO_BUILD= yes
+PLIST_FILES= bin/ispell \
+ bin/spell
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/^#CHECK/CHECK/g" ${WRKSRC}/scripts/ispell
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/ispell ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/spell ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/aspell-ispell/distinfo b/textproc/aspell-ispell/distinfo
new file mode 100644
index 000000000000..b5efc8eadad3
--- /dev/null
+++ b/textproc/aspell-ispell/distinfo
@@ -0,0 +1,2 @@
+SHA256 (aspell-0.60.6.1.tar.gz) = f52583a83a63633701c5f71db3dc40aab87b7f76b29723aeb27941eff42df6e1
+SIZE (aspell-0.60.6.1.tar.gz) = 1878163
diff --git a/textproc/aspell-ispell/pkg-descr b/textproc/aspell-ispell/pkg-descr
new file mode 100644
index 000000000000..d4b2664063f0
--- /dev/null
+++ b/textproc/aspell-ispell/pkg-descr
@@ -0,0 +1,3 @@
+Command line wrapper for aspell, behaving like ispell
+
+WWW: http://aspell.sourceforge.net/
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 549fdf941d6f..ab3e9a7467c2 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -3,21 +3,18 @@
PORTNAME= aspell
PORTVERSION= 0.60.6.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= aspell
+MASTER_SITES= GNU/aspell
MAINTAINER= office@FreeBSD.org
COMMENT= Spelling checker with better suggestion logic than ispell
LICENSE= LGPL21
-OPTIONS_DEFINE= NLS DOCS ISPELL
+OPTIONS_DEFINE= NLS DOCS
OPTIONS_SUB= yes
-ISPELL_DESC= Install the ispell wrapper
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-docdir=${DOCSDIR} \
@@ -28,6 +25,7 @@ USES= gmake iconv perl5 shebangfix
USE_LDCONFIG= yes
SHEBANG_FILES= scripts/aspell-import
+INSTALL_TARGET= install-strip
VERINST= ${PORTVERSION:R:R}
SUB_FILES= aspell.ver
PLIST_SUB= VER=${VERINST}
@@ -35,28 +33,16 @@ SUB_LIST= VERINST=${VERINST}
INFO= aspell-dev aspell
NLS_USES= gettext
-NLS_CONFIGURE_ARGS= --disable-nls
+NLS_CONFIGURE_ENABLE= nls
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MISPELL}
-CONFLICTS+= ispell* ??-ispell*
-SCRIPTS= ispell spell
-.endif
-
# Does not link without at least -O
.if !defined(CFLAGS) || ${CFLAGS:M-O*} == ""
CFLAGS+= -O
.endif
-post-install: ${DICT_TARGET}
+post-install:
@${INSTALL_DATA} ${WRKDIR}/aspell.ver ${STAGEDIR}${PREFIX}/etc
-.if ${PORT_OPTIONS:MISPELL}
- @${INSTALL_SCRIPT} ${SCRIPTS:S|^|${WRKSRC}/scripts/|} ${STAGEDIR}${PREFIX}/bin
-.endif
- @${ECHO_CMD} "@dirrm share/aspell" >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm lib/aspell-${VERINST}" >> ${TMPPLIST}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libaspell.so.16 \
- ${STAGEDIR}${PREFIX}/lib/libpspell.so.16
.include <bsd.port.mk>
diff --git a/textproc/aspell/pkg-plist b/textproc/aspell/pkg-plist
index 61382a76d97c..25af7a89040b 100644
--- a/textproc/aspell/pkg-plist
+++ b/textproc/aspell/pkg-plist
@@ -1,13 +1,11 @@
bin/aspell
bin/aspell-import
-%%ISPELL%%bin/ispell
bin/precat
bin/preunzip
bin/prezip
bin/prezip-bin
bin/pspell-config
bin/run-with-aspell
-%%ISPELL%%bin/spell
bin/word-list-compress
etc/aspell.ver
include/aspell.h
@@ -133,3 +131,5 @@ man/man1/word-list-compress.1.gz
%%NLS%%@dirrmtry share/locale/fi
%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ast
+@dirrmtry %%DATADIR%%
+@dirrm lib/aspell-%%VER%%