aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2015-02-17 05:16:34 +0800
committernivit <nivit@FreeBSD.org>2015-02-17 05:16:34 +0800
commit722ccf9ddb6607c02e67d84f3ccccdf17d7c224d (patch)
treeff3a0e7e3c59cb82e31c4a2f2627164dafea0cbe /textproc
parenta794ae6e1fa9278f04eadb7835fb7abeab873b23 (diff)
downloadfreebsd-ports-gnome-722ccf9ddb6607c02e67d84f3ccccdf17d7c224d.tar.gz
freebsd-ports-gnome-722ccf9ddb6607c02e67d84f3ccccdf17d7c224d.tar.zst
freebsd-ports-gnome-722ccf9ddb6607c02e67d84f3ccccdf17d7c224d.zip
- Update to 2.1.0
- Add LICENSE (GPLv2) - Restrict Python version to 2 - Sort variables and their values - Remove files/patch-etc-ecmds.conf - Add patch/patch-lib_ecmds_configreader.py - Remove Author: line and fix blank after WWW: in pkg-descr - Use @sample macro in pkg-plist
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ecromedos/Makefile57
-rw-r--r--textproc/ecromedos/distinfo4
-rw-r--r--textproc/ecromedos/files/patch-etc-ecmds.conf38
-rw-r--r--textproc/ecromedos/files/patch-lib_ecmds_configreader.py24
-rw-r--r--textproc/ecromedos/pkg-descr3
-rw-r--r--textproc/ecromedos/pkg-plist213
6 files changed, 94 insertions, 245 deletions
diff --git a/textproc/ecromedos/Makefile b/textproc/ecromedos/Makefile
index 74dfde5fd846..7486eb449845 100644
--- a/textproc/ecromedos/Makefile
+++ b/textproc/ecromedos/Makefile
@@ -2,45 +2,46 @@
# $FreeBSD$
PORTNAME= ecromedos
-PORTVERSION= 1.0.1
-PORTREVISION= 5
+PORTVERSION= 2.1.0
+PORTREVISION= 0
CATEGORIES= textproc print www
-MASTER_SITES= http://www.ecromedos.net/files/${PORTVERSION}/
+MASTER_SITES= http://www.ecromedos.net/files/src/${PORTVERSION}/
MAINTAINER= nivit@FreeBSD.org
COMMENT= Document preparation system that allows concurrent publication
-RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
- ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
- ${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt
+LICENSE= GPLv2
-NO_BUILD= yes
-USES= python
-USE_TEX= latex
-USE_GNOME= libxml2 libxslt
-
-OPTIONS_DEFINE= DOCS
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
+ ${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt \
+ convert:${PORTSDIR}/graphics/ImageMagick \
+ pygmentize:${PORTSDIR}/textproc/py-pygments
-PORTDOCS= *
+NO_BUILD= yes
-ECMDS_CONF= ${WRKSRC}/etc/ecmds.conf
-ECROMEDOC= ${DATADIR}/doc
-ECROMEBIN= ${DATADIR}/bin/${PORTNAME}
+USES= python:2
+USE_GNOME= libxml2 libxslt
+USE_TEX= latex
post-patch:
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- -e 's|%%DATADIR%%|${DATADIR}|g' ${ECMDS_CONF}
+ @(cd ${WRKSRC} && \
+ ${REINPLACE_CMD} \
+ -e 's|^\#!${SETENV} python|&2|1' \
+ -e 's|[^!]/usr/bin|${LOCALBASE}/bin|g' \
+ -e 's|%%ETCDIR%%|${ETCDIR}|g' \
+ bin/${PORTNAME} etc/ecmds.conf lib/ecmds/configreader.py)
do-install:
- @${MKDIR} ${STAGEDIR}${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} "-not ( -name "*.orig" -or -name "*.bak" )"
- ${RM} -f ${STAGEDIR}${ECROMEBIN}
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${ECROMEBIN}
- ${LN} -s ${ECROMEBIN} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- ${LN} -s ${ECROMEBIN} ${STAGEDIR}${PREFIX}/bin/ecmds
- ${MV} ${STAGEDIR}${DATADIR}/etc/ecmds.conf ${STAGEDIR}${DATADIR}/etc/ecmds.conf.sample
- ${MV} ${STAGEDIR}${DATADIR}/etc/plugins.conf ${STAGEDIR}${DATADIR}/etc/plugins.conf.sample
- ${MV} ${STAGEDIR}${ECROMEDOC} ${STAGEDIR}${DOCSDIR}
- ${LN} -s ${DOCSDIR} ${STAGEDIR}${ECROMEDOC}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/bin
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ (cd ${WRKSRC} ; \
+ ${COPYTREE_SHARE} "data lib transform" ${STAGEDIR}${DATADIR} \
+ "-not ( -name "*.orig" -or -name "*.bak" )" ; \
+ ${INSTALL_DATA} etc/ecmds.conf ${STAGEDIR}${ETCDIR}/ecmds.conf.sample ; \
+ ${INSTALL_DATA} etc/plugins.conf ${STAGEDIR}${ETCDIR}/plugins.conf.sample ; \
+ ${INSTALL_SCRIPT} bin/${PORTNAME} ${STAGEDIR}${DATADIR}/bin/${PORTNAME})
+ @(cd ${STAGEDIR}${PREFIX}/bin ; \
+ ${LN} -s ../${DATADIR_REL}/bin/${PORTNAME} ecmds ; \
+ ${LN} -s ../${DATADIR_REL}/bin/${PORTNAME} ${PORTNAME})
.include <bsd.port.mk>
diff --git a/textproc/ecromedos/distinfo b/textproc/ecromedos/distinfo
index 8c678684c3e5..de7761a941a8 100644
--- a/textproc/ecromedos/distinfo
+++ b/textproc/ecromedos/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ecromedos-1.0.1.tar.gz) = 2dc388f9306a69072e01a0842fe22aaa4007f9d48d820995f7d014b490d55bcf
-SIZE (ecromedos-1.0.1.tar.gz) = 375691
+SHA256 (ecromedos-2.1.0.tar.gz) = 6b75f85feaf8cc0bb2434a313d9a53377214bebada49fed4f37e3d46579c6453
+SIZE (ecromedos-2.1.0.tar.gz) = 72374
diff --git a/textproc/ecromedos/files/patch-etc-ecmds.conf b/textproc/ecromedos/files/patch-etc-ecmds.conf
deleted file mode 100644
index ab20d2038117..000000000000
--- a/textproc/ecromedos/files/patch-etc-ecmds.conf
+++ /dev/null
@@ -1,38 +0,0 @@
---- etc/ecmds.conf Mon Apr 24 22:39:42 2006
-+++ etc/ecmds.conf.port Tue Apr 25 23:30:03 2006
-@@ -7,7 +7,7 @@
- #
- # Base installation directory
- #
--base_dir = /opt/ecromedos-1.0.1/
-+base_dir = %%DATADIR%%
-
- #
- # Library directory
-@@ -37,22 +37,22 @@
- #
- # Path to 'latex' executable
- #
--latex_bin = /usr/bin/latex
-+latex_bin = %%LOCALBASE%%/bin/latex
-
- #
- # Path to GNU 'dvipng' executable
- #
--dvipng_bin = /usr/bin/dvipng
-+dvipng_bin = %%LOCALBASE%%/bin/dvipng
-
- #
- # Path to ImageMagick's 'convert' executable
- #
--convert_bin = /usr/bin/convert
-+convert_bin = %%LOCALBASE%%/bin/convert
-
- #
- # Path to ImageMagick's 'identify' executable
- #
--identify_bin = /usr/bin/identify
-+identify_bin = %%LOCALBASE%%/bin/identify
-
- #
- # Density of dots/inch to use when converting vector formats to raster images
diff --git a/textproc/ecromedos/files/patch-lib_ecmds_configreader.py b/textproc/ecromedos/files/patch-lib_ecmds_configreader.py
new file mode 100644
index 000000000000..55e82981a934
--- /dev/null
+++ b/textproc/ecromedos/files/patch-lib_ecmds_configreader.py
@@ -0,0 +1,24 @@
+--- lib/ecmds/configreader.py.orig 2012-01-12 21:43:00 UTC
++++ lib/ecmds/configreader.py
+@@ -113,9 +113,7 @@ class ECMDSCfgFileReader:
+ try:
+ cfile = os.path.normpath(options['config_file'])
+ except KeyError:
+- syspath = os.path.normpath(sys.path[0])
+- cfile = os.sep.join(["..", "etc", "ecmds.conf"])
+- cfile = os.path.join(syspath, cfile)
++ cfile = "%%ETCDIR%%/ecmds.conf"
+ if not os.path.isfile(cfile):
+ msg = "Please specify the location of the config file."
+ raise ECMDSError(msg)
+@@ -189,9 +187,7 @@ class ECMDSPluginsMapReader:
+ try:
+ pmap = os.path.normpath(config['plugins_map'])
+ except KeyError:
+- syspath = os.path.normpath(sys.path[0])
+- pmap = os.sep.join(["..", "etc", "plugins.conf"])
+- pmap = os.path.join(syspath, pmap)
++ pmap = "%%ETCDIR%%/plugins.conf"
+ if not os.path.isfile(pmap):
+ msg = "Warning: plugins map not found."
+ sys.stderr.write(msg + "\n")
diff --git a/textproc/ecromedos/pkg-descr b/textproc/ecromedos/pkg-descr
index 03a9e6cf5335..19c61d838e50 100644
--- a/textproc/ecromedos/pkg-descr
+++ b/textproc/ecromedos/pkg-descr
@@ -8,5 +8,4 @@ supports the target formats XHTML and LATEX. Where LATEX output can be
further processed into high-quality printable formats by use of the
TEX typesetting system (http://www.ctan.org).
-Author: Tobias Koch <tkoch@ecromedos.net>
-WWW: http://www.ecromedos.net/
+WWW: http://www.ecromedos.net/
diff --git a/textproc/ecromedos/pkg-plist b/textproc/ecromedos/pkg-plist
index e7063452868e..0cc577deaf7a 100644
--- a/textproc/ecromedos/pkg-plist
+++ b/textproc/ecromedos/pkg-plist
@@ -1,187 +1,39 @@
bin/ecmds
bin/ecromedos
-%%DATADIR%%/bin/configreader.py
-%%DATADIR%%/bin/configreader.pyc
-%%DATADIR%%/bin/ecmdsproc.py
-%%DATADIR%%/bin/ecmdsproc.pyc
+@sample %%ETCDIR%%/ecmds.conf.sample
+@sample %%ETCDIR%%/plugins.conf.sample
%%DATADIR%%/bin/ecromedos
-%%DATADIR%%/bin/error.py
-%%DATADIR%%/bin/error.pyc
-%%DATADIR%%/bin/preprocessor.py
-%%DATADIR%%/bin/preprocessor.pyc
-%%DATADIR%%/bin/validator.py
-%%DATADIR%%/bin/validator.pyc
-%%DATADIR%%/bin/xslprocessor.py
-%%DATADIR%%/bin/xslprocessor.pyc
-%%DATADIR%%/data/arrow_left.svg
+%%DATADIR%%/data/arrow.svg
%%DATADIR%%/data/next.gif
-%%DATADIR%%/data/next.png
%%DATADIR%%/data/prev.gif
-%%DATADIR%%/data/prev.png
-%%DATADIR%%/data/toc.gif
-%%DATADIR%%/data/toc.png
-%%PORTDOCS%%%%DATADIR%%/doc
-@unexec if cmp -s %D/%%DATADIR%%/etc/ecmds.conf.sample %D/%%DATADIR%%/etc/ecmds.conf; then rm -f %D/%%DATADIR%%/etc/ecmds.conf; fi
-%%DATADIR%%/etc/ecmds.conf.sample
-@exec if [ ! -f %D/%%DATADIR%%/etc/ecmds.conf ] ; then cp -p %D/%F %B/ecmds.conf; fi
-@unexec if cmp -s %D/%%DATADIR%%/etc/plugins.conf.sample %D/%%DATADIR%%/etc/plugins.conf; then rm -f %D/%%DATADIR%%/etc/plugins.conf; fi
-%%DATADIR%%/etc/plugins.conf.sample
-@exec if [ ! -f %D/%%DATADIR%%/etc/plugins.conf ] ; then cp -p %D/%F %B/plugins.conf; fi
+%%DATADIR%%/data/up.gif
%%DATADIR%%/lib/__init__.py
-%%DATADIR%%/lib/hylight/__init__.py
-%%DATADIR%%/lib/hylight/__init__.pyc
-%%DATADIR%%/lib/hylight/codegenerator.py
-%%DATADIR%%/lib/hylight/codegenerator.pyc
-%%DATADIR%%/lib/hylight/ecmdsgenerator.py
-%%DATADIR%%/lib/hylight/ecmdsgenerator.pyc
-%%DATADIR%%/lib/hylight/error.py
-%%DATADIR%%/lib/hylight/error.pyc
-%%DATADIR%%/lib/hylight/langDefs/__init__.py
-%%DATADIR%%/lib/hylight/langDefs/__init__.pyc
-%%DATADIR%%/lib/hylight/langDefs/abap.py
-%%DATADIR%%/lib/hylight/langDefs/actionscript.py
-%%DATADIR%%/lib/hylight/langDefs/ada95.py
-%%DATADIR%%/lib/hylight/langDefs/agda.py
-%%DATADIR%%/lib/hylight/langDefs/ampl.py
-%%DATADIR%%/lib/hylight/langDefs/amtrix.py
-%%DATADIR%%/lib/hylight/langDefs/apache.py
-%%DATADIR%%/lib/hylight/langDefs/applescript.py
-%%DATADIR%%/lib/hylight/langDefs/arm.py
-%%DATADIR%%/lib/hylight/langDefs/asp.py
-%%DATADIR%%/lib/hylight/langDefs/aspect.py
-%%DATADIR%%/lib/hylight/langDefs/assembler.py
-%%DATADIR%%/lib/hylight/langDefs/avenue.py
-%%DATADIR%%/lib/hylight/langDefs/awk.py
-%%DATADIR%%/lib/hylight/langDefs/bat.py
-%%DATADIR%%/lib/hylight/langDefs/bibtex.py
-%%DATADIR%%/lib/hylight/langDefs/blitzbasic3d.py
-%%DATADIR%%/lib/hylight/langDefs/bmscript.py
-%%DATADIR%%/lib/hylight/langDefs/c.py
-%%DATADIR%%/lib/hylight/langDefs/c.pyc
-%%DATADIR%%/lib/hylight/langDefs/clearbasic.py
-%%DATADIR%%/lib/hylight/langDefs/clipper.py
-%%DATADIR%%/lib/hylight/langDefs/clips.py
-%%DATADIR%%/lib/hylight/langDefs/cobol.py
-%%DATADIR%%/lib/hylight/langDefs/coldfusion.py
-%%DATADIR%%/lib/hylight/langDefs/csharp.py
-%%DATADIR%%/lib/hylight/langDefs/css.py
-%%DATADIR%%/lib/hylight/langDefs/dylan.py
-%%DATADIR%%/lib/hylight/langDefs/eiffel.py
-%%DATADIR%%/lib/hylight/langDefs/erlang.py
-%%DATADIR%%/lib/hylight/langDefs/euphoria.py
-%%DATADIR%%/lib/hylight/langDefs/express.py
-%%DATADIR%%/lib/hylight/langDefs/flx.py
-%%DATADIR%%/lib/hylight/langDefs/fortran77.py
-%%DATADIR%%/lib/hylight/langDefs/fortran90.py
-%%DATADIR%%/lib/hylight/langDefs/frink.py
-%%DATADIR%%/lib/hylight/langDefs/haskell.py
-%%DATADIR%%/lib/hylight/langDefs/hecl.py
-%%DATADIR%%/lib/hylight/langDefs/icon.py
-%%DATADIR%%/lib/hylight/langDefs/idl.py
-%%DATADIR%%/lib/hylight/langDefs/informix.py
-%%DATADIR%%/lib/hylight/langDefs/ini.py
-%%DATADIR%%/lib/hylight/langDefs/inp.py
-%%DATADIR%%/lib/hylight/langDefs/io.py
-%%DATADIR%%/lib/hylight/langDefs/j.py
-%%DATADIR%%/lib/hylight/langDefs/java.py
-%%DATADIR%%/lib/hylight/langDefs/js.py
-%%DATADIR%%/lib/hylight/langDefs/mssql.py
-%%DATADIR%%/lib/hylight/langDefs/perl.py
-%%DATADIR%%/lib/hylight/langDefs/php.py
-%%DATADIR%%/lib/hylight/langDefs/python.py
-%%DATADIR%%/lib/hylight/langDefs/python.pyc
-%%DATADIR%%/lib/hylight/langDefs/sql.py
-%%DATADIR%%/lib/hylight/langDefs/xml.py
-%%DATADIR%%/lib/hylight/langDefs/xml.pyc
-%%DATADIR%%/lib/hylight/langDefs/yacc.py
-%%DATADIR%%/lib/hylight/themes/__init__.py
-%%DATADIR%%/lib/hylight/themes/__init__.pyc
-%%DATADIR%%/lib/hylight/themes/acid.py
-%%DATADIR%%/lib/hylight/themes/acid.pyc
-%%DATADIR%%/lib/hylight/themes/berries-dark.py
-%%DATADIR%%/lib/hylight/themes/berries-dark.pyc
-%%DATADIR%%/lib/hylight/themes/berries-light.py
-%%DATADIR%%/lib/hylight/themes/berries-light.pyc
-%%DATADIR%%/lib/hylight/themes/bipolar.py
-%%DATADIR%%/lib/hylight/themes/bipolar.pyc
-%%DATADIR%%/lib/hylight/themes/blacknblue.py
-%%DATADIR%%/lib/hylight/themes/bright.py
-%%DATADIR%%/lib/hylight/themes/contrast.py
-%%DATADIR%%/lib/hylight/themes/darkblue.py
-%%DATADIR%%/lib/hylight/themes/darkness.py
-%%DATADIR%%/lib/hylight/themes/desert.py
-%%DATADIR%%/lib/hylight/themes/dull.py
-%%DATADIR%%/lib/hylight/themes/easter.py
-%%DATADIR%%/lib/hylight/themes/easter.pyc
-%%DATADIR%%/lib/hylight/themes/emacs.py
-%%DATADIR%%/lib/hylight/themes/emacs.pyc
-%%DATADIR%%/lib/hylight/themes/golden.py
-%%DATADIR%%/lib/hylight/themes/golden.pyc
-%%DATADIR%%/lib/hylight/themes/greenlcd.py
-%%DATADIR%%/lib/hylight/themes/ide-anjuta.py
-%%DATADIR%%/lib/hylight/themes/ide-anjuta.pyc
-%%DATADIR%%/lib/hylight/themes/ide-codewarrior.py
-%%DATADIR%%/lib/hylight/themes/ide-codewarrior.pyc
-%%DATADIR%%/lib/hylight/themes/ide-devcpp.py
-%%DATADIR%%/lib/hylight/themes/ide-devcpp.pyc
-%%DATADIR%%/lib/hylight/themes/ide-eclipse.py
-%%DATADIR%%/lib/hylight/themes/ide-eclipse.pyc
-%%DATADIR%%/lib/hylight/themes/ide-kdev.py
-%%DATADIR%%/lib/hylight/themes/ide-msvcpp.py
-%%DATADIR%%/lib/hylight/themes/ide-msvcpp.pyc
-%%DATADIR%%/lib/hylight/themes/kwrite.py
-%%DATADIR%%/lib/hylight/themes/matlab.py
-%%DATADIR%%/lib/hylight/themes/navy.py
-%%DATADIR%%/lib/hylight/themes/navy.pyc
-%%DATADIR%%/lib/hylight/themes/nedit.py
-%%DATADIR%%/lib/hylight/themes/nedit.pyc
-%%DATADIR%%/lib/hylight/themes/neon.py
-%%DATADIR%%/lib/hylight/themes/neon.pyc
-%%DATADIR%%/lib/hylight/themes/night.py
-%%DATADIR%%/lib/hylight/themes/pablo.py
-%%DATADIR%%/lib/hylight/themes/pablo.pyc
-%%DATADIR%%/lib/hylight/themes/peachpuff.py
-%%DATADIR%%/lib/hylight/themes/peachpuff.pyc
-%%DATADIR%%/lib/hylight/themes/print.py
-%%DATADIR%%/lib/hylight/themes/print.pyc
-%%DATADIR%%/lib/hylight/themes/rand01.py
-%%DATADIR%%/lib/hylight/themes/rand01.pyc
-%%DATADIR%%/lib/hylight/themes/the.py
-%%DATADIR%%/lib/hylight/themes/the.pyc
-%%DATADIR%%/lib/hylight/themes/typical.py
-%%DATADIR%%/lib/hylight/themes/typical.pyc
-%%DATADIR%%/lib/hylight/themes/vampire.py
-%%DATADIR%%/lib/hylight/themes/vampire.pyc
-%%DATADIR%%/lib/hylight/themes/vim-dark.py
-%%DATADIR%%/lib/hylight/themes/vim.py
-%%DATADIR%%/lib/hylight/themes/whatis.py
-%%DATADIR%%/lib/hylight/themes/whitengrey.py
-%%DATADIR%%/lib/hylight/themes/zellner.py
-%%DATADIR%%/lib/hylight/themes/zellner.pyc
-%%DATADIR%%/plugins/data.py
-%%DATADIR%%/plugins/data.pyc
-%%DATADIR%%/plugins/final.py
-%%DATADIR%%/plugins/final.pyc
-%%DATADIR%%/plugins/highlight.py
-%%DATADIR%%/plugins/highlight.pyc
-%%DATADIR%%/plugins/math.py
-%%DATADIR%%/plugins/math.pyc
-%%DATADIR%%/plugins/picture.py
-%%DATADIR%%/plugins/picture.pyc
-%%DATADIR%%/plugins/strip.py
-%%DATADIR%%/plugins/strip.pyc
-%%DATADIR%%/plugins/text.py
-%%DATADIR%%/plugins/text.pyc
-%%DATADIR%%/plugins/verbatim.py
-%%DATADIR%%/plugins/verbatim.pyc
-%%DATADIR%%/transform/DTD/article.dtd
-%%DATADIR%%/transform/DTD/book.dtd
-%%DATADIR%%/transform/DTD/report.dtd
+%%DATADIR%%/lib/ecmds/__init__.py
+%%DATADIR%%/lib/ecmds/configreader.py
+%%DATADIR%%/lib/ecmds/ecmdsproc.py
+%%DATADIR%%/lib/ecmds/error.py
+%%DATADIR%%/lib/ecmds/highlight/__init__.py
+%%DATADIR%%/lib/ecmds/highlight/formatter.py
+%%DATADIR%%/lib/ecmds/preprocessor.py
+%%DATADIR%%/lib/ecmds/templates.py
+%%DATADIR%%/lib/ecmds/validator.py
+%%DATADIR%%/lib/ecmds/xslprocessor.py
+%%DATADIR%%/lib/plugins/data.py
+%%DATADIR%%/lib/plugins/final.py
+%%DATADIR%%/lib/plugins/glossary.py
+%%DATADIR%%/lib/plugins/highlight.py
+%%DATADIR%%/lib/plugins/index.py
+%%DATADIR%%/lib/plugins/math.py
+%%DATADIR%%/lib/plugins/picture.py
+%%DATADIR%%/lib/plugins/strip.py
+%%DATADIR%%/lib/plugins/table.py
+%%DATADIR%%/lib/plugins/text.py
+%%DATADIR%%/lib/plugins/verbatim.py
+%%DATADIR%%/transform/DTD/ecromedos.dtd
%%DATADIR%%/transform/i18n/english.xml
%%DATADIR%%/transform/i18n/german.xml
%%DATADIR%%/transform/i18n/i18n.xml
%%DATADIR%%/transform/i18n/i18n.xsl
-%%DATADIR%%/transform/i18n/spanish.xml
%%DATADIR%%/transform/latex/annotation.xsl
%%DATADIR%%/transform/latex/biblio.xsl
%%DATADIR%%/transform/latex/color.xsl
@@ -191,14 +43,23 @@ bin/ecromedos
%%DATADIR%%/transform/latex/entities.xsl
%%DATADIR%%/transform/latex/equation.xsl
%%DATADIR%%/transform/latex/figure.xsl
+%%DATADIR%%/transform/latex/index.xsl
%%DATADIR%%/transform/latex/latex.xsl
%%DATADIR%%/transform/latex/list.xsl
%%DATADIR%%/transform/latex/listing.xsl
+%%DATADIR%%/transform/latex/main.xsl
%%DATADIR%%/transform/latex/section.xsl
+%%DATADIR%%/transform/latex/style.xml
+%%DATADIR%%/transform/latex/style.xsl
%%DATADIR%%/transform/latex/table.xsl
%%DATADIR%%/transform/latex/text.xsl
%%DATADIR%%/transform/latex/toc.xsl
%%DATADIR%%/transform/latex/utility.xsl
+%%DATADIR%%/transform/pdflatex/ecmds.xsl
+%%DATADIR%%/transform/shared/version.xsl
+%%DATADIR%%/transform/shared/wspace.xsl
+%%DATADIR%%/transform/xelatex/ecmds.xsl
+%%DATADIR%%/transform/xelatex/entities.xml
%%DATADIR%%/transform/xhtml/annotation.xsl
%%DATADIR%%/transform/xhtml/biblio.xsl
%%DATADIR%%/transform/xhtml/color.xsl
@@ -208,12 +69,14 @@ bin/ecromedos
%%DATADIR%%/transform/xhtml/entities.xsl
%%DATADIR%%/transform/xhtml/equation.xsl
%%DATADIR%%/transform/xhtml/figure.xsl
+%%DATADIR%%/transform/xhtml/index.xsl
+%%DATADIR%%/transform/xhtml/keys.xsl
%%DATADIR%%/transform/xhtml/list.xsl
%%DATADIR%%/transform/xhtml/listing.xsl
%%DATADIR%%/transform/xhtml/section.xsl
+%%DATADIR%%/transform/xhtml/style.xml
%%DATADIR%%/transform/xhtml/table.xsl
%%DATADIR%%/transform/xhtml/text.xsl
%%DATADIR%%/transform/xhtml/toc.xsl
%%DATADIR%%/transform/xhtml/utility.xsl
%%DATADIR%%/transform/xhtml/xhtml.xsl
-@dir %%DATADIR%%/spool